View Full Version : Can't enter vent in steam room in Cozumel mission, Help!

11-26-2006, 06:49 PM
I am playing the PC version of Double Agent, and I am stuck.

I am in the steam room and I have jumped up to the ledge, used my knife to pry open the vent, and want to enter it, but I can't. No matter what position I move the character into, it will not enter the vent.

I have noticed the game has a bug (what a shock, another bug!) when you try to enter a vent from a small ledge, it seems to have this problem. I had the same problem in the prision mission when I was on a small ledge trying to enter a vent...

However, it has now been 3 days, and I am getting so damn mad at this. I am stuck, and I would like to play the game.

I have tried EVERYTHING I can think of (even replaying the entire mission). I have tried orienting Sam in every way I can and then hitting the key to get into the damn vent, but it will not work.

Does anybody have any suggestions?


11-26-2006, 06:53 PM
Try walking toward the vent while rolling the mousewheel. It seems that some speeds prevent actions like this.

11-26-2006, 07:00 PM
Thanks for the tip, but I've already tried that.

(That idea did help me with breaking into that safe in shanghai though!)

11-26-2006, 07:10 PM

You were right! Even though I had said I tried your suggestion before (and I certainly have), I kept trying it after your reply,and after about 30 tries, it FINALLY WORKED!!!!!!!!!!!!!!!!!!

Thanks a lot, for motivating me to try that again! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

11-26-2006, 10:13 PM
Yeah... whenever you run into a problem like this, remember that the controls are expecting analog joystick input... which keyboard users like us replicate with a mousewheel and directional keys. Some vents are more stubborn than others and require you to crank the mouse wheel forward more... this vent is certainly one of them.

- GoliathVT

11-27-2006, 06:36 AM
Previously in Splinter Cell there would be an icon flashing "Enter Crawlspace", but that's gone.

Personally I kinda like that, since it's annoying always to have some sort of interaction-icon placed in front of you.

In order to prevent you from entering some vent just by leaning against a wall with a vent, the developers have made it so that you can only enter the vent or other crawlspaces if you move into them while moving at max speed.

The same goes for Safe-cracking, it only works while moving at max speed.

When assembling mines, you can adjust the speed of the arm with the mousewheel too - makes it a lot easier.

Switching to a sticky cam is no longer done by pressing the 5 button like previously, instead you need to press Z once, to have the quickopsat show your current SC20K with whatever launchable is in it. When the QuickOpsat showing your SC20K fades downwards, you'll enter the sticky cam view via your Opsat.

Unfortunately they "forgot" to mention all this when they wrote the manual, but that's just how it is. Has nothing to do with SC DA being a port.

The whole deal about the QuickOpsat, that you use to get a view from whatever gadget you're using, be it a sticky cam or the cam you use to peep through doors, is, that it is the only thing that can actually show you an image from that cam. Sam has no virtual reality goggles, he uses his Opsat to acquire images from those gadgets, which is probably also the reason why the resolution is lower when looking at the Opsat - it's a fckn modded cellphone thingy http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

I bet it's to keep things as realistic as possible, while also adding new features and giving you a smoother feel and a more logical approach to moving around, using gadgets and all that great stuff.

Still they should've let you experiment a bit, while explaining what has changed, before you begin the game.