PDA

View Full Version : FPS always over 60, but camera movement jerky



Violins77
05-24-2011, 11:14 PM
Ok so I searched the whole internet about this issue but nothing seems to help. I get VERY good performance in the game, I think it was well optimized, but the camera seems to move like it's vibrating instead of being smooth. I never had this issue in AC2.

Turning Vsync on or off makes no real difference, there is always spots where is it jerky. Forcing tripple buffering make things even worse. It is really weird because it feels like the camera is moving at 20fps when everything else is rendered at 60fps.

Also, multiplayer runs flawlessly, it only happens in single player.

i5 @ 3.4Ghz
ATI HD 5870
4GB Ram

Tried admin mode, disabling 2 core, latest drivers, disabling A-V, XP compatibility mode, UAC is off, forcing Vsync from 3 different applications.

Thank you if you can give me some advices!

LFyfe
05-25-2011, 06:12 PM
I'm in exactly the same boat. I have tried every possible solution the Internet and I can come up with.

For me it seems that having Vsync off pretty much solves the issue but I can't stand the screen tearing. The jerky movement only occurs in places where the framerate would normally increase way above the display's refresh rate (when inside a tomb, looking away from the city or looking straight up at the sky etc.) Tripple buffering really improves overall performance, but noticeably increases the jerky movement in these areas.

I think the only solution for this problem is a patch from Ubisoft, something to make the game more compatible with tripple buffering or maybe an in game frame limiter.

Please help! The jerky movement is very distracting.

My specs are: (nothing overclocked)
Phenom II 965 quad 3.4ghz
Sapphire HD 5850
4gb ram
Windows 7 64bit


Thanks

Violins77
05-25-2011, 08:36 PM
@LFyfe, that's it, that is EXATCTLY the problem... The effect is worse in place where framerate would be over 60FPS... Like you said, a frame limiter would probably do the trick. You know the funny part of this, is that this jerkyness is actually happenning because the game is really really optimised well. But for me, I'll just keep playin II until there is a patch or another fix to this. Let me know if you find a solution!

LFyfe
05-26-2011, 06:23 AM
HOLY S#!% I FIXED IT!!!

The problem has something to do with Anti Aliasing. Even if you have MSAA OFF in the game, it still causes issues somehow.

Here is the fix:
Turn on 'Morphological filtering' using ATI Tray Tools...

- Now you can't just do this in Catalyst (not sure why), you need to download ATI Tray Tools
- Make a profile for ACB (using the ACBSP.exe) in the Manage Profile section.
- Tick the box for 3D to... custom settings, then click Edit.
- Under the 3D General tab you will find the Morphological filtering check box, Tick it.
As far as I can see that is the only setting you need to change (leave Anti Aliasing on 'Application Controlled' or you will get crazy graphical glitches.
Save the Profile and go into the game - no more stutter in High FPS sections!

Let me know if this doesn;t work for you and I'll see what other setting I have turned on that may have helped.

Violins77
05-26-2011, 02:29 PM
You what is funny, I think it would make sence... At one point, I think I had it running fine because I was trying to decrease FPS in the game by turning on AA in Ati Tray Tools (wich I already use instead of CCC) and I might have checked the Morphological filtering... But I had to turn it off because of the lightning glitch you mentionned...

So I think you might just be my savior here... I'll try it later when I come home from work, and if it works I'll try it with tripple buffering as well!

Thanks a lot, I'll keep you posted!

Violins77
05-26-2011, 06:56 PM
Didn't work for me... If you could take a screenshot of you ATT windows and send it to me at [email address removed] I would appreciate!

LFyfe
05-26-2011, 07:08 PM
No Worries, I'll send screens tonight when I get home from work...

Violins77
05-26-2011, 07:59 PM
Update, I had to close ther ATT box, saving is not enough... It actually makes things a lot better, but it really comes at a performance price, wich I think is why it makes things better. Now I barely reach 60 FPS, staying in the 50's... But hey, still way better than before!

LFyfe
05-26-2011, 08:38 PM
It decreases performance a little for me (I was already in the 50's anyway so I don't notice much). What setting do you have the MSAA in game? You could try turning it down a notch. I turn it off completely because it drops my FPS by 5 with each increment.

Also, make sure you turn Morphological Filtering off when you exit the game (the profile will have an option to do that automatically) as it makes some text in Windows very blurry.

Violins77
05-26-2011, 09:53 PM
MSAA is at 0 in the game... I'll wait a couple more weeks in case there is a patch but if there isn't, I guess that'll do. I just don't get why it doesn't do it in mp...

Thanks again!

Mr_Shade
05-27-2011, 05:18 AM
I have edited out your email details - remember this is a public forum, and advertisers do scan the pages for emails to send spam too..

If you want to share pictures, you can do so via Private Threads, which are private and safe http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif


remember too - that Ubisoft Support may also be able to help you in the issue - you can contact them via the links in my signature.