PDA

View Full Version : Game Crashing



Magnavox01
09-14-2010, 06:33 PM
So, just purchased this game, to play the co-op, the last co-op splinter cell was for the old xbox and it was amazing, so of course had to get this one. About 5-10 minutes into the game, my monitor goes black and turns off, tried to turn it back on, cntrl-alt-delete, alt tab, windows button, but nothing worked. Had to reboot my computer. Turned down all the graphics upon restart, changed the settings on my video card for maximum performance vs. quality. Tried again, again, 5-10 minutes in, it does the exact same thing.

My specs:
AMD Athlon II x4 620 Processor 2.6 GHZ
4 GB of ram
Windows 7 64 Bit
HD Radeon 5770

Video Card driver fully updated.
Catalyst Version 10.8

I am above the required recommendations to play the game. Browsed google and these forums looking for someone with similar problems, couldn't find much, other than to update drivers, which I did. So was wondering if anyone knows of something that I can do, that would be greatly appreciated.

Edit. Others posts about the game crashing say theirs crashes and goes right to the desktop, my problem, the game crashes my whole PC seems like. Has happened 3 times thus far, each time I had to reboot my PC.

KingDaniel0
09-14-2010, 07:47 PM
---------------------------------------------------------------------------------

Hello Magnavox01,

First of all tell me one thing that, does this Crash/System hang occur ONLY while playing SCC, or even with other PC titles and games on your computer ? Can you easily play other Games on your rig ? This could be an issue related to your System Hardware, but I can't conclude anything, as of now.

How Old is your PC (Graphics Card, RAM, Monitor etc.) ? Can you play the 'Single Player' Campaign of SCC ? And have you first tried reinstalling the whole Game again ?

Disable the setting Catalyst A.I. under ATI's CCC (TICK the 'Disable Catalyst A.I.' box), and make sure ALL the settings under the 3D section (AA, AF etc.), are set to the 'Use application settings' Option. Don't conflict any SCC in-game Video settings with ATI's Control Panel i.e. CCC.


And also check for any 'Dust' on top of the GPU's fan, as well as other PC components, and make sure there is proper ventilation inside your ATX cabinet. Are all the Cables connected properly, including the Monitor ?

Which version of the Game do you have, RETAIL or digital download ? If you have bought this game from STEAM, then you must first Verify the Integrity of the Game Cache Files:

https://support.steampowered.c...p?ref=2037-QEUH-3335 (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335)


Anyways, have you checked your Graphics Card/GPU's Temperature when this crash/hang occurs ? Make sure there is NO overheating during the Gameplay. Monitor it's TEMP using HWMonitor, or any other tool you may have:

http://www.cpuid.com/softwares/hwmonitor.html

Which brand of Power Supply/PSU are you using ? Is it sufficient for your whole PC under stress/load ? And is your problem similar to this guy: ?

http://forums.ubi.com/eve/foru...1014258/m/5751066878 (http://forums.ubi.com/eve/forums/a/tpc/f/7211014258/m/5751066878)



---------------------------------------------------------------------------------------

Magnavox01
09-14-2010, 08:09 PM
Thank you for the lengthy reply. I just purchased this PC on Thursday, arrived yesterday. So I only have a few games installed. As of now, the three crashes that have happened to me all resulted from playing SCC, within 5-10 minutes of starting it up. I have played numerous, 30 minute long games on other titles.

I'll try disabling the Catalyst A.I. setting, and try again.
As for the dust, negative, just arrived in the mail.

And I have the retail version.

I don't think the graphics card would be overheating, but definitely worth a check. DL HWMonitor from that link? Tried playing SCC earlier today, turned it on and logged on about 5 minutes after booting my PC up after it having had been off for 16 hours. Don't think it Should overheat within 10 minutes of booting up. Again, my specs are over what the game requires, but definitely worth a check to verify all options.
Not sure on what brand of the power supply is. Its a 650w, according to where I purchased it from. And I don't know how to check.

As for that thread link, I did have that problem, but I fixed it. When the computer first arrived, I had it hooked up to my HDTV, the resolution was 1900 by something, I forget. And I guess the game saved in that resolution, I had to go into some file and change my resolution manually for the game to load. But no, when SCC crashes, or my computer crashes, I have to reboot the whole thing, it doesn't just crash to the desktop.

I'll input an edit, when I check the temp / disable Catalyst A.I.
Again, thank you for the quick and lengthy reply.

EDIT:

Power Supply:
Glacial Power
GP-AL650aa

Disabled Catalyst A.I., all settings were set to 'Use Application Settings'

GPU core temp was:
37 c (98f) before game play
ranged from 40c to 64c (147f) during game play

Crash occured after about 15 minutes. (With Catalyst A.I. disabled, and all settings under 3D set to 'Use Application Settings').
Not sure what the temp was when the crash happened, I periodically alt tabbed to edit my post, the highest I Saw the temp at was 64c. 147f seems rather high, but I told my brother to download it just to compare, and his was at 188f, not doing anything intense what so ever. So I take it my video card isn't overheating?

KingDaniel0
09-15-2010, 12:45 AM
Originally posted by Magnavox01:
As of now, the three crashes that have happened to me all resulted from playing SCC, within 5-10 minutes of starting it up. I have played numerous, 30 minute long games on other titles.

This proves quite a few things to me. It looks like your game might need a reinstall, IMO. As you have already played other PC games on this current rig of yours, then obviously some SCC game files may be corrupted. Or some particular in-game Graphics/Video setting is causing the game to crash.

I didn't know you had a brand New PC, so that's why I had to ask so many things. *Just trying to leave no stone unturned*.

Anyways, you don't have to worry about anything else (Overheating, PSU etc.). It's all fine. Just try reinstalling the full game again, on some other Windows Folder, as well as 'Hard Drive' partition. But before installing, remove/delete all previous game entries, and Saved profile folders, from your drive.

Btw, does this crash occur only while playing the Co-Op Mode, or even on a 'Single Player' Campaign ?

If reinstallation doesn't fix your problem, then give me some time to rethink on this issue again. But you may post any progress from your side.

Regards,
Daniel.



--------------------------------------------------------------------------------

Magnavox01
09-15-2010, 07:43 PM
Well, I reinstalled, and so far it's working great! Still lots of lag spikes though -.-
Hah. Easy fix. Thank you.

Magnavox01
09-16-2010, 01:42 PM
Reinstalled yesterday. Was able to play 2 hours of Co-op with no crashing. Just now tried to play single player and it crashed two times, within 10 minutes.

Not sure what the problem can be this time.

New driver version came out yesterday. Dl'ed and installed. Bout' to try again.
Googled around a bit, seems alot of people said version 10.4 fixed alot of splinter cell conviction PC issues, could revert to that version and try it as well.

If you need any more information let me know. Want to play this game :/

KingDaniel0
09-16-2010, 04:21 PM
----------------------------------------------------------------------------------

Hello,

Also just make sure that you install this ATI Hotfix 10.4a driver for your card, and then check for any in-game Performance difference. My apologies, I forgot to mention this before:

http://www.atomicgamer.com/fil...dows-7-windows-vista (http://www.atomicgamer.com/files/85669/ati-catalyst-10-4a-preview-hotfix-driver-for-windows-7-windows-vista)

http://www.fileshack.com/file....ws+7+&+Windows+Vista (http://www.fileshack.com/file.x/18350/ATI+Catalyst+10.4a+Preview+Driver+-+Windows+7+&+Windows+Vista)


Hotfix Notes:


Splinter Cell Conviction - Resolves stability issues in the game when using a Windows 7 / Windows Vista / Windows XP based system with an:

ATI Radeon HD 3xxx Series of products

Splinter Cell Conviction - Resolves performance stuttering issues when using a Windows 7 / Windows Vista / Windows XP based system with an:

ATI Radeon HD 2xxx Series of products
ATI Radeon HD 3xxx Series of products
ATI Radeon HD 4xxx Series of products
ATI Radeon HD 5xxx Series of products.



---------------------------------------------------------------------------------------

Magnavox01
09-16-2010, 05:10 PM
Downloaded and installed driver 10.4
But when I go to catalyst control center it shows i'm still at version 10.9

Still crashing every 10 minutes.

Edit

Resolution at 1200, anti aliasing at 2x and anisotropic filtering at 2x I crash after 10 minutes. Lowering my resolution to 800, with same settings, I get no crash. I don't see how lowering my resolution fixes the problem. My computer is well over the required for the game. Does that mean my video card isn't getting enough power, and if so, how can I give it more.

emilronn
09-17-2010, 05:35 AM
Try opening the game as Admin, it fixed seriously every problem i had with the game, crashes, server problems etc.

Magnavox01
09-17-2010, 11:49 PM
Originally posted by emilronn:
Try opening the game as Admin, it fixed seriously every problem i had with the game, crashes, server problems etc.

Didn't work
Crashed within 8 minutes.

Magnavox01
09-18-2010, 09:09 PM
So. I think I finally found the fix for these annoying crashes.

After messing with all of the ingame settings, turning things on and off, and playing for 10 minutes, getting a crash, and messing with all of my video card settings in the "Catalyst Control Center" numerousssssss times, I finally decided to try out the built in "Ati Overdrive". I turned up the "High Performance GPU Clock Settings" to 880 MHZ, the default is 850 MHZ. And turned up the "High Performance Memory Clock Settings" to 1275 MHZ. Forgot what the default was, but barely turned those up, I guess slightly overclocking my video card, also turned up the fan on my video card, and I tested splinter cell again, with everything on max, and max resolution, GPU temp maxed out at 55c, while before overclocking it maxed out at 64c. But my idle temperature went up 7 degrees. Did a little research and anything below 70c for your GPU should be fine, so still not sure why my monitor crashed, if before 'overclocking' it only got up to 64. But I'm just happy that it works.
But, never overclocked before, not really sure if its considered overclocking, if its a built in function of the catalyst control center, but if my temperatures never go above 60c am I decreasing the video cards lifespan?

Is there any other factor involved besides heat in overclocking that causes it to wear out more quickly?

Like, if you overclock a video card, but there's nothing wrong with your temps afterwards, is the overclock still going to shorten the life of the card?

Or is heat the only factor involved in the overclock that could damage the card?

KingDaniel0
09-18-2010, 11:21 PM
Originally posted by Magnavox01:
Downloaded and installed driver 10.4
But when I go to catalyst control center it shows i'm still at version 10.9

Still crashing every 10 minutes.

You must always do a FRESH and a clean install of the GPU drivers. Never install drivers, when the previous entries have not been properly deleted/removed from your System.

Go to Control Panel----> Programs and Features, and Select the 'ATI - Software Uninstall Utility' option, and click the Change/Remove button. Make sure you also delete any entries from the 'Program Files\ATI Technologies' Windows folder/path. Reboot your PC.

**You must also run any registry cleaner, to wipe leftover traces of the ATI drivers, e.g. RegCleaner. To use RegCleaner, Open the program and on the front page put a tick next to all the 'ATI'-related entries, and then click the 'Remove Selected' button.

http://www.majorgeeks.com/download460.html

Now do a fresh install of the ATI Hotfix 10.4a driver, and test SCC with this driver version.


I don't have this game with me, so I'm not sure why a particular in-game setting, or Screen resolution will make the Game unstable, but it's always better to disable AA/Multisampling, as well as VSYNC, if they pose any problem in-game.



--------------------------------------------------------------------------------------