View Full Version : problem switching between versions - HELP!!!!

02-29-2008, 11:31 PM
Ok - I was running SH4 with THO and was 3 patrols into a career.

I did buy the U-Boat addon deactivated TMO, saved a copy of my personal SH4 player folder and then ran the upgrade to add the 1.05 and installed the new license key.

After looking at it a bit I wanted to move back to my SH4-TMO to finnish out the career. I uninstalled SH4_UBoat (really the entire program). I deleted ALL the SH4 folders in Program\ubisoft and the SH4 folder in "My Documents", reinstalled SH$ from scatch. This ran - no problem BUT when I activated the TMO it will not run.

WHen I try to start I get the Ubisoft intro, the short film that normal SH4 has and then I get the TMO splash screen. At the point when it should open the game menu I get a CTD.

I have used fresh downloads of TMO and SH4, reloaded from scratch and the same thing keeps happening. I even reset the computer to a restore point the day before I ran the U-Boat upgrade and I still get the CTD after I activate TMO.

What the heck could be going on???? By theory if I compleatly remove the "new" SH4-UB I should be able to reinstall SH4 and activate TMO as I did BEFORE.

Any one has anyideas????

BTW I noticed that after I completely remove SH4 it never asks for the activation key when I reinstall it. Is there a way to force reload of hte activation key? Could the new SH4-UB activation key, which I assume is still hidden in the system somewhere be casuing the issue?

03-01-2008, 12:41 AM
Another point of information. SH4 uns fine after I install it from scratch. After I activate TMO it CTD after the TMO splashscreen. After I deactivate TMO SH4 still CTD but this time it is after the short game intor and befoer the SH4 splash screen.

I am really confused. BTW as a further test I took my system all the way back to a restore point before I installed SH4 the very first time. Still the same issue.

03-01-2008, 12:47 AM
Correction - After I deactivate the TMP the CTD is afer the SH4 Splash screen - not before.

03-01-2008, 01:35 AM
Ok - further update. One issue I had was that I was using an older version of the Mod-enabler. Once I got a newer version the program would sstill CTD after TMO was activated but it would run again after I deactivated TMO.

The TMO I am using is a fresh one I downloaded today.

03-01-2008, 03:05 AM
OK - it is 4:03 AM in the morning and I have realized I am a complete idiot. But I swear that I dont remember downloading the 1.04 patch for SH4 when I bought the game 2 weeks ago.

If I knew how to delete a thread I would delete this one.

GO home people - nothing to see here.

I am going to bed.

03-02-2008, 04:24 AM
You can save all the heartache of this by having two installs of SH4 on your computer bu using Multi SH4.

If you want to do it post again and I will run you through it...should take less than an hour and you will have TMO and Uboat Missions running as two seperate programs with save folders for both.


03-02-2008, 11:07 AM
I would like to know how to do that.

03-02-2008, 12:24 PM
Just a quick example of how to have

SH4 Wolves of the Pacific (V1.4)
SH4 Wolves of the Pacific Uboat Missions (V1.5)

or as many versions of SH4 as you want on your computer.

Go to program files/ubisoft/Wolves of the Pacific

Right Click and press COPY

Move to blank area in the same location and press PASTE.

This will create a file called Wolves of the Pacific Copy.

This will take about 4-10minutes depending on the abilities of your computer. Make sure both the original and copy are patched to v1.4

Now go to this location here


and download MultiSH4. Extract and copy and paste the MultiSH4, the four submarines into the Program files/ubisoft/Sh4 Wolves of the Pacific.

Then double click and run it.

Alter the lower SH4 letters to something different ie UBI and then click save.

This will put a separate save folder into my documents. Which will be your Uboat Saved missions folder.

Now run the Uboat Missions and it will load over your original version of SH4. (I have tried to get it to load to different locations but it won't).

Now it is pure administrative work

Go to your desktop and delete the SH4 shortcut.

Go into program files/ubisoft folder and rename the Original SH4 as 'Uboat Missions'. Open the folder and look for the SH4 picture which is the 'application.exe'....rename it 'Uboat missions' create a shortcut and place it on your Desktop.

Go into program files/ubisoft folder and rename 'SH4 Wolves of the Pacific Copy' as SH4 Wolves of the pacific. Go into the folder and create a shortcut from the SH4 application.exe and place it on your desktop.

When you run both they will create the necessary save folders in My Documents.

This is more long winded than it need be because of the fact that you cannot direct where the Uboat add-on loads to.........it is a pain in the BUTT.

If you also want to run 'trigger maru' and still keep a 'stock' game recopy again, rename, run multi SH4 etc and then put the Mod into the file using JSGME.

Not as bad as it looks, is quite simple when you have tried it......must be I can do it!!!!!!!!

Good luck