PDA

View Full Version : DLC wan't start!!



alldim
04-03-2011, 07:00 PM
For some reason my DLC is not starting. The game acts as I didn't have it. I mean, there is no little snake in my game screen... I don't understand why. Do we need to finish the game first? Or maybe we can't finish the game first.
The most confusing thing is that I have drachen armor and mp chars

Judgebread
04-04-2011, 06:41 AM
Hi, Had the same on the 360, I had to delete title update #5 from the HDD, (go to My Xbox, memory, find AC:B and delete that file), When you restart AC:B the get a title update that is 2 megs bigger than the one you deleted.
http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

Mr_Shade
04-04-2011, 09:19 AM
Hi There,

Since you say you have the Armour and the other multiplayer items - the DLC appears to be working?

The title update fix, is only intended to be used, if the DLC won't work at all..


The only thing I can think as to why it's not working, is if you have not played the game enough..

The DLC story line appears only after you have completed sequence 3 - when you start seq 4 - you should have an onscreen message about recovered memories - and a new icon on the map.

venusdoom676
04-05-2011, 09:25 AM
I am getting the same. I have the armour, Done all the sequences, gotten all the viewpoints. Nothing http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif No icon. Does it need to be in another sequence, or is there something wrong with the game?

alldim
04-06-2011, 06:48 PM
Actually I do have 80% of the game completed. Playing it the second, I am curious if it will work, even if I still think it won't.
If you can't play it after finishing the game i don't understand since it happens after the Borgias death.
I sure am not before sequence 3, got all the way to sequence 9