PDA

View Full Version : My Water is not PERFECT?



BurnerGPL
04-04-2007, 09:04 AM
Recently upgraded to an Intel e6600 and Nvidia 8800GTX. Reinstalled PF standalone, and did the proper patch order to latest patch.

I think I have done this right, but I may have missed something. I'm at OpenGL. Below is part of my conf file. I have set Water=3. Looked inside the game and the only option for PERFECT is for LANDSCAPE DETAIL. If I go to simple setup the highest I can go with is EXCELLENT.

Am I missing something? Maybe a config setup within my VC's control panel? Right now I just set it to default for QUALITY.

Using PFSETUP I see the card is listed as a Nvidia 6600/6800.

I remember a long time ago seeing the option for PERFECT but that was on another computer, another set of hardware (ATI) and another installation all together.

SUGGESTIONS??????

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=0

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=3
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=3
Water=3
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

Art-J
04-04-2007, 09:36 AM
I'm an ATI user, so I don't know what tweaks are optimal for NV, but the first thing which is noticeable here is "HardwareShaders" parameter set to "0". I'm sure it must be "1" If You want to see pixel-shaded water and other eyecandy.
I also THINK You might need to turn stencil buffer on (in the Il2setup program), but don't quote me on this one http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif.

Cheers - Art

dbillo
04-04-2007, 09:54 AM
Everything you need to enable Perfect Landscape can be done on the Driver tab when you run il2setup. You need to use OpenGL (which you have done). You need to use a 32-bit resolution, and you need to check Use Stencil Buffer.

You've got Water=3 in your conf.ini, which is a fast render option, so should be fine.

The only other thing you may have to do is select Perfect in the Landscape Detail pulldown in the game video settings screen. I'm pretty sure, this is the same as setting Hardwareshaders=1 in the conf.ini section you posted.

buzzsaw1939
04-04-2007, 11:58 AM
maybe a noob can help on this one.. I was just in there, and noticed that if you click on custom, (then) landscape detail, you have the perfect option. http://forums.ubi.com/images/smilies/16x16_smiley-happy.gif

BurnerGPL
04-04-2007, 12:21 PM
I see that too, but just for landscape.

major_setback
04-04-2007, 12:26 PM
I think you will get a reply to this in the community help forum, here:

http://forums.ubi.com/eve/forums?a=corfrm&cf=49310655

Otherwise you should be running the game in Open GL not Direct X (there is a choice between the two graphics options somewher in the game.)

BurnerGPL
04-04-2007, 12:34 PM
Yes, I am definitly in Open GL mode.

dbillo
04-04-2007, 01:31 PM
Originally posted by BurnerGPL:
I see that too, but just for landscape.
That's the one you want...it enables the Perfect Water as well. So, to reiterate:

1. Run in OpenGL
2. Select a 32-bit resolution
3. Enable the Stencil Buffer
4. Set a Water= number in the conf.ini
5. Select Perfect Landscape mode

That's all, I think.

BurnerGPL
04-04-2007, 02:33 PM
Hardwareshaders=1

I needed to set that, it was at 0. I don't know why but I know it works now. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif Thanks for the help.

Waldo.Pepper
04-04-2007, 03:03 PM
Originally posted by BurnerGPL:
Hardwareshaders=1

I needed to set that, it was at 0. I don't know why but I know it works now. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif Thanks for the help.

I was about to suggest you pay a visit to your Urologist.

WWSensei
04-05-2007, 06:34 AM
Originally posted by BurnerGPL:
Hardwareshaders=1

I needed to set that, it was at 0. I don't know why but I know it works now. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif Thanks for the help.

Settting the Landscape Detail to Perfect changes the Hardwareshaders to 1. The answer was in front of you the whole time. Put it this way, the term "Landscape" isn't limited to "Land". It refers to all the landscape--including the water.

BurnerGPL
04-05-2007, 07:49 AM
I understand that, you understand that, but something was awry. As I said up in the original message I only saw perfect for landscape in the game. Seems like it wasnt changing it in the conf.ini file?? I had Landscape Detail to Perfect but in the confi.ini file it wasnt set.

Im glad its set now, looks good, and had help from the great forum members!

Wilburnator
04-05-2007, 01:00 PM
When I installed 1946 I had to manually change hardwareshaders=0 to hardwareshaders=1 to get perfect mode. I chose perfect mode in the in game landscape detail option serveral times, and still had flat water until I went into the conf.ini and changed it myself. I never had to do that in previous editions of the game, but I sure had to in 1946.