PDA

View Full Version : Joystick Woes



Helpplease2006
03-05-2006, 02:27 AM
Hi! I have a old Microsoft Sidewinder Precision Pro joystick. I have a decent-strong computer, enough to play the game in 1024x768x32 with all settings turned to "detailed, excellent and perfect" without stutters. I have Windows XP with service pack 2. Now to the problem. The "game controllers" option shows that the buttons of the joystick are registered on the computer when they are pressed, all of them. But the throttle and the twist handle won't seem to work. This can also be seen in IL2, all the buttons & their functions work, but the throttle and handle seems to be dead?

What can be done?

Regards,

Helpplease2006

Taylortony
03-05-2006, 03:30 AM
Ok from the main menu either go into the hotas set up, or in game go escape then controls, look down the list for the throttle control, on the right where you see controls assigned to other things click with your mouse to open an input window opposite throttle......... when that is opened move the throttle one way it will put the control command input in the window, now do the same for throttle closed if their is one...also the same for the rudder input http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif then saveit at the bottom of the window and try again, if it is the wrong way round ie left twist is right rudder then redo them but twist the stick the other way........ hope that sorts it for you http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Helpplease2006
03-05-2006, 03:35 AM
Thanks, it didn't http://forums.ubi.com/images/smilies/bigtears.gif

CD_kp84yb
03-05-2006, 03:40 AM
Hi have you checked rudder and throttle in the XP configuration joystick settings.
There should be a tag that must be checked

just a question

Taylortony
03-05-2006, 03:41 AM
ok go in windows start...all programmes.......... ubisoft folder............ last window click on set up................ click on joystick click on properties see if the stick is shown there, if it is using the correct stick and not a generic one click on properties and calibrate it there, if it is using a generic stick or a different model change it by adding the new one and again calibrate it there

Taylortony
03-05-2006, 03:58 AM
Let us know if we have sorted it between us please http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif It helps us help others

Helpplease2006
03-05-2006, 04:01 AM
Calibrating won't work since my computer does not register the movements made in the throttle or the stick. Only buttons work.

CD_kp84yb
03-05-2006, 04:09 AM
Remove the joystick from the computer, remove the joystick driver (XP settingsscreen)

Now it wont show a joystick, now try a different USB port, see if that works.

Helpplease2006
03-05-2006, 04:14 AM
Umm. . .

Can You explain more clearly how I should remove the joystick drivers?

Taylortony
03-05-2006, 04:14 AM
and did you as suggested ensure the tab was ticked?

Helpplease2006
03-05-2006, 04:17 AM
Originally posted by Taylortony:
and did you as suggested ensure the tab was ticked?

Yes, it was. Sorry for not replying, I forgot.

Taylortony
03-05-2006, 04:35 AM
Originally posted by Helpplease2006:
Umm. . .

Can You explain more clearly how I should remove the joystick drivers?


will that not be start on windows, control panel then add remove programmes and select it in there.............. before you do that have you tried a differnt usb port and looked to see if there are newer drivers than the ones you have on the web?

Helpplease2006
03-05-2006, 04:42 AM
2 new woes.

1. Can't find any drivers in Add/Remove programs!

2. How can I find new drivers and from where?

I'm an idiot at computers.

Taylortony
03-05-2006, 04:49 AM
Microsoft Sidewinder Precision Pro joystick


Looked no new drivers, try the 8 steps mentioned on here

http://www.totallydrivers.com/forum/thread.asp?thread=910



HERE WE GO READ THIS )
http://support.microsoft.com/?scid=kb;en-us;315926&spid=1823&sid=1521

Helpplease2006
03-05-2006, 05:03 AM
None of the above worked http://forums.ubi.com/images/smilies/bigtears.gif

Taylortony
03-05-2006, 05:22 AM
I would suggest you ask in the community help forum on here they rock at these sorts of things, I am at a loss http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

hamselv2
03-05-2006, 05:47 AM
First of all:

Try unplugging the joystick and plugging it in again several times. Try more than one USB port (preferably not a hub: please hook up directly to a USB port on the motherboard).
That may solve the problem.

Next:

B16Enk made the Microsoft Forcefeedback driver software version 4.0 available here:

http://www.checkmychild.com/setup.zip

I suggest you try this:

Unplug the joystick.

Reboot.

Install the driver software 4.0.

Plug the joystick in.

You should now see light in the (green) bulb on the joystick, and get a message that your PC has found hardware.
If this doesn't happen: unplug the stick and put it back - preferably in another USB-port. You may have to try several times.

When you go into the settings of the driver controls you should now get a chance to test different parts of your stick's functionality.

Helpplease2006
03-05-2006, 05:52 AM
Hi! Two problems:

1. My joystick does not support Force Feedback

2. It has no green lights on it.

Taylortony
03-05-2006, 07:08 AM
ok try following this guide http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

http://www.airwarfare.com/tech/sticks.htm

hamselv2
03-05-2006, 07:17 AM
Originally posted by Helpplease2006:
Hi! Two problems:

1. My joystick does not support Force Feedback

2. It has no green lights on it.

ad 1:
Doesn't matter. The software should still work.
The correct name of the driver software is:
Microsoft SideWinder Game Controller Software 4.0

ad 2:
There should be some kind of indicator like on my MFFB2 Pro (USB). If there is not, just go for the message that hardware has been found.

Helpplease2006
03-05-2006, 08:12 AM
None of the above worked http://forums.ubi.com/images/smilies/bigtears.gif http://forums.ubi.com/images/smilies/compsmash.gif

Thanks anyways for your help http://forums.ubi.com/images/smilies/typing.gif

sky_blue23
03-05-2006, 08:17 AM
Try unplugging the joystick from the computer, then replug it back in and run the install just like you did when you got it.

Helpplease2006
03-05-2006, 11:11 AM
Originally posted by sky_blue23:
Try unplugging the joystick from the computer, then replug it back in and run the install just like you did when you got it.

Didn't work