PDA

View Full Version : Constant Stuttering.



nelly75
02-26-2019, 10:56 AM
With the in-game vsync enabled I get massive stuttering and hitching also had a couple of long pauses during gameplay. I found forcing vsync and fastsync in the Nvidia Control Panel didn't help in fact it made the stuttering worse.

The only way I've found to remove stuttering is to disable vsync altogether but then I have to put up with screen tearing instead.

Can this please get looked at?

My System: i7 7700K @4.8 Ghz, RTX 2080 Ti, 32GB Ram and Windows 10 OS.

nelly75
02-26-2019, 11:12 AM
Just tried adaptive sync in the Nvidia Control Panel and it was a little bit better during gameplay but still some stuttering in the menu screens and on the event select screen.

UbiMatcha
02-26-2019, 12:14 PM
Hey nelly75! Thanks for the report.
Do you notice this happening anywhere specific, such as checkpoints, track animations etc?
Could I also ask you to double check your GPU drivers are fully updated, thanks!

nelly75
02-26-2019, 12:16 PM
With in-game vsync enabled it was stuttering pretty much everywhere. GPU driver is 419.17

UbiMatcha
02-26-2019, 12:25 PM
Thanks for confirming!
I'm aware you've already adjusted your settings (https://support.ubi.com/en-GB/faqs/000039038/Performance-Issues-in-Trials-Rising-TR), so we'd recommend running through some basic troubleshooting (https://support.ubi.com/en-GB/faqs/000025947).
If the issue persists, we'd appreciate it if you could forward us your Msinfo and Dxdiag (https://support.ubi.com/en-GB/faqs/000026442/Submit-Dxdiag-and-Msinfo/) files in a support ticket (https://support.ubi.com/en-GB/Cases/New).
Thanks!

nelly75
02-26-2019, 01:30 PM
I've submitted a ticket, hopefully it helps you guys ����

UbiMatcha
02-26-2019, 03:30 PM
Thanks for that nelly75!

distrust74
02-26-2019, 04:03 PM
nelly, did you try switching from fullscreen to borderless?
This helped a lot for me to reduce/minimize that constant microstutter.

UBiMatcha, in fullscreen mode I experienced pretty much the exact same thing nelly described. I also use a 2080ti, I run it in 4k, and the nvidia vsync options don`t work on this game.
So in fullscreen mode its either vsync with microstutters or no-vsync with massive tearing for me.

nelly75
02-26-2019, 04:21 PM
Tried both in borderless and fullscreen mode and didn't really make much difference.

I'll stick with the screen tearing until it gets patched ����

UbiSailorScout
02-26-2019, 10:53 PM
Hi nelly75! I checked your NFO file, and noticed a few programs that may be causing issues. Can you try disabling or uninstalling the following:
- AI Suite 3
- MSI Afterburner
- RivaTuner
- Fraps
- TunnelBear

Let me know if it improves at all!

@distrust74 Thanks for sharing!

distrust74
02-26-2019, 11:47 PM
Np, I am sorry switching to borderless didn`t work for nelly. I tested it again today on my system, and it`s still working (with ingame vsync, the nvidia panel settings seem to be ignored either way).
I`d still hope for a fullscreen fix though.

nelly75
02-27-2019, 02:07 AM
Hi nelly75! I checked your NFO file, and noticed a few programs that may be causing issues. Can you try disabling or uninstalling the following:
- AI Suite 3
- MSI Afterburner
- RivaTuner
- Fraps
- TunnelBear

Let me know if it improves at all!

@distrust74 Thanks for sharing!

Disabling the rivatuner overlay got rid of some of the stuttering and running the game without MSI Afterburner got rid of stuttering altogether. Problem is this is really not an ideal solution for me, I use the MSI Afterburner software for my custom GPU fan setting and I use Rivatuner to monitor my system temperatures.

Is there a chance this can be addressed in a title update please?

nelly75
02-27-2019, 03:08 AM
Another quick update. Did some more testing and found that if I start the game with rivatuner overlay enabled it causes the stuttering but if I start the game with rivatuner disabled and then enable after the game has finished loading it seems to run fine.

UbiMatcha
02-27-2019, 10:59 AM
Thanks for sharing that workaround nelly75!
If you encounter any further issues please let us know.

nelly75
02-27-2019, 12:19 PM
Thanks for the help guys, it's an awesome game by the way :D:D

Stonie74
03-04-2019, 10:31 AM
I have constant stuttering on full screen mode, yet the FPS counter in the top left, enabled in UPlay, shows a constant 60fps

Running borderless takes away most of the stutter, and it happens very occasionally, probably once or twice during each track, and the FPS goes between 59 and 61fps when the stutter happens. The stutter is minor, just a split second, but enough to be noticed.

This game should run better in Full screen compared to Borderless Window, but it doesn't.

PC Specs are as follows

CPU:- Intel core i5 6500 3.2 GHz
GPU:- Nvidia GeForce GTX 970 4GB
OS:- Windows 10 64-bit
Ram:- 16GB HyperX DDR3 (edit. It's actually DDR4 memory)

Ubi-Mullac
03-04-2019, 12:11 PM
Have you tried the troubleshooting prior in this thread?

Stonie74
03-04-2019, 12:29 PM
Have you tried the troubleshooting prior in this thread?

Yes, I have disabled Nvidia control panel, and shut down all programs running in the background. I have tried lowering the settings, at current, I'm running 1080p, at highest settings, and lowering those settings makes no difference whatsoever.

It just seems that it is badly coded/ported.

Like I say, the FPS is constant in the top left at 60fps in full screen, no dips, but the stuttering is abysmal.
Running borderless window is a vast improvement, but by no means should this be any sort of acceptable workaround.

Ubi-Mullac
03-04-2019, 12:53 PM
And you have no overlays active?

Stonie74
03-04-2019, 02:22 PM
No, I turned off the Nvidia overlay. But I do have the U-Play fps counter in the top right.

I have just tried it with the U-Play overlay disabled showing the FPS, and put back to full screen, but no change as far as frame skipping.

No overlays are running in the background.