PDA

View Full Version : Metiochos Game Breaker Bug



DarthManwe
10-04-2018, 12:08 AM
After speaking to Perikles for first time, three quest should have been given, but only two were given. From online, I learnt that I am missing A Venomous Encounter quest with Metiochos tied and surrounded by snakes.

After a long search in Athens, found the villa, and even snakes were in there, and Metiochos called for help.... But after I killed snakes, Metiochos were not tied, he was lounging on a bench, completely immortal and non reactionary.

Essentially, main quest is broken. Save is dead.

DarthManwe
10-05-2018, 02:54 AM
New playthru, different main char ( kassandra)

Same bug.

C'mon I cant be the only f.....g person on the whole community that is getting this major, game breaking bug.

Edit : I am just gonna keep bumping this thread till I get some sort of feedback, so feel free to ignore me. I was loving the game, now can't play it. I right now have a level 39 alexios that is stuck on at Athens entrance quests.

This is ridicilous to the extreme.

Edit 2 : Yes, I have verified files on uplay. Yes, they were fine. No I am not running a crack, any community manager can look at my account and see a damn Gold edition odyssey in there. Yes, my computer is in specs ( Well above all of them, but what does that have to do with a damn quest bug anyway). No, I did not try to use any sort of code injector ( They mean cheatengine, and no)

DarthManwe
10-05-2018, 11:05 AM
Bump

StrykerAU
10-05-2018, 12:57 PM
Also having this problem.

Played through with Alexios up to just part this quest and it worked fine. Wanted to give Kassandra a try and got to the Road to the Symposium and encountered the same missing quest.

This is a big disappoinment because I was enjoying K's voiceover much more so.

DarthManwe
10-05-2018, 03:59 PM
Maybe ıts relevant or not, but I started playing Kassandra and didnt like her facial animation about an hour into story, then started Alexios and got to that point first time.

So technically I never got to that point with my first Kassandra save ( which is long gone), so my first encounter with the bug was on my 2nd char as well.

DarthManwe
10-05-2018, 11:08 PM
Bump

DarthManwe
10-06-2018, 07:25 PM
Looks like more and more people are having main quest not granting the next one in chain at different stages of the story.

It's still broken on mine.

And this is not in Known Issues or being investigated list?

Some acknowledgement would be nice, considering we paid real good money for Gold editions and such. Is this gonna be fixed or am I not gonna be able to play this game past a certain point no matter what?

Malatar314
10-08-2018, 11:55 PM
Bump. Can't get Venomous Encounter after restarting the game as Kassandra on PC... Utterly game breaking. Any word from Ubisoft?

Malatar314
10-09-2018, 05:22 PM
Bump. Still can't play since there's not a single quest I can go do from Athens...

ubi--unicorn
10-09-2018, 05:24 PM
Hi guys, this issue has been reported. I'll pass this thread along as well. Apologies for the inconvenience.

nightmare93333
10-09-2018, 07:06 PM
Got the same issue... startet with kassandra changed character to alexios now im 26 and still cant talk to metiochos.
he is sitting on the bank outside of the room where he should be hiding from those snakes - killed the snakes anyway and still cant talk to him

nightmare93333
10-09-2018, 07:07 PM
#edit Double-Post because your website was down for like 2 min

DarthManwe
10-12-2018, 06:28 AM
Fired up the save I took just before welcome to athens.

Got venomous encounter now. Seems to be all working for now.

Well, at least until I encounter another game breaker

miklet01
10-28-2018, 02:40 PM
my problem is Herodotos. But same result, cannot complete Symposium. YouTube gas videos of how it's supposed to work. From posts on this forum I can see several ways this can get stuck. No response from UBISOFT yet. Betting an update is needed to the game and we all have to start over from square one. Fun factor sinking....

miklet01
11-01-2018, 01:02 AM
three weeks ago
well, please have the courage to tell us the game is broken and you have no plans to fix it... cowards