PDA

View Full Version : poor patch design



K_Warner
10-12-2005, 12:52 AM
Ok, I installed ALL OF THE PATCHES in the order I was supposed to install them in.... I've done this numerous times now all to no avail. Game fails to start and seeing how I have a Dell XPS I know for a fact that my system is not the issue. Perhaps it's human error? I really don't care at this point. I paid $19.95 for this game. Any more and I would be very upset. This is a very poorly supported game. Don't get me wrong UBI. I've owned and played all three of the Silent Hunter series. I just have to say that I'm not impressed with the updates for this game. I have a lot of games on my computer that when you foirst install the game and go to get the newest patch you DON'T need to install ever patch that's been released for it. You simply install the latest patch and all is done.

I'm sure that this post will not last long on this site before it is pulled. I just hope that I have a few out there that agrees with me and you see that there are actually some people out there that does not agree with your design philosophy.

K_Warner
10-12-2005, 12:52 AM
Ok, I installed ALL OF THE PATCHES in the order I was supposed to install them in.... I've done this numerous times now all to no avail. Game fails to start and seeing how I have a Dell XPS I know for a fact that my system is not the issue. Perhaps it's human error? I really don't care at this point. I paid $19.95 for this game. Any more and I would be very upset. This is a very poorly supported game. Don't get me wrong UBI. I've owned and played all three of the Silent Hunter series. I just have to say that I'm not impressed with the updates for this game. I have a lot of games on my computer that when you foirst install the game and go to get the newest patch you DON'T need to install ever patch that's been released for it. You simply install the latest patch and all is done.

I'm sure that this post will not last long on this site before it is pulled. I just hope that I have a few out there that agrees with me and you see that there are actually some people out there that does not agree with your design philosophy.

EJGrOst_Caspar
10-12-2005, 01:20 AM
Instead of giving pass to your anger, you should better ask for help. Maybe that is what you want, its not quite recognisable.

In fact I think, this game (and the whole series) is supported very well (ok, that not because of UBI at all, but... it is). Mostly those patches are not only error fixing, but each one means half an addon in my eyes. And all you really need are maybe 2 or 3 patches. Thats not very uncomfortable or is it?

So, just tell us, what kind of game do you mean? Pacific Fighters, or IL-2ForgottenBattles/Ace ExpansionPack/PacificFighters merged version, or whatever?

LEXX_Luthor
10-12-2005, 01:34 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">You simply install the latest patch and all is done. </div></BLOCKQUOTE>
hehe good one.

Tooz_69GIAP
10-12-2005, 01:40 AM
Best advice is to check out the sticky thread at the top of this forum which tells you the CORRECT patch order. You DO NOT need to install EVERY SINGLE patch for this game, just a selct few. That sticky tells you which ones.

FritzGryphon
10-12-2005, 02:06 AM
You'll also find the game is perfectly stable and playable without patching. You do not need to install any of them.

They are provided as a courtesy, mainly to address historical accuracy, and add new content. Support for the IL-2 series is second to none, and the hundreds of megs of patches is testament to that.

310th Falcon
10-12-2005, 02:34 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">You simply install the latest patch and all is done. </div></BLOCKQUOTE>
http://forums.ubi.com/images/smilies/51.gif


Best Regards

nakamura_kenji
10-12-2005, 03:01 AM
100mb(3.03) + 141mb(4.01) = 241mb patch 0_0 rather have seperate chance download fail have do again less

download more 1 patch not to hard it?

Flying_Nutcase
10-12-2005, 03:36 AM
This game is awesome and the patches are all fine. As mentioned above, check out the top sticky thread in this forum, 'Correct Patch Order'. You probably downloaded the wrong patches.

Good luck.

And it will be a good lesson for you not to blame someone as soon as something doesn't work for you. Maybe the problem is a misunderstanding/lack of info and not some conspiracy/someone's fault. Explaining the situation and asking for help goes a long way. http://forums.ubi.com/images/smilies/25.gif

Triggaaar
10-12-2005, 04:54 AM
Hey Warner, welcome to the forum.

Everyone here has installed the patches, and they do work. If you detail exactly what you did, and where it went wrong, people here will help you - or you could post in the community help forum.

As said above:
1) You do not need the patches to make the game work - I was flying just fine with no patches, whilst I waited for the expansion packs. I noticed no bugs in the game (not saying there aren't any, but without patches, it was still as bug free as any other game).
2) The patches are not just fixes, but add a lot of functionality to the game (and I'm not talking about functionality that shoud've been there in the first place).
3) For IL2 FB, AEP, and PF, there are just 2 patches required. Again, as said above, it may be preferrable to download 240Mb in 2 chunks.

Chuck_Older
10-12-2005, 05:30 AM
Guys-

He paid 19.95 for the game

He has Pacific Fighters. Not FB+PF

K_Warner~
Quite to the contrary, this game is simply one of the best support sims, if not THE best supported one. You spent 20 bucks which is not a lot of money, and you have had some troubles. This forum is not the place Ubi looks for input or complaints for their titles. Ubi didn€t make the sim, 1C:Maddox Games did. Ubi is a publisher

If you explain your troubles, you may get help

Miki40
10-12-2005, 06:15 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by EJGrOst_Caspar:
Instead of giving pass to your anger, you should better ask for help. Maybe that is what you want, its not quite recognisable.

In fact I think, this game (and the whole series) is supported very well (ok, that not because of UBI at all, but... it is). Mostly those patches are not only error fixing, but each one means half an addon in my eyes. And all you really need are maybe 2 or 3 patches. Thats not very uncomfortable or is it?

So, just tell us, what kind of game do you mean? Pacific Fighters, or IL-2ForgottenBattles/Ace ExpansionPack/PacificFighters merged version, or whatever? </div></BLOCKQUOTE>


This is lip service my friend, stop doing that, the man is right, you have to accept that is at least odd not to have by now a cumulative patch.
As for the support...is not great( at present at least ) with a patch with some important fixes to fix a previously buggy patch, which was due in August and now we are into mid October!

Skycat_2
10-12-2005, 07:08 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by K_Warner:
Game fails to start and seeing how I have a Dell XPS I know for a fact that my system is not the issue. </div></BLOCKQUOTE>

Your system may be the issue. Sort of.

Have you tried to run the game straight from the box, no patches added? If you get error messages and the game won't start even fromt the basic version, you may be experiencing a common problem that is caused by copy protection in the rts.dll -- a replacement rts.dll from Ubi Soft customer support may fix this. There have been recent threads on this, perhaps two or three weeks old now, in this forum.
Edit: solution threads (http://forums.ubi.com/eve/forums/a/tpc/f/26310365/m/1551051363).

Next, as some here have speculated, it seems that you are trying to run Pacific Fighters as a standalone game (IE, not merged to Forgotten Battles and Ace Expansion). If so, be sure you are installing the patch series that does not have the lower case 'm' at the end of the title. M = merged.

Be sure you do have all the patches you need. Right now, you really only need two which isn't so bad -- several early patches were combined into the "3.0 to 3.03" patch. Install that one, and the 4.01 patch on top of that. You can skip the 3.04 patch in between if you want.

Last, are you sure that one of your patches isn't possibly corrupted? If the game runs at version 3.0 ("Out of the box"), install the first patch and run it again. If fine, install the 4.01 patch.

Tully__
10-12-2005, 07:10 AM
There is no cumulative patch to keep the individual download size down. A large portion of the customer base lives in parts of the world where good, stable broadband connections are not available and the size of a single patch would make it almost impossible to get an un-corrupted download even at the current size. As it is there are a couple of sites that have broken the individual patches down into smaller portions to aid those on dialup.

K_Warner
10-12-2005, 09:23 AM
http://forums.ubi.com/images/smilies/1072.gif

Last night some old college buddys came up from Denver. And well, it really does not take a whole lot of imagination to figure out where the night went after they arrived.

To sum it up. I Should never post in a forum under the influence. Or for that matter update any software on your computer while under the influence

My apologies if I have affended anyone here. I'm sure I can get it done properly now that my head is a bit miore level to say the least......

kew

K_Warner
10-12-2005, 09:27 AM
http://forums.ubi.com/images/smilies/35.gifThe more I read what I wrote and the replys the more i can't stop laughing at myself...

K_Warner
10-12-2005, 09:34 AM
http://forums.ubi.com/images/smilies/351.gif

OK, I certainly hope that you all will have a good laugh on me. In the two minutes since I posted my last reply on here I have succecfully updated Pacific Fighters to v401........

Mental note to self: unplug my computer when old college buddys pop up.......

FoolTrottel
10-12-2005, 09:37 AM
Congratulations on the succesfull patching!

And on the fact that you can't stop laughing at yerself! (Well, it should've stopped by now I guess)

And thanks for being so honest!

Now, go fly!

Have Fun!

Bearcat99
10-12-2005, 09:50 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by K_Warner:
I'm sure that this post will not last long on this site before it is pulled. I just hope that I have a few out there that agrees with me and you see that there are actually some people out there that does not agree with your design philosophy. </div></BLOCKQUOTE>

Oh ye of little faith....

http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif Glad you got that short between the headsets fixed. I suggest you look here (http://forums.ubi.com/eve/forums/a/tpc/f/26310365/m/4591089933/r/4591089933#4591089933) and consider going all the way. Looking at your specs you will have to tone the settings down a bit but it should still look pretty darn good. I know mine did when I was on excellent....

Also hit the Sturmovik Essentials link in my sig.. pay attention to the 5 & 4 star sites (the whole thread is full of stuff and can save you alot of space in your favorites menu). Welcome aboard.... and remember... dont drink and install software. http://forums.ubi.com/images/smilies/88.gif

Flying_Nutcase
10-12-2005, 11:25 AM
Another convert. http://forums.ubi.com/images/smilies/16x16_smiley-happy.gif

major_setback
10-12-2005, 05:27 PM
It's ok. I was drunk when I read it! http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

http://forums.ubi.com/images/smilies/1072.gif

fireman519
10-12-2005, 06:09 PM
What's wrong with drosting while punk?

Platypus_1.JaVA
10-13-2005, 09:46 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by K_Warner:
http://forums.ubi.com/images/smilies/351.gif

OK, I certainly hope that you all will have a good laugh on me. In the two minutes since I posted my last reply on here I have succecfully updated Pacific Fighters to v401........

Mental note to self: unplug my computer when old college buddys pop up....... </div></BLOCKQUOTE>

And I was under the impression you wanted SH3 patched up http://forums.ubi.com/images/smilies/35.gif