PDA

View Full Version : Game stuck at loading screen every time I try to play



LoadedGunn47
09-21-2018, 04:42 AM
I hope somebody here will be able to help as Ubisoft tech support provided me with some of the most asinine "solutions" I've ever heard and apparently nobody on the internet is running into this issue going by my exhaustive search for assistance. To put it as simply as possible, ever since that recent brain fart of a big *** patch foisted upon it, my game doesn't work. It starts, goes to the main menu, but if any attempt is made to actually play it online or single player I end up looking at a loading screen as frozen as a popsicle after about 3 seconds (it varies). I've done literally everything from uninstalling (3 times), deleting the save games, clearing the cache, to turning off cloud save and still nothing. After contacting support and essentially asking them to refund me if they're gonna stop me from being able to play their game because of an unnecessarily large patch I'm basically at wits end. I can only assume that Ubisoft has a team of monkeys working round the clock on these patches, so I hope that one day I will be able to blast bad guys in Bolivia again but any help that may speed up that happening would be greatly appreciated

Lynxpics
09-21-2018, 05:05 AM
We could not give you some useful advice too , but I suggest you check windows10 recent update record(if you are using win10).

ubi--unicorn
09-24-2018, 10:36 PM
Hey LoadedGunn47. Your ticket is closed, if you need further support, please open it up by responding with a screenshot of your port forwarding and a new MSINFO. Let me know when you've done so and I'll look into it. Thanks!