PDA

View Full Version : Unplayable FPS in cities?



nuclearpanda31
07-02-2018, 04:46 AM
Hello all, I'm hoping somebody can help me out here.

I want to play this game so badly, but the FPS in cities that I get makes it miserable for me. If I am not in a city, I get a solid 60 with no stutters and it's buttery smooth. Fast forward to any city, and stutters begin to happen and my FPS fluctuates rapidly between 30-50 to the point where it's unbearable.

My system specs are as follows, and they should be more than enough to run the game at a solid 60:

i5-4690k @ 3.7 ghz
16 GB RAM
AMD RX-480 8GB on 18.6.1 drivers
250gb SSD, Win. 10 64-bit

I'd really like some help. I love the game but I cannot play it in this state.

Dryminator
07-02-2018, 06:55 AM
This issue has been going on since Closed Alpha and Ubi either has not fixed or has not even identified the issue. The game is severely affecting CPUs, but the issue is not affecting all players, only some, who have no apparent connection between each other. I have the issue myself, game likes to crash a lot when the stutters begin. I'm forced to play in 30FPS mode and when streaming the game, it gets really bad.

We have made many threads and many support tickets, but I dont think anything comes from it any time soon. And Ubi doesn't look to be into optimising their performance any time soon. They care about that players are getting too much points in drifts and cars cannot be customized well and what not, instead of getting performance better.

A good example in 30FPS mode. I am standing at LA HQ outside, not doing anything. CPU load is 95% for idling, GPU load if 40%. GPU load never goes over 70% when playing, CPU load is always around 90-100%.

i5-3570K @ 3.8ghz
16GB RAM
GTX 1070 8GB
1TB Samsung Evo 850 SSD
Win 10 Pro, 64-bit, ver 1803

TG_striker890
07-02-2018, 09:39 AM
This issue has been going on since Closed Alpha and Ubi either has not fixed or has not even identified the issue. The game is severely affecting CPUs, but the issue is not affecting all players, only some, who have no apparent connection between each other. I have the issue myself, game likes to crash a lot when the stutters begin. I'm forced to play in 30FPS mode and when streaming the game, it gets really bad.

We have made many threads and many support tickets, but I dont think anything comes from it any time soon. And Ubi doesn't look to be into optimising their performance any time soon. They care about that players are getting too much points in drifts and cars cannot be customized well and what not, instead of getting performance better.

A good example in 30FPS mode. I am standing at LA HQ outside, not doing anything. CPU load is 95% for idling, GPU load if 40%. GPU load never goes over 70% when playing, CPU load is always around 90-100%.

i5-3570K @ 3.8ghz
16GB RAM
GTX 1070 8GB
1TB Samsung Evo 850 SSD
Win 10 Pro, 64-bit, ver 1803

95% CPU load is not idling. Depending on controllers / ram / etc. this is probably "full load" for the done tasks.
Which means that your CPU is bottlenecking. Your CPU is also not fullfilling the recommended requirements, which falls in line with your experiences ingame. And off course if you start streaming it gets even worse. Your CPU is severly underperforming your GPU.

There's no Issue on Ubis side, your pc is just not able to run the game. Time for a new CPU.

SignexNL
07-02-2018, 10:18 AM
The launch version fixed that for me, i used to have 40-50fps in cities with a 1070 Ti in the beta but now it's a solid 60fps and haven't seen it dip below that.

That is at 2560x1080, Ryzen 1600 OC'd to 3,9ghz.

nuclearpanda31
07-03-2018, 02:28 AM
What about people that meet requirements like me? What am I supposed to do? Hope that they release a patch that improves performance, because I have yet to see it listed on known issues. I should not have to play on all low settings just to get smooth gameplay on a system that meets and exceeds recommended specs...:(

Dryminator
07-03-2018, 08:49 PM
My CPU should be fine. You see, when I play on say 60FPS, the framerate is fine. The game freezing is the issue. I dont have low framerate, neither in cities nor in the countryside. There is almost no lag. But the game likes to freeze even during the smoothest experience. The CPU is watercooled, so temperature is not an issue.

I have seen posts where the same issue happens to players who have like i7-6700K... playing in 60FPS mode, game freezes and has to be completely restart, no getting out of the freeze in-game. The CPU is not the problem here, the issue is in game code.

But I have also seen cases where two players have almost identical CPU-s, one has the issue, the other has not, both meet Ultra requirements.

It is fairly possible that some combination of the game and Windows 10 update/settings causes it, really difficult to troubleshoot without going to extremeties because I am not going to reroll drivers or reinstall stuff because one single game is freezing while the other 399 are not.

ubi--unicorn
07-03-2018, 09:37 PM
If you are experiencing low FPS, these steps (https://support.ubi.com/en-gb/Faqs/000035324/Improving-game-performance-TC2/) may help.

Dryminator
07-03-2018, 10:44 PM
If you are experiencing low FPS, these steps (https://support.ubi.com/en-gb/Faqs/000035324/Improving-game-performance-TC2/) may help.

I am working through my issue directly with Ubisoft Support via a ticket (06389081).

nuclearpanda31
07-04-2018, 12:53 AM
I have already gone through those. Is there a way I can contact support or message you any information?

Ubi-Baron
07-04-2018, 10:19 AM
Hi nuclearpanda31

You can speak with the Support Team through the site here (support.ubi.com)

Make sure to include a DxDiag and MSINFO (https://support.ubi.com/en-GB/faqs/000023904/How-To-Submit-Dxdiag-MSinfo/), as this will be required to help look into this.