PDA

View Full Version : Good PC - bad performance PLEASE HELP!



LongKong88
07-01-2018, 11:17 AM
Hi whats up

I bought myself The Crew 2 and already in the closed beta I had very bad performance issues.
My specs:

CPU: Intel(R) Core(TM) i7-6700k @4.00GHz
RAM: 32GB DDR4 RAM (4 sticks)
GPU: GTX 970

The game is running on the main disk (500GB SSD).

I even tried to set the options to the lowest but I still only get like 20 fps. I also tried to verify my files.
The day I installed the newest Geforce Experience Driver I HAD 60 FPS AT ULTRA SETTINGS (!).
But after restarting the PC my performance went back to the middle ages. Then I tried reinstalling the GPU Driver and performance got better for like 10 minutes.

As I see in the Task Manager my sytstem is not overwhelmed with the game. When playing it my CPU is at 20%, my GPU at 50% and my RAM is like 15%.
I think maybe my operating system is glichjng (Windows 10 64bit) or the game is just not using my specs as it should.

I appreciate your help! Thanks!

LongKong88
07-01-2018, 11:22 AM
Edit:

My firend has the exact same PC like me and he is playing on Very High with constant 60 fps.

ubi--unicorn
07-01-2018, 07:14 PM
Hey LongKong88, these steps (https://support.ubi.com/en-gb/Faqs/000035324/Improving-game-performance-TC2/) may help with this issue. If they do not, please create a ticket (https://support.ubi.com/en-US/Cases/New) with your MSINFO and DXDIAG files (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files). Feel free to PM me your ticket number for further troubleshooting.