PDA

View Full Version : The Crew 2 BattlEye Service



svakotsako
06-29-2018, 08:13 PM
Sorry for double posting but was first time in this forum and I see later that have category for every game.

i'm trying to start The Crew 2 but receive this:


20:58:01: Starting BattlEye Service...

20:58:04: Launching game...
20:58:07: Note: File blocks can be ignored if they don't cause problems with the game.
20:58:07: [INFO] Blocked loading of file: "\Device\HarddiskVolume1\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\The Crew 2\TheCrew2_BE.exe".
20:58:07: Failed to launch game.
Trying everything I can. Updating Video drivers; Update windows; Verify game; uninstalling game and installing again, same with UbiLauncher. Delete temp folder. Do msconfig stuff. Scan hard drive for errors but still get same and same error.

PC configuration is: i7-6700hq @ 2,60Ghz / 16 gb ram memory and Nvidia GeForce GTX 960M

Any ideas what i can do to start this game?

dbgager
06-29-2018, 09:12 PM
Battleye is an anticheat service.. Did you modify the game in any way.

Gopro_Yell0
06-29-2018, 09:20 PM
my friend got the same problem and no he did not modify

svakotsako
06-29-2018, 09:25 PM
No. Just buy game and try to start and get this error. Reading a lot and trying all things I found but no success. As I see have a lot post with similar problems with crew2 and battleye service. Hope soon we can play.

Sgt.Ghork
06-29-2018, 09:52 PM
Got the very same problem =/

Gopro_Yell0
06-30-2018, 01:13 AM
we delete all ubisoft and battleeye fils and install them agen and now he can play agen try do the same :D

UbiSailorScout
06-30-2018, 01:41 AM
Hey there! You may want to try Gopro_Yell0's idea, and uninstall and reinstall the game. This FAQ (https://support.ubi.com/en-GB/Faqs/000025213/BattlEye-FAQ#Troubleshooting%20BattlEye) offers some help with troubleshooting Battleye issues. Please refer to the "My BE Launcher window shows “[INFO] Blocked loading of file: …” messages. What’s wrong?" section for assistance.
If this does not help, please make a ticket (https://support.ubi.com/en-US/Cases/New) with your msinfo and dxdiag files attached (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files).

svakotsako
06-30-2018, 02:24 PM
uninstall everything also all games, install again the crew 2 and get same error. Trying to replace battlEye file from beta (from 1900365-Game-exits-about-a-minute-after-login) but still not working. Waiting and hope for update or something else.

Already do all ideas from FAQ

Racingkittens
06-30-2018, 02:34 PM
Try un- and reinstalling BattlEye by doing this.


Delete the "Battleye" folder in the game folder
Delete this folder C:/Program Files (x86)/BattlEye
Open the command prompt (Start -> Run -> "cmd")
Type in the following: sc delete BattlEye
(optional) Reboot
Verify game files and try starting the game again



This should re-install BattlEye.

svakotsako
07-03-2018, 05:58 PM
Nothing happend same error. Send ticket already waiting for answer. Thanks anyway

ubi--unicorn
07-03-2018, 09:35 PM
svakotsako, can you PM me your ticket number? Thanks!

svakotsako
07-07-2018, 03:03 PM
Everything working with The Crew 2 now after simple thing - preinstalling windows 10 all updates and nvidia latest drivers.
Nothing more.

NDAC_werkea.
10-10-2018, 10:14 PM
I have the same problem after a windows update
more like a malware update
all my game stop to function properly, and after I did the Windows reset. everything was back to normal.


too bad you have to reinstall hundred of software

xenopont
12-19-2018, 11:27 AM
battle eye doesn't work on the newest windows insider build

UbiSailorScout
12-19-2018, 11:41 PM
Hey there! BattlEye does not 100% support Windows Insider, which is most likely why you are getting an error.