PDA

View Full Version : First few min very laggy



Erhanninja
06-23-2018, 09:03 PM
I donít know if itís just me however I highly doubt it as I always have around 30ms ping and a good internet connection.

Every time I join a dominion game first few mins are very laggy. Literally people teleport everywhere. I play on console in the UK region not sure if that helps. Itís absolutely rubbish. If Iím facing a cent etc itís instant death.

Also I want to say how Iím dissapointed with Ubisoft dedicated servers. I was away when this happened. And came back thought oh yeah we have servers now but game is still as bad as before. Then found out they only brought it to PC. I canít understand why when biggest player base is in console they go and balance the game based on PC. Also bring servers to PC. For me this is a very stupid decision. Reps why dedicated servers are first and only on PC?

UbiInsulin
06-23-2018, 09:41 PM
The dedicated servers went live on console after PC, but they have been live since March. We've seen substantial improvement in match stability since then, but that doesn't mean there aren't still things to work on.

I'd advise getting in touch with https://support.ubi.com if these connectivity issues continue through multiple matches.

HazelrahFirefly
06-23-2018, 10:38 PM
Actually, he/she might be referring to players joining the match. For every person that does you will definitely receive a gorging amount of lag for approximately twenty seconds.

Sometimes it's bad enough that I just let myself die so I can be dead throughout it lol. Nothing to be done, I'd rather have players join a game that goes steady afterward then the games dropping left and right.

For the record, up to 6 d/c since the servers. Love it!