PDA

View Full Version : AEP and BOE problem!



fi-bluedragon
04-05-2004, 07:49 PM
I have just found out that if you install Battle Over Europe over IL2-FB and then install Aces Expansion Pack afterwards, the game doesn't upgrade properly. The opening screen still says version 1.22 and not version 2.0. I thought that maybe this was just a slight glitch with one file, but I then tried to go into a 2.0 version game being played over at Hyperloppy and I was rejected, with a message saying that I was using the wrong version of the game.

I originally had installed AEP first and then got BOE later and am sure that before I installed BOE I could select a Gloster Gladiator as my Finnish campaign aeroplane, yet once I had installed BOE, I couldn't select that particular plane.

Are these known bugs?

fi-bluedragon
04-05-2004, 07:49 PM
I have just found out that if you install Battle Over Europe over IL2-FB and then install Aces Expansion Pack afterwards, the game doesn't upgrade properly. The opening screen still says version 1.22 and not version 2.0. I thought that maybe this was just a slight glitch with one file, but I then tried to go into a 2.0 version game being played over at Hyperloppy and I was rejected, with a message saying that I was using the wrong version of the game.

I originally had installed AEP first and then got BOE later and am sure that before I installed BOE I could select a Gloster Gladiator as my Finnish campaign aeroplane, yet once I had installed BOE, I couldn't select that particular plane.

Are these known bugs?

PinkPriest
04-06-2004, 12:11 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> YOU CAN'T INSTALL AEP ON A 1.22 INSTALL. <HR></BLOCKQUOTE>


Wrong. I installed AEP over 1.22. Works fine.

Hawggy
04-06-2004, 12:16 AM
It's obvious these bugs are only happening to certain people, I have a partner who's had no problems at all - I'll re-phrase:

You're looking for trouble if you:

A) don't use the autorun feature to install FB, AEP may not find your game

B) patch FB up to 1.22, then install AEP, it may not install properly

But, hey, I was just reading the manual from AEP, which says it'll work fine up to 1.21. It DOESN'T say it WON'T work w/ 1.22, but it doesn't say it does, and that spells T-R-O-U-B-L-E...

"This is Chess, this ain't CHECKERS!!"

269GA-Maxmars
04-06-2004, 01:39 AM
I had that very same problem, when I decided to reinstall the whole flying circus.

My cure has been to do things in the following order:

1) Install FB starting from Autorun.exe file on CD-Rom, not Setup.exe (I have autorun disabled, therefore I tend to call directly setup.exe files).

This cured the missing "language=en_us" key in the windows registry. (There was a topic on the matter some time ago here)

2) Install AEP, always from the file pointed by the autorun.inf.

3) Install BOE, and patch it with the small patch found on justflight web site.

4) Add the latest version of Dgen/Ngen beta so I am sure that BOE didn't overwrite the AEP newest files (http://www.il2center.com/AEPplus.zip).

fi-bluedragon
04-06-2004, 03:14 AM
Thanks for that, Maxmar. I thought that I would have to start again and follow the order FB, then AEP then BOE. What I still find strange is that I'm sure that I started a Finnish campaign with a Gladiator when I first installed AEP and then when I installed BOE I wasn't given the option to select that plane - very strange!

fi-bluedragon
04-06-2004, 04:05 AM
I followed the order of installing FB, then AEP then BOE and everything is now fine again, but there is a definite bug regarding the Finnish campaign. After I installed AEP and before BOE, I went into the game and setup a campaign flying the Finnish Gloster Gladiator (J8A). I then installed BOE, and surprise, surprise, when you start a new Finnish campaign you can no longer select that particular plane, although you can continue flying it from the campaign that was set up earlier.

Hawggy
04-06-2004, 08:54 PM
MAN, WHERE DID YOU GUYS GET BoE?!?!?!?!? I don't have plastic, so I can't order it!!! WHERE CAN I GET IT RETAIL!?!?!?

http://ubbxforums.ubi.com/images/smiley/16x16_smiley-sad.gif

"This is Chess, this ain't CHECKERS!!"

steve_v
04-06-2004, 09:19 PM
fi-bluedragon

There is something amiss with your install proceedure. I have three hard drives on two computers with multiple installs and can get the J8A on all. (see below) You can continue here or at the Just Flight Forums.

http://forum.justflight.com/forum/forum.asp?FORUM_ID=16

http://home.earthlink.net/~viner45/sitebuildercontent/sitebuilderpictures/j8a.jpg

HH Quazi
04-06-2004, 09:53 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Hawggy:
MAN, WHERE DID YOU GUYS GET BoE?!?!?!?!? I don't have plastic, so I can't order it!!! WHERE CAN I GET IT RETAIL!?!?!?

http://ubbxforums.ubi.com/images/smiley/16x16_smiley-sad.gif

"This is Chess, this ain't CHECKERS!!"<HR></BLOCKQUOTE>

No retail. Only www.justflight.com (http://www.justflight.com) at this time. Sad but true. S!

http://www.angelfire.com/falcon/nightschpanker/QuasiPOWsmall.jpg

fi-bluedragon
04-07-2004, 04:54 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by steve_v:
fi-bluedragon

There is something amiss with your install proceedure. I have three hard drives on two computers with multiple installs and can get the J8A on all. (see below) You can continue here or at the Just Flight Forums.

http://forum.justflight.com/forum/forum.asp?FORUM_ID=16

http://home.earthlink.net/~viner45/sitebuildercontent/sitebuilderpictures/j8a.jpg <HR></BLOCKQUOTE>

Well Steve, all I have done is completely wiped Forgotten Battles from my hard drive including deleting the directory, then installed FB, then AEP then BOE in that order, and then when I go to the Finnish campaign there is no J8A to be selected. I tried doing the install the other way around (BOE then AEP), and everything runs fine but the start up screen shows the game version as 1.22 and when you try to enter a game on Hyperloppy which is a version 2.0 (AEP) server, you get a message saying you are running the wrong version. Have you actually tried joining a version 2.0 game at Hyperloppy yourself?

I think the possible problem lies in the fact that according to the AEP manual the add should be installed over either version 1.0 or 1.21 of FB, but if you install over BOE, you are actually installing over version 1.22, because BOE upgrades to that version.

God, this is confusing.

steve_v
04-07-2004, 08:50 PM
Just got in from work and have to sleep. Will get back with you tomorrow.

steve_v
04-09-2004, 06:02 AM
Have a short break from work.

I am going to reccommend a clean install. You may have already done this, but this method has not failed yet.

uninstall BoE from control panel
uninstall AEP from control panel
delete FB folder
delete desktop shortcuts
reboot

install FB box version 1.0
reboot
install AEP
reboot
install BoE
reboot

some notes:
you may want to keep the following files for the new install - Users, Missions, PaintSchemes, and conf. Place the conf. in the FB v1.0 install so AEP can add the water line to the conf. If you forget, you can add it yourself later. Water=1 to [Render_OpenGL].

(If you want to install BoE before AEP, do not install patch 1.22 when asked at the prompt. There have been reports by some of game instabilty when AEP is installed over patched versions. These were resolved by a fresh install.)

Until your install is complete and stable, do not add any "modified" files or attempt virtual drives as both may interfere with a normal install.

If you would like to have multiple versions/installs, here are two ways:

crazyivan1970: http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=63110913&m=330109682&r=358108682#358108682

IKP_Hawk: http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=49310655&m=314103891

fi-bluedragon
04-13-2004, 04:20 PM
Thanks Steve, it worked, I can now select the J8A and Fiat plane for the Finnish campaign. I did exactly the same install before but the big difference was I didn't reboot between each install section.

steve_v
04-13-2004, 07:17 PM
Glad you got it going. I am looking forward to the patch and the BoE update, specifically the Spit and P-38 campaigns. The western maps are a real joy.

edit: Posted - 11 Apr 2004 : 22:23:29

Can confirm now that there will be several models of Spitfire IX used in BoE RAF campaign as well as several models of AI B-25. The Spitfires will be used in all roles, including ground attack because they can carry bombs.
-Starshoy

http://forum.justflight.com/forum/topic.asp?TOPIC_ID=3713

[This message was edited by steve_v on Tue April 13 2004 at 07:06 PM.]