PDA

View Full Version : Choppy Fps on all graphic presets



Samwood231
10-27-2017, 05:54 PM
Is anyone else getting low choppy Fps no matter what preset they have on?

I'm running at 1080p on
980m sli
Intel i7 6700
16gb hyper x ram

Got latest 388 nvida driver also.

Really, really hope they add sli support soon as now.

No matter what graphic setting I use every benchmark I run, I keep getting a low result.

ConnorMCKenway
10-27-2017, 08:23 PM
Same man, did Ultra for fun and got 30 fps and then I did the lowest settings and got 35-40 fps.
1080p
GTX 1060 6gb
FX-8350
12gb RAM

ConnorMCKenway
10-27-2017, 08:24 PM
Very disappointed with this game.

RVSage
10-27-2017, 09:22 PM
Follow the steps , here hope this helps

https://www.reddit.com/r/assassinscreed/comments/791p70/psa_pc_tips_and_ticks_mods_stick_if_possible_will/

UbiFluouise
10-27-2017, 09:50 PM
Hello Assassins! Our team is happy to address any performance issues you're experiencing so that we can find the source of what may be causing this for you. If your system is able to launch the game and you're able to play, you're just not getting the smoothest experience graphically, please check out this article (https://support.ubi.com/en-US/faqs/000031701/Performance-Issues-in-Assassin-s-Creed-Origins-ACO/) with some additional information and instruction on how you can alleviate this if your system meets the requirements. If you've checked this over and nothing has helped what you personally are experiencing with your system, please create a Case with our technical support team (https://support.ubi.com/Cases/New) and tell them everything you've tried leading up to contacting for assistance, even if it has not worked for you. Also, please attach system files (https://support.ubi.com/en-US/faqs/000023904/How-To-Submit-Dxdiag-MSinfo/) to your Case as well, as this will help our team investigate the issue in greater depth with you. Thank you!

Dethtool_74
10-27-2017, 10:13 PM
Turning off SLI worked for me which I am running the same cards.

Samwood231
10-29-2017, 01:26 PM
Same man, did Ultra for fun and got 30 fps and then I did the lowest settings and got 35-40 fps.
1080p
GTX 1060 6gb
FX-8350
12gb RAM

Still choppy for me atm, I have been playing around with the settings, I am running on ultra 1080p settings with 40-50 fps. Occasional dips to 38. I Still would like sli support thought, garenteed 60 I reckon then.

I turned anti aliasing down to medium, but every thing else is on ultra. I also found strangley increasing the fov to 110 gave me a couple more fps.

Samwood231
10-29-2017, 01:27 PM
Turning off SLI worked for me which I am running the same cards.

A 1060 or a 980m sli system?