PDA

View Full Version : Gamepad Issues



iordanougiannis
10-27-2017, 01:52 AM
I am using a Logitetch RumblePad 2 to play the game but I have encountered some problems. A few of the actions are not performed correctly, while others are performed correctly.

These are the actions that are performed correctly by pushing the default button assignments:

moving, dodging, climb up and down, light attack.

The actions that are not performed correctly are heavy attack - shield break, aiming with the bow, crouch, the pulse and calling senu.

I have not checked every action but there are a few issues.

Is it because my gamepad is not supported. Do you have a list of supported gamepads ?

If I buy an XBOX controller for PC will I have any issues ?

I look forward to your reply.

Kraschman2010
10-27-2017, 08:04 AM
Having the same issue with the Rumblepad 2. Also of note the options appear to want to default to keyboard and mouse and do not persistently change even when buttons are pressed

danijel.1983
10-27-2017, 08:33 AM
Ever Since ACIII you had to play with Xbox controller (for pc). Since I donít own one I used some cheap no name Chinese controller and an Xbox emulator and it Worked fine (ACIII, BF, unity, syndicate). Without it the buttons were all mixed up.
Does anyone know if other controllers are supported now for Origins or are we supposed to play with Xbox controller for pc again?

iordanougiannis
10-27-2017, 09:52 AM
I tried using x360ce emulator but it didn't work.

danijel.1983
10-27-2017, 09:55 AM
I tried using x360ce emulator but it didn't work.
Same here. Not working or I canít set it up properly.

iordanougiannis
10-27-2017, 10:02 AM
The weird thing is some keys work fine but others glitch. Whenever I push the LT for heavy attack the icon for the leather needed in the first mission to create the chestplate, disapppears.

MKumitsu
10-27-2017, 10:22 AM
Im having similar issues while using Logitech Dual Action Pad. Even in main menu when I press any button, it seems to be pressed continuously. Keyboard and mouse work OK.
If needed, I can upload video showing the problem. Any feedback from the Devs?

iordanougiannis
10-27-2017, 11:38 AM
Looking at this page https://support.ubi.com/en-GB/Faqs/000031689/PC-Controls-for-Assassin-s-Creed-Origins-ACO/, it shows the picture of a XBOX controller, so it might imply that it is supported.

danijel.1983
10-27-2017, 11:57 AM
Xbox controller most likely is supported.
But like I mentioned earlier in my post I donít own one sadly and I used to play previous titles with x360ce emulator.
But since itís not working for Origins Iím thinking either I set it up wrong or something else is the matter.

iordanougiannis
10-27-2017, 12:02 PM
Xbox controller most likely is supported.
But like I mentioned earlier in my post I donít own one sadly and I used to play previous titles with x360ce emulator.
But since itís not working for Origins Iím thinking either I set it up wrong or something else is the matter.

Sadly, I am in the same position.

Ubi-Keo
10-27-2017, 01:23 PM
I am using a Logitetch RumblePad 2 to play the game but I have encountered some problems. A few of the actions are not performed correctly, while others are performed correctly.

These are the actions that are performed correctly by pushing the default button assignments:

moving, dodging, climb up and down, light attack.

The actions that are not performed correctly are heavy attack - shield break, aiming with the bow, crouch, the pulse and calling senu.

I have not checked every action but there are a few issues.

Is it because my gamepad is not supported. Do you have a list of supported gamepads ?

If I buy an XBOX controller for PC will I have any issues ?

I look forward to your reply.

The only supported controllers for the game are Xbox One and Xbox 360 controllers.

Kraschman2010
10-27-2017, 02:05 PM
Got it fixed... Now to preface this, I am running Steam, and on Windows 10 64 bit, so if you're not, it's possible your milaege may vary.

Here's what I did.

Went to http://www.x360ce.com/ and downloaded the 64 bit version of the software, copied the executable into my game folder, C:\Program Files (x86)\Steam\steamapps\common\Assassins Creed Origins. Then ran the program as admin.

The settings I used were basically those that were identified as presets for Unity, but they work here.

Under Controller 1: (I only have 1)

On the Advanced tab, set dead zones to 5% as apparently 0% does not always work. Did the same on the Left Thumb and Right Thumb tabs with Anti Dead Zone and Dead Zone for X and Y axis. Also set Force Feedback passthrough yo ON (checked) but haven't tried again in game to verify the feedback woks yet.

Now the most important settings.

Under Game Settings:

Select ACOrigins.exe, then for Hook Mask set COM, DI, PIDVID, STOP, LL SA, and WT to ON (checked), for XInput files, set all 64 bit options to ON, and Select 64bit for DInput file.

Save and exit the application,

Run Origins as normal and enjoy controller goodness. Both triggers and menu/map buttons work, as well as DPad.

This is the nicest looking AC game I've ever seen... Holeeeee crap on a cracker.

SashaSidorovich
10-27-2017, 02:20 PM
My PS4 dualshock run just fine

Kraschman2010
10-27-2017, 03:04 PM
Errata: Turn OFF force Feedback. It messes up the Y button functionality.

MKumitsu
10-27-2017, 05:57 PM
Got it fixed... Now to preface this, I am running Steam, and on Windows 10 64 bit, so if you're not, it's possible your milaege may vary.

Here's what I did.

Went to http://www.x360ce.com/ and downloaded the 64 bit version of the software, copied the executable into my game folder, C:\Program Files (x86)\Steam\steamapps\common\Assassins Creed Origins. Then ran the program as admin.

The settings I used were basically those that were identified as presets for Unity, but they work here.

Under Controller 1: (I only have 1)

On the Advanced tab, set dead zones to 5% as apparently 0% does not always work. Did the same on the Left Thumb and Right Thumb tabs with Anti Dead Zone and Dead Zone for X and Y axis. Also set Force Feedback passthrough yo ON (checked) but haven't tried again in game to verify the feedback woks yet.

Now the most important settings.

Under Game Settings:

Select ACOrigins.exe, then for Hook Mask set COM, DI, PIDVID, STOP, LL SA, and WT to ON (checked), for XInput files, set all 64 bit options to ON, and Select 64bit for DInput file.

Save and exit the application,

Run Origins as normal and enjoy controller goodness. Both triggers and menu/map buttons work, as well as DPad.

This is the nicest looking AC game I've ever seen... Holeeeee crap on a cracker.

It works like a charm mate, I mean it works in the menu cause when Im trying to start new game (or load my save) the game crashes. I will tweak with it tomorrow and leave some feedback here.

andrecirillo
10-27-2017, 06:08 PM
Thank you guys for controls customization, because you really invented a new way of playing and I just dont' get it. RB for light attack? WTF?

How about mapping hold actions to avoid button conflicts and more possibilites, so I could put strong attack on holding X, runing on holding RT and so on.

Kraschman2010
10-27-2017, 06:12 PM
It's been working swimmingly for me once I turned Force Feedback back off.

andrecirillo
10-28-2017, 03:25 PM
The custom control mapping is kind of broken, I've had to manually edit ControlMappings.xml to put assassinate and attack on X and interact and parry on B, as in the previous games.

svagbob
01-07-2018, 11:39 AM
On the Advanced tab, set dead zones to 5% as apparently 0% does not always work. Did the same on the Left Thumb and Right Thumb tabs with Anti Dead Zone and Dead Zone for X and Y axis. Also set Force Feedback passthrough yo ON (checked) but haven't tried again in game to verify the feedback woks yet.

Now the most important settings.

Under Game Settings:

Select ACOrigins.exe, then for Hook Mask set COM, DI, PIDVID, STOP, LL SA, and WT to ON (checked), for XInput files, set all 64 bit options to ON, and Select 64bit for DInput file.

Save and exit the application,

Dude! I had to log in to this forum and thank you. This saved me from buying a xbox controller!
You're awesome man.