PDA

View Full Version : 100% CPU usage on all cores, even on low. (Intel)



Tolrem
10-27-2017, 12:06 AM
Intel i5 4590
Geforce GTX 970

The game has 100% CPU usage on all cores, even on low, which results in unstable framerate and lots of stuttering. I know I don't have a high end config, but I should at least be able to run it on high with around 30-45 fps.

On reddit lots of users also have the issue, even on i7 7700k.

ZLounTV
10-27-2017, 06:31 AM
Try turning on V-Sync and thus limiting FPS to your refresh rate. If it doesn't work, try limiting your FPS in MSI Afteburner - RivaTuner Statistics.

Animator_Alex
10-27-2017, 06:50 AM
I am experiencing the same thing - I5 4670K

Stiler
10-27-2017, 07:43 AM
Same issue here on my 2600k oc'd @ 4.4 ghz, it gets to 100% usage across the board.

Harkkyn
10-27-2017, 09:03 AM
My oc'd 3770k 4.4ghz is experiencing this as well 100% usage on almost all cores and its paired with a 1080ti running at 1440p

JohnyW_PL
10-27-2017, 04:08 PM
For me (i5 4690K, 16GB RAM 2400MHz and GTX 1080 Gaming X) game I have very high usage on Core 1, 2 and 3. Core 0 is loaded 30-89% (never 100%) and during benchmark, in the city I see that FPS is going down from 60 FPS to 42-45.

I saw that it help me when I am in game and I change colligation to Core 0 only and again I change it to all cores. When I run benchmark again CPU usage was also high (that is good because it shows that game is using all PC power) but now game is running much more smooth (city part was 42-45 FPS and now it is 53-60 FPS) and all cores are loaded more equally

JPWiseguy
10-27-2017, 04:31 PM
JohnyW_PL's advice is solid, Ubisoft games tend to have that problem and doing that will make all cores run evenly.

But I have I found another fix for this as well...

Try running the game in a Borderless Window instead of Fullscreen.

I also have found that when GPU usage is too high, first thing you should do is leave your settings at highest level and reduce the Resolution Modifier until you find a good level without going up to 100%. THEN if it's still too much for your GPU, start bringing down detail settings as needed.

The_Warhound
10-27-2017, 04:34 PM
8700k using 70%-89% and running temps at low 70c - 78c, with a 1080ti, seems like this wasn't optimized very well.

JohnyW_PL
10-27-2017, 04:42 PM
I am using borderless window and for me chaning or rather "restarting" of colligation helps visible. It is worth to try both solutions and hope that Ubi can fix this is future updates :)

Zwetjee
10-27-2017, 05:53 PM
I've got the same issue.

my specs;
GTX 1080ti (fe)
I5 7600k @ 4.4 ghz
16gb ddr4 @ 2400 mhz.
ASUS ROG Switft 27" 1440p @ 144hz with Gsync.

So I did a couple of ingame bench....

1080P @ Highest preset. 72 FPS avr.
1440P @ Lowest Preset, 68 FPS avr.
1440P @ Highest preset, 58 FPS avr.
1440P @Highest preset and resolution scaling on 160%, 52 FPS avr.

With all tests the CPU and GPU latency was about 8- 13 ms.

all of the above benchmarks, the CPU was @ 100% constant.
I dont think this is a matter of CPU bottlenecking, this is a real bug concerning the optimizing the game, i hope an patch will come soon for this.

This is not unity... but they need to fix this. In city's high CPU usage is understandable. But in the deserts with almost no AI / NPC's walking around, the cpu should be lower

scotchty
10-27-2017, 07:44 PM
Im having the same issue my specs are Gtx 1070 , I7-6700 3.40 GHz and 32gigs of ram

pilot2fly89
10-27-2017, 08:28 PM
Same issues, CPU anywhere from 85-100%. i7 4790k, 16gb ram, gtx 1080 sc, 1080p resolution

Black.Aria
10-27-2017, 08:54 PM
I am having this happen, it is also crashing all the time. I have updated everything and restarted and did verify a bunch.
I have tried every setting and I get the same thing happening.

I have a I74770k at 4ghz
24gb ram
64bit
2X SLI GTX 970, I have taken one card out and its the same.
I have switched to a SSD and 2 HHD's still the same for me.

UbiFluouise
10-27-2017, 09:07 PM
Hello everyone! So if anyone is experiencing some irregularities or is noticing that the game isn't running as smoothly as expected, there are some things listed in this article (http://https://support.ubi.com/en-US/faqs/000031701/Performance-Issues-in-Assassin-s-Creed-Origins-ACO/) that you can look into to see if this helps to improve the performance. If you've exhausted this list of things and it still has not improved on what you're experiencing, please bring this to the attention of our technical support team (https://support.ubi.com/Cases/New) and attach your system files (https://support.ubi.com/en-US/faqs/000023904/How-To-Submit-Dxdiag-MSinfo/) on first contact so our team can provide some insight on the matter for you. It would also be beneficial to you to list the steps from the article, or any other additional troubleshooting, that you had tried prior to reaching out for further assistance as well so the agent that helps you will be able to proceed with you without suggesting repeat steps. Thank you!

AOD_SN0ST0RM
10-27-2017, 10:57 PM
Same here 6700k at 100% usage in cities, my 1080ti isn't hitting 60% usage, the game has some serious utilisation issues

JPWiseguy
10-28-2017, 01:14 AM
Well, my borderless window trick didn't work as well as I had originally thought, but it does help a little along with the ALT-TAB CPU affinity trick. I have had to lower my settings to very high @ 1080p resolution, that has helped more than anything to keep a stable frame rate, although I still see frame rate drops and 100% CPU usage most of the time.

The stuttering cinematics are really annoying. Game definitely needs a big fat patch...or two...and I'm sure UBI will do just that.

Intel i5-4670K @ 4.4 GHz
Gigabyte GTX 1070 SC @ 2 GHz
16GB 2400 MHz RAM
500GB Western Digital 850 EVO SSD
Windows 10 (Fall Creator's Update)
NVIDIA Driver 388.10

Voidolt
10-28-2017, 02:07 AM
Same problem. I have around 80-100% CPU Usage... Please Ubisoft fix it or if not then i want refund... So i'm not playing right now untill patch came out.

pilot2fly89
10-28-2017, 02:40 AM
So I did a little playing around. In the starting city of Siwa, I get lots of FPS drops and my CPU is anywhere from 95-100%. As soon as I leave the city, total CPU usage drops dramatically to around 65% and FPS is at a stable 60 with little to no hitches.

jerryvn
10-30-2017, 10:04 PM
The reason for 100% CPU is from doubled layer of anti-crack system Denuvo and VMProtect.
"Basically, Ubisoft have implemented VMProtect on top of Denuvo, tanking the game’s performance by 30-40%, demanding that people have a more expensive CPU to play the game properly, only because of the DRM."

Source: https://torrentfreak.com/assassins-creed-origin-drm-hammers-gamers-cpus-171030/