PDA

View Full Version : Clicking sound



Yiakubou
10-26-2017, 11:17 PM
As soon as the game launches, I get a repeating clicking sound and have to turn the volume down. I'm using Creative Soundblaster HD USB through speakers (no headset as reported in another thread). Never had a similar issue before or in any other game / app. Using standard Windows 10 drivers. At this state the game is unplayable for me. The clicking sound persist when I turn the volume down in game options.

darkerdark2007
10-26-2017, 11:50 PM
i have the same problem light noise during dialogs i have asus G20-CB Realtek Audio Driver V6.0.1.7560

ludicrousNATION
10-27-2017, 12:32 AM
I'm getting a constant clicking noise with the audio in this game, using a creative x-fi usb card connected to speakers and up to date drivers. Don't have this issue with any other game. Ideas?

NetQvist
10-27-2017, 12:35 AM
I had a very weird constant crackling sound issue, sound was fine in everything else as well. Decided to install the newest realtek drivers from the mobo manufacter (asus maximus ranger vii) and it started working fine.

kariminator_x
10-27-2017, 01:35 AM
Me too, the sound is slightly distorted (sizzle) on Sound Blaster Z with Home Cinema. All ll my drivers are up to date.
Really annoying, since the time I was waiting for that game.
Any help would be appreciated.
Thank you in advance.

Sorry for my bad English.

TeddyBrosovelt
10-27-2017, 01:38 AM
I'm having the same exact issue as everyone else in this thread. I'm using a Creative Sound Blaster Omni Surround (USB). The moment that I launch the game the only output through my speakers is the same clicking/whine.

Dimv92
10-27-2017, 04:20 AM
Same here. Asus Xonar DG, PCI

UbiGabrinth
10-27-2017, 04:58 AM
Hello everyone. A user in another thread (http://forums.ubi.com/showthread.php/1774025-Sound-is-broken-(not-just-ingame)) recommended changing your default playback device as a potential workaround to this issue. Can anyone effected try doing so both after the sound begins and also after a computer restart while the clicking noise isn't occurring? Please get back to me with any results or lack thereof.

Yiakubou
10-27-2017, 12:35 PM
Hi there,

I can confirm that changing the default playback device to something else works. I changed this to nVidia High Defintion Audio output (which is basically sound going from my graphics card to monitor speakers through display port). But this is a pretty bad workaround, since I want to use my Sound Blaster HD with my good speakers, which has much better sound quality output - not the crap going through monitor speakers.

I did not bother to switch to my Realtek sound integrated on the MBD - I would have to reroute some cables, but I'm sure this would work as a workaround as well.

However, I have found a better workaround that let's me keep using my soundblaster:

- Go to your soundblaster control panel
- Disable all effects, uncluding THX, EAX or even equalizer.
- Launch the game

I had equalizer ON and THX Crystallizer effect ON. As soon as turn these OFF and start the game, I only get one click sound when the game launches and then everything is fine. If you want to play with some effects ON, what works for me is also to start the game with everything disabled, alt+TAB and enable everything while the game is running.

If you're not sure about these settings, you can also:

- go to Windows device manager
- find your sound driver and update it automatically by Windows through internet.

This has downloaded a driver dated with year 2017 for me (Creative have only drivers from 2016 on their official support page) and this will also reset all your sound settings (meaning all your effects are disabled by default). So if you never played with the creative control panel, just update the driver through device manager - it will not fix the issue that is clearly in the game, but at least you can play.

Yiakubou
10-28-2017, 01:45 PM
I just want to update this post saying that despite my above workaround works for me (anyone with Soundblaster HD should try), I am still seeing (hearing) issues reported by others, although they do not prevent me to play the game:

- The sound overall is kinda flat. Changing the audio dynamic range in audio options seems to affect this somehow. In high mode the sound volume is lower than other apps, in night mode the volume gets balanced to the normal level.

- In cutscenes, the voices are very low - without subtitles enabled, it is quite impossible to hear every word.

Yohei_Mito
10-28-2017, 03:15 PM
Same problem here!!, but I use headphones Hyper Cloud X (kingston)

I have not yet tried disabling the equalizer on my motherboard. All my drivers, both video, windows 10 and audio, are updated to their latest versions.

I hope Ubi is already thinking about fixing this in the next patch!

Cheers.

Blasta101
10-28-2017, 03:27 PM
There's a static noise in the game sometimes when you boot it, can go away if you restart - but upon booting another time can reoccur.

Yiakubou
11-02-2017, 07:22 PM
Just to update, all my audio issues are now fixed with 1.03 patch. Thanks!

Yiakubou
11-02-2017, 07:32 PM
ok, nope! After restarting my PC it looks like all these issues are still there. The best workaround in order not to compromise your audio quality is still to disable all playback devices (even the default one that you use), launch the game, alt+TAB back to desktop and enable the playback device you use.