PDA

View Full Version : Riven question...



jam777
12-05-2003, 05:42 PM
While (still) waiting for my invite into URU Live, I have decided to re-visit RIVEN. However, the intro splash screens have no sound, nor do any of the movies that play during the game. All other sounds are okay. I've tried different versions of Quicktime and also different compatibility modes, but to no avail, still no sound. Anybody have any ideas?

Pentium 4 3.0 ghz
512 megs ram
Leadtek Geforce FX 5900 Ultra 256m ram
Sound Blaster Audigy 2 ZS
Windows XP Pro

jam777
12-05-2003, 05:42 PM
While (still) waiting for my invite into URU Live, I have decided to re-visit RIVEN. However, the intro splash screens have no sound, nor do any of the movies that play during the game. All other sounds are okay. I've tried different versions of Quicktime and also different compatibility modes, but to no avail, still no sound. Anybody have any ideas?

Pentium 4 3.0 ghz
512 megs ram
Leadtek Geforce FX 5900 Ultra 256m ram
Sound Blaster Audigy 2 ZS
Windows XP Pro

maztec
12-05-2003, 06:55 PM
perhaps audio codec? .. or an older version of quicktime.. perhaps hte one tha comes on the cd with it?

jam777
12-06-2003, 09:53 AM
Thanks for your reply. http://ubbxforums.ubi.com/infopop/emoticons/icon_smile.gif

I tried uninstalling all versions of Quicktime and Quicktime32 and even tried installing the version off of the cd. But no luck. I had a feeling that it might be a codec, but which one? Is there some sort of way to find out which codec Riven requires?

maztec
12-06-2003, 11:06 AM
no clue myself.. see if there is a readme on the disk and if that contains any information?

jam777
12-06-2003, 03:35 PM
Will do.

Thanks

cbfromvt
12-09-2003, 06:17 AM
When I originally installed Riven on PC with Windows XP, had sound problems. The following procedure worked for me and the program runs as expected.

This is how I installed step by step:
IF Riven is installed, uninstall it.
Install Riven CD 1 into drive.
Red Orb Entertainment window opens automatically.
Close Red Ord Entertainment Window.
Right click drive Riven CD is in, then Click - Explore.
Right click SETUP icon.
Select Compatibility Mode Tab.
Check - Run this program in Compatability mode box - then select Win98/ME - Click OK.
Double click Setup icon, install process should begin.
Follow the instructions to install (I used recommended setup).
Click START - Programs - Riven, then right click Riven icon and make sure Run this program in compatibility mode is NOT checked - click OK.
Click START - Program - Riven, then right click Riven icon, then Click - Send to, and finally Click - Desktop(create shortcut).
Click the desktop icon just created to start the game.

My Computer:
Home built, Epox 8RDA+ Mother Board, AMD 2600 CPU, 512 MB PC3200 Memory, GeForce 4 TI 4400, Soundblaster LiveX Gamer 5.1, Windows XP Home Edition. This system had Quick Time Version 6.4 installed prior to installing Riven. Did not recieve any message regarding sound during install process.

Wifes Computer:
Home Built, Epox 8KHA Mother Board, AMD 1800 CPU, 512 MB PC2100 Memory, Voodo 5 5500, Onboard Sound (AC97 Digital Audio by VIA), Windows XP Home Edition (Upgraded Windows 98). This system did not have any Quick Time Programs installed, so was prompted to install from Riven CD.

Let me know if this works on your PC.

Good Luck,

CB

jam777
12-09-2003, 07:20 PM
Well, I did what you suggested and still no sound coming from the movies. http://ubbxforums.ubi.com/infopop/emoticons/icon_mad.gif

I appreciate your help, though.

Got any other ideas?

cbfromvt
12-09-2003, 08:53 PM
The only other thing I can think of would be to try using onboard sound, if your motherboard has that feature. A real long shot and a bit messy.

CB

Rocky1138
12-09-2003, 09:33 PM
Did you make sure you have your speakers on?

Your audio drivers installed?

Your audio card turned on in the BIOS?

Is your volume up?

DrewKempa
12-10-2003, 09:34 AM
The issue is with the quicktime movie sound driver I believe. I know I had the exact same problem.

It's to do with the mohawk.dll (or another native American tribe sounding name .dll) in the root directory of your Riven installation. I think I edited it (in notepad) and changed a setting. Just can't remember what it was (at work atm)

DrewKempa
12-10-2003, 06:21 PM
Just checked.

Go to Riven folder and open the file "mohawk.w32" with notepad. Find the line with "fEnableAudioProxy=true" and change it to "fEnableAudioProxy=false"

That worked for me.

jam777
12-10-2003, 10:29 PM
Well, whaddya know!! It worked! And all this time I thought it was a codec. Damn!

Thanks DrewKempa! I was just ready to give up and uninstall, too. Thanks again.

And thanks to everybody else for all the great suggestions.

http://ubbxforums.ubi.com/infopop/emoticons/icon_cool.gif

DrewKempa
12-11-2003, 05:55 AM
You're welcome. Glad you're up and running...

cbfromvt
12-11-2003, 06:18 AM
Hello,

Glad to hear you are able to play Riven. Just checked my system and the mohawk.w32 line states "fEnableAudioProxy=true".

Computers http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

CB

jam777
12-11-2003, 09:03 PM
Geez!! Talk about Murphy's Law!
I finally get Riven up and working correctly and then the DRC goes and sends me my invitation to URU Live! Wow!

This is definitely not a bad thing! Woohoo! http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

I guess Riven's gonna hafta wait. http://ubbxforums.ubi.com/infopop/emoticons/icon_wink.gif

Auscreely
12-11-2003, 09:07 PM
I just run it in "Windows 98" Compatibility mode, and all works http://ubbxforums.ubi.com/infopop/emoticons/icon_smile.gif

~Auscreely~

flashgordon59
12-12-2003, 01:22 PM
exactly how do you open a file with notepad?

flashgordon59
12-12-2003, 01:36 PM
i'm thinking go to "my computer" and right click the e drive with riven disk one in it; then click explore.

But, there's no folder with just a riven subtitle. I see setup, program, all, assets, and other such subtitles, but no "riven" folder.

flashgordon59
12-12-2003, 06:20 PM
i went to start, programs, riven, right clicked the riven and wen to properties.

Properties gave me a pop up with general, shortcut, and compatibility tabs. Going to shortcut tab gave me an option of "find target" which showed a list of options including one with mohawk subtitle. It says it can't open; i don't know how to open with notepad I think?

flashgordon59
12-12-2003, 06:28 PM
well, I don't know if I was suppose to open mohawk from the path I went from; i don't know if going through start was your root installation, but I found a way to open mohawk with notepad from the path I found mohawk. I got nothing about enableproxyfalse or true, and now I can't undo opening mohawk from notepad.

Methinks
12-12-2003, 06:57 PM
One other thought...
Have you installed the patch?

cbfromvt
12-14-2003, 06:56 AM
Hello,
If you installed the game in the dafault directory, the game should be in C:/Program Files/Riven. That is the path you should follow to get to the Mohawk.w32 file. If you have already opened this file with notepad once, the icon will be a notepad icon. You should be able to just right click the icon and then click open. This is where you should find the mohawk.w32 file.
Good Luck
CB