PDA

View Full Version : LOVE this game but having lag issue since oct5 update



Zombie.Mantis
10-08-2017, 12:47 AM
Hi, I'm getting a little constant lag or stutter. its so small that its hard to notice but i can feel it in my gameplay, such as missing parries and even blocks that i used to find easy to do. I've changed setting to low and shadows etc. but nothing. so would this be an issue of my video card or more from my internet? ill tell u my specs. Nvidia 970 card, and my connection speed is 300 down and 30 up. I'm sure my net can't be the issue but any advice would be great. maybe its the update since all was better before that. am i getting lagged down if I'm playing against a slower connection speed? will i lag to stay with him? is it more the video card or the connection? please help. this is my favorite game despite of the issues but i can't really play much now due to the frustrations of lag and inputs feeling a bit off, prob due to the lag. and would dedicated servers fix lag issues due to connections? thanks! please advise me anyone. keep up the good work ubi. i know your trying to make the game better and i know you get lots of ****. I'm confident the game will get to a point where its amazing on all things!!! playability is first priority to me over balancing heroes.Thanks UBI u rock!

Halvtand
10-08-2017, 10:16 AM
In another thread someone reported that a clean install fixed it. If you are able, please try to uninstall both the Uplay client and for honor, then redownload and install both.

Zombie.Mantis
10-13-2017, 07:05 AM
hmm, really good idea. ill give that a shot! thanks!