PDA

View Full Version : Xplain this



GMG Peter
06-29-2017, 02:43 PM
Today I was switching from xbox console to other one in the living room. I don't know if there was some update today but I did have to did one because it was long ago, when I played FH in living room..

So here's the thing my old TV was full HD 100hz LED (so #hit) and where it was, was a miserable wifi signal, but the game did run "smooth" for me (issues were mostly from server not me)
Now I run the game on 4K 1000hz TV which should be MUCH better and faster(not to mention better wifi signal)..it is better in color etc. BUT - my chars feel now ultra slow compared to others. While the others have their speed still same as before.

I simply cannot hit the parry or counter GB window with that and to deflect with my orochi is almost impossible now! I played vs few LB's today and they are heavy classes supposed to be slow, but they were faster than my assassin class wtf? Before I was able to switch stance with orochi (wich is like very fast) LB was able to change his attack directions way more faster than orochi was able to even switch defense.

And no I am not noob, not the best but since the beta I have played hundreds of hours and I was able to have solution to most of the exploits and spammers, the problem was always focus and tactics but this is very another case.

I had really lot of moments like "I will never play this piece of broken game again, because there was and are big balance and server issues, but on contrary to this I did persist till now playing this game. But now I am frustrated on whole another level lol.

Draghmar
06-29-2017, 03:02 PM
The game output 1080p on the consoles from what I know so it must by scaled up by your TV and that adds a few ms.
And did you turn any enhancement off? Or some Game Mode on? Visual filters adds great deal of lag.

SirCorrino
06-29-2017, 03:25 PM
With a new TV there's likely a difference in screen delays. Make sure you have gaming mode on to minimize it, or turn off any form of enhancements to the screen.

Also, look up both your old TV and the new one online to find the delay for each of them. You might be surprised to find that your new one has a higher delay.

GMG Peter
06-29-2017, 03:27 PM
Ah the TV mode could solve it. Thanks very much. And the upscale yes that could add a few ms that didn't hit me before

UbiNoty
06-30-2017, 12:36 AM
If you're still having problems you might want to hit up support (https://support.ubi.com/en-us/Games/4315) - they may be able to give you a few tips for optimizing to your new tv.