PDA

View Full Version : Game unplayable lately?



BABONIM
05-12-2017, 10:18 PM
for two days I have noticed a significant decrease in consistency of the game. It feels like the game is sluggish and I cannot connect any of my free light chains with classes that offer it (Warden and Orochi). I have no idea what the fault is here but I can tell you right now the game is very very unresponsive to me which is weird because I have 100mb download fios internet.

has anyone else experienced this as of late?

XxHunterHxX
05-12-2017, 11:38 PM
Its coz the population of the game is small so you end up with a host from antartica or zimbabue and if they have a ****ty internet and host the game then you will have a laggy game >_> i had games that a most people could guard break me or spamm me and i couldnt do anything evrithing was to slow...coz this game works by you seeing the animation so if you see a guy going for a guard break and you ir to slow then off the cliff with you...so your only chance is to play eather warden and spamm sholder bash or play warlord and keep pushing people off thats what is the game at the moment....

BABONIM
05-13-2017, 09:04 PM
well on my screen it says their connection is at the good range which is all green but some how the game is very inconsistent in registering my inputs. Not only that sometimes impossible things happen like a person counter guard breaking my guard break when i had just parried his attack and guard broke him.

The other day I was playing a warden and I threw a person to a wall and went for my guaranteed top heavy and they actually managed to block it on a duel setting. Has anyone else been experiencing these weird issues of late.

Infidel.Castro
05-13-2017, 09:10 PM
It's been horrible today :(

Infidel.Castro
05-13-2017, 10:41 PM
Well I dropped down to NAT yellow and that has seemed to help a little, though still a bit laggy at times.

UbiNoty
05-14-2017, 12:00 AM
Log in a ticket with support (https://support.ubi.com/en-us/Games/4315)! Make sure to mention what region you're in, and perhaps the times you usually play, what game modes you're trying to play in, etc., and we'll look into it.

CaynAldan
05-14-2017, 12:11 AM
It's the same for me. Hits passing through my guards or my guaranted attacks being blocked

BABONIM
05-15-2017, 08:26 PM
My biggest issue is the free chain attacks such as wardens side attack and orochis top light attack not registering leading to a easily parriable slow side attacks. This happens so many times because I would get a guaranteed top light attack and I know its going to hit but when I press the attack button second time it does not register right away for some odd reason and register few frames later when I have my mouse in a different guard position.

This is very frustrating and I want to propose that we just make the free chain hits automatic eliminating the possibility of ****ing this up due to input lag.