PDA

View Full Version : Assassin's Creed II Not Launching in the slightest



ninjaxflipper
04-22-2017, 11:14 PM
I purchased AC2 on steam, after going through the installation and the uplay login I tried starting the game and it didnt work. It would make my screen go black (except for a small white square to the top left for some reason) for about 1 second then it'd just close with no error given. People have told me to try uninstalling and updating uplay because apparently there was a thing about AC2 being released with a early version but it made no change to it.
Nothing on https://support.ubi.com/en-US/faqs/000025513/General-PC-Troubleshooting worked for me either

strigoi1958
04-23-2017, 12:54 AM
First you should go to your steam library and click the right mouse button on Assassin's creed 2, go to properties then select the Local files tab and click the Verify integrity of game files... button.



Try a different graphics driver and make sure vsync is turned on.

if that does not fix it


Contact steam and Ubi support and open a ticket (tell them what is wrong)
You should post the spec of your pc, including
what CPU
what GPU
how much RAM
HARD DRIVE SIZE
which version of windows are you using.

ninjaxflipper
04-23-2017, 06:39 AM
First you should go to your steam library and click the right mouse button on Assassin's creed 2, go to properties then select the Local files tab and click the Verify integrity of game files... button.



Try a different graphics driver and make sure vsync is turned on.

if that does not fix it


Contact steam and Ubi support and open a ticket (tell them what is wrong)
You should post the spec of your pc, including
what CPU
what GPU
how much RAM
HARD DRIVE SIZE
which version of windows are you using.


Okay I figured it out
My ******* realized that I had AC2 installed on my hard drive but uplay was installed in windows.
I just reinstalled it in windows and wowie it works just fine