PDA

View Full Version : X45 with another joystick controller problems



sgaletti
02-29-2004, 01:59 AM
I just bought a X45 and installed Dhauzimmer's drivers. I alse have an additional joystick with CH rudder pedals on my gameport which is seen as the first input device. I use the additional joystick onlyu because the CH analog pedals need it. I succed assigning the correct control axis to the game (ID2 for X45) but he HW input calibration screen on FB still shows me the 1^ device joystick, so I can't set the axis sensitivity, dead zone etc. etc., and if the first device is decalibrated (very often since it's broken) also my X45 is decalibrated.
Is there a Fix?
Thank you

Gianluca

sgaletti
02-29-2004, 01:59 AM
I just bought a X45 and installed Dhauzimmer's drivers. I alse have an additional joystick with CH rudder pedals on my gameport which is seen as the first input device. I use the additional joystick onlyu because the CH analog pedals need it. I succed assigning the correct control axis to the game (ID2 for X45) but he HW input calibration screen on FB still shows me the 1^ device joystick, so I can't set the axis sensitivity, dead zone etc. etc., and if the first device is decalibrated (very often since it's broken) also my X45 is decalibrated.
Is there a Fix?
Thank you

Gianluca

GAU-8
02-29-2004, 02:57 AM
ya know..i have the same problem...

the stick side of my X45 finally broke, i replaced it with a new one. i was going to use the throttle (from broken stick) as a "bombers sight quadrant" for the HE-111, an TB3..
ALAS..
no matter what i do.. only the broken stick shows up for "active" rather than the new one...dowsnt matter what the ID is, or whats plugged in first, or calibrated. both throttles work, but only the broken stick is recognised in FB if both are plugged in.

BEARCAT..got a solution?

Bull_Pup
02-29-2004, 03:03 PM
Look for this section in your conf.ini,

[rts_joystick]
X=0 0 0 0 0 0 0 0 0 0 0
Y=0 0 0 0 0 0 0 0 0 0 0
Z=0 0 0 0 0 0 0 0 0 0 0
RZ=0 0 0 0 0 0 0 0 0 0 0
FF=0
U=0 0 0 0 0 0 0 0 0 0 0
V=0 0 0 0 0 0 0 0 0 0 0
1X=0 0 0 0 0 0 0 0 0 0 0 0
1Y=0 5 10 17 25 33 43 54 71 87 100 0
1RX=0 0 0 0 0 0 0 0 0 0 0
1RZ=0 0 0 0 0 0 0 0 0 0 0
1U=0 0 0 0 0 0 0 0 0 0 0
1V=0 0 0 0 0 0 0 0 0 0 0
1Z=0 8 19 29 39 51 62 75 86 100 100 0
1X1=0 3 7 15 25 35 50 66 84 100 100 0
1Y1=0 5 10 17 25 33 43 54 71 100 100 0
1RX1=0 100 100 100 100 100 100 100 100 100 100 0
1RZ1=0 0 0 0 0 0 0 0 0 0 0
1U1=0 100 100 100 100 100 100 100 100 100 100 0
1V1=0 100 100 100 100 100 100 100 100 100 100 0

Those are the controller axis sensitivities. the zero's are unused axis in my setup.

I have an X45 (id2) and ch usb pedals (id1).
The following axis correspond to them in my setup,

1Y = Brakes
1Z = Rudder
1X1 = Roll
1Y1 = Pitch
1RX1= Prop Pitch
1U1 = Throttle
1V1 = Elevator Trim

You can determine what axis you need to tweak by editing your conf.ini to void each axis, one at a time, and map whats' what. Fill one axis with zero's and see what stopped working in game. repeat the process.