PDA

View Full Version : Shugoki Demon embrace problem on pc



Sarutahik0
02-28-2017, 10:08 PM
Hi Just for informations if some of pc players has the same problem.

The Demon Embrace of shugoki using S + MBM is working 1 of 10 times sometimes he just guardbrake and it s annoying taking out stamina and make you kill most of the time.
So please can it be possible to be fixed at least for keyboard and mice players.

Thanks a lot.

NB: Ahhh and the P2P disconections before the last kill player on dominions it s not fun !!!

Chanceofwar
02-28-2017, 10:53 PM
I feel you have a little hostility for everyones lord Shugoki so we here at Shugkoi.Love.org want to offer you a 3 day program where you get your very own Shugoki that you will bond and do lots of hugs and learn how to appreciate everyones favorite hero.

Lokthama
05-02-2017, 07:16 AM
Hi Just for informations if some of pc players has the same problem.

The Demon Embrace of shugoki using S + MBM is working 1 of 10 times sometimes he just guardbrake and it s annoying taking out stamina and make you kill most of the time.
So please can it be possible to be fixed at least for keyboard and mice players.

Thanks a lot.

NB: Ahhh and the P2P disconections before the last kill player on dominions it s not fun !!!

same here whenever im low health especially and its important that it lands. i parry and wallbang and immediately hold back. then he just gb's.... its infuriating and i cant figure out what could be the problem. its just getting me killed in situations where i obviously should win.

kweassa1917
05-02-2017, 07:41 AM
It seems the "↓ (S)" command needs to register after whatever previous action you've taken, and does not "queue-up" as with attacks. So, I think, in theory, it's set up that the "S" input needs to register for at the minimum 0.17s (= at least 1 frame) AFTER the recovery time of whatever your previous action was.

Like, if you do an attack or something, and then hold S back and press MMB too early, the "S" does not register and the input is lost during recovery time, but only the MMB input registers... but if you hold S until the recovery time is undoubtedly over, and press MMB after you see the Shug flinch backwards, then it fires up.