PDA

View Full Version : UBISOFT SHOW SOME PROFESSIONLISM - Stop Ignoring !



Masser_V
02-09-2017, 03:39 PM
Once again , another For Honor beta comes and GTX TITAN owners can't play because........................................... .................? Well , we don't know because UBISOFT doesn't answer our threads or our tickets until after the beta closes which they state " Sorry about your issues but the beta is now closed" This is not what proferssional companies do.

UBISOFT , you have known about these issues, we have all sent DX Diags , crash logs EVERYTHING TO HELP YOU SOLVE THIS and what have you done in return?


IGNORE US

Your tech test worked just fine on TITANS , yet these beta won't even launch. Ghost Recon Beta's also worked fine on TITANS. I was looking forward to purchasing both these games but I will not give a company any of my money that ignores me.

Maybe show some professionalism and respond to the TITAN threads or otherwise lose even more customers.

You claim your company is about doing what right in an industry plagued with shady company practices like unfavorable YouTube harassment of negative reviewers, hired reviewers to boost game ratings etc and albeit you shun this behaviour , IGNORING customers with issues directly creates resentment towards you and is a major step in the wrong direction.

I wouldn't even mind if you told us " Honestly , we don;t know why this is happening" at least thats something sincere and its better then being ignored

Gareths213
02-09-2017, 03:42 PM
Don't be mad friend, everything will be fine. I'm here for you.

Tronny666
02-09-2017, 03:44 PM
Don't be mad friend, everything will be fine. I'm here for you.

Me too, let's forget about this, go out pop couple of beers.

IMurdocI
02-09-2017, 03:46 PM
please check the support forums and Known issues before posting a new thread:

http://forums.ubi.com/showthread.php...4-Known-Issues (http://forums.ubi.com/showthread.php/1571436-PC-XB1-PS4-Known-Issues)


[PC] 1st Gen Titan graphics cards do not work, although they worked in previous tests



nVidia is informed about the issue and working on a solution.
Possible workaround: Uninstall & reinstall graphics drivers.

FredEx919
02-09-2017, 03:47 PM
Masser_V,

We try to get to every thread we can, but as you may have noticed there is a high load so we may not catch your specific thread every time. Because you aren't seeing a response where you are looking, it doesn't mean we're ignoring you. I would highly suggest checking in the known issues. It specifically mentions titan cards. As with all other known issues (http://forums.ubi.com/showthread.php/1571436-PC-XB1-PS4-Known-Issues), we'll update the list and everyone once a solution is available. Closing up this thread as this is listed in the known issues thread. Make sure you're checking there before posting.