PDA

View Full Version : Assassin's Creed: Unity PC Crashing



Greek_Hylian
01-31-2017, 10:00 PM
Even though the game runs fluidly, without problems, it crushes every time!! The amount of time it needs to occur varies and it has nonthing to do with what happens in the game! It just crushes and throws me to the Windows Desktop.

My laptop is Asus N550 JK with i7, 8GB Ram, GTX 850M and all the up-to-date drivers.

I had heard about Unity's problems but I hoped they would have solved them till now...

Is there a solution?

GhostAssassinLT
01-31-2017, 10:16 PM
Do you get any error message when the crash occurs?
We need more information in order to be able to help you, just saying it crashes unfortunetly doesn't give us a lot to go on.

strigoi1958
01-31-2017, 11:29 PM
Laptops are not officially supported and your laptop is below the minimum recommended spec. For a laptop, yours is quite good but the i7 4700HQ is slower than the minimum i5 2500k plus the GTX 850M performance is below the gtx 680. I think it might still run but the demand on your laptop is huge, especially if you go to anywhere that has a lot of detail or crowds. If it crashes in the same places it might that your laptop is struggling. Unity does't have problems, when it launched it had a few minor glitches but no game breaking bugs, people were upset because of the requirement specs but the games is so huge it needs a powerful pc to run.

As LasseThid asked is there a message? Acu.exe has stopped working ... or something similar?
What windows are you using? 7, 8, 10?

Anyway, possible fixes.

make sure your laptop is not overheating, I bought a laptop cooler with fans built in that my laptop sits on. It has stopped lots of crashes in games and programs.

Find the Acu.exe and delete it then verify your game files so it downloads again and checks for damaged files.
turn off all background tasks, (antivirus and anything else you do not need to be running) your cpu needs all it's power just for the game.

if you have geforce experience uninstall it, it uses a lot of cpu resources and it can cause games to crash

Make sure you have .Net Framework 3.5 and 4.0 installed. for 3.5, go to Programs and Features and click on Turn on/off windows features on the left, select .Net Framework 3.5 checkboxes and then press ok, for 4.0, download it from Microsoft website.
.

Greek_Hylian
02-01-2017, 11:33 AM
Do you get any error message when the crash occurs?
We need more information in order to be able to help you, just saying it crashes unfortunetly doesn't give us a lot to go on.

No there's no message! Just crashes and throws me to the Desktop!!

Greek_Hylian
02-01-2017, 11:35 AM
My laptop runs the game flawlessly in 1080p!! It runs smooth as butter! It just crashes suddenly, without obvious reason and in no specific occasion.



Laptops are not officially supported and your laptop is below the minimum recommended spec. For a laptop, yours is quite good but the i7 4700HQ is slower than the minimum i5 2500k plus the GTX 850M performance is below the gtx 680. I think it might still run but the demand on your laptop is huge, especially if you go to anywhere that has a lot of detail or crowds. If it crashes in the same places it might that your laptop is struggling. Unity does't have problems, when it launched it had a few minor glitches but no game breaking bugs, people were upset because of the requirement specs but the games is so huge it needs a powerful pc to run.

As LasseThid asked is there a message? Acu.exe has stopped working ... or something similar?
What windows are you using? 7, 8, 10?

Anyway, possible fixes.

make sure your laptop is not overheating, I bought a laptop cooler with fans built in that my laptop sits on. It has stopped lots of crashes in games and programs.

Find the Acu.exe and delete it then verify your game files so it downloads again and checks for damaged files.
turn off all background tasks, (antivirus and anything else you do not need to be running) your cpu needs all it's power just for the game.

if you have geforce experience uninstall it, it uses a lot of cpu resources and it can cause games to crash

Make sure you have .Net Framework 3.5 and 4.0 installed. for 3.5, go to Programs and Features and click on Turn on/off windows features on the left, select .Net Framework 3.5 checkboxes and then press ok, for 4.0, download it from Microsoft website.
.

Greek_Hylian
02-01-2017, 12:37 PM
UPDATE: The game crushes even if I let it idle in the Main Menu, before even loading a game!! The message is: "ACU has stopped working" and I'm using Windows 10.

strigoi1958
02-01-2017, 05:55 PM
Have you followed my previous steps? you will need to do them.

also in win 10 there is an xbox app you have to disable the game dvr as it uses resources and can crash games.

marco3440
02-14-2017, 03:33 PM
the problem is when i go to the castle luxemburgo to sincronize.wen i was here the game stop literally and say ACU STOPEED WORKING. i talk to ubi support and for now i havent recived an answer.. help please

strigoi1958
02-15-2017, 12:03 AM
Hi marco it helps if you post your pc specs. I read some people had this problem but after they completed sequence 6 they could go to locations that caused problems.

WendysBrioche
02-18-2017, 02:35 AM
I don't know if you're having the same problem I've had, but if using an Nvidia card, updating to a new driver without uninstalling the previous driver first can cause crashes in games.

Try looking for your nvidia graphics driver in your control panel under uninstall a program, uninstall both it and GeForce Experience, restart, re-install GeForce Experience from Nvidia's website, then install the new graphics card Nvidia drivers fresh.

dedekpetr
02-18-2017, 07:21 PM
Laptops are not officially supported and your laptop is below the minimum recommended spec. For a laptop, yours is quite good but the i7 4700HQ is slower than the minimum i5 2500k plus the GTX 850M performance is below the gtx 680. I think it might still run but the demand on your laptop is huge, especially if you go to anywhere that has a lot of detail or crowds. If it crashes in the same places it might that your laptop is struggling. Unity does't have problems, when it launched it had a few minor glitches but no game breaking bugs, people were upset because of the requirement specs but the games is so huge it needs a powerful pc to run.

As LasseThid asked is there a message? Acu.exe has stopped working ... or something similar?
What windows are you using? 7, 8, 10?

Anyway, possible fixes.

make sure your laptop is not overheating, I bought a laptop cooler with fans built in that my laptop sits on. It has stopped lots of crashes in games and programs.

Find the Acu.exe and delete it then verify your game files so it downloads again and checks for damaged files.
turn off all background tasks, (antivirus and anything else you do not need to be running) your cpu needs all it's power just for the game.

if you have geforce experience uninstall it, it uses a lot of cpu resources and it can cause games to crash

Make sure you have .Net Framework 3.5 and 4.0 installed. for 3.5, go to Programs and Features and click on Turn on/off windows features on the left, select .Net Framework 3.5 checkboxes and then press ok, for 4.0, download it from Microsoft website.
.

Hey,

thanks for the tips. Well I went through them all and Acu.exe is still crashing. I've tried to delete it and reinstall twice but doesn't help.

Any more ideas where could be the problem, the game uses around 70% of my CPU. So I set all the details to LOW. Still.... :/
I run on Windows 10

Thanks

Peca

strigoi1958
02-19-2017, 12:17 AM
Hi DedekPetr what is your PC spec please... if it is a laptop or below minimum requirements it may be possible to run it at a lower resolution maybe 1280 x 720