PDA

View Full Version : Ridiculously low FPS on Assassin's Creed 1



TTD187
01-15-2017, 09:40 PM
This is killing me and I have no idea what to do!

I really want to play through these games again, but the information is too sparse. So many people have issues either with low FPS or even running the game but no fixes, so here I am on Ubi's site asking for help.

I installed this game on Steam and found that I can only get a maximum of 40 frames per second by turning down all settings, but this was only in the menus and it would eventually drop down to the standard 13 FPS. When actually trying to game, I seem to only manage 7 FPS. Because of this, I decided that I've got a Uplay version of the game, so I redeemed and installed that and exactly the same problem. I have absolutely no idea what's going on, but it really is giving me a headache.

Spec:

GTX 770
Intel Core i5-4690k
8GB RAM
Windows 10 Anniversary.

Anyone have any pointers?

GhostAssassinLT
01-15-2017, 10:17 PM
I have no idea why you would get such low fps. I completed the game a couple of weeks ago and I'm getting a steady 60 fps with V-Sync on.
I know some people have to run the game in compatibility mode or as an administrator. Have you tried that?
Also what is your setting for V-Sync and are you running the Dx9 or Dx10 version?
Is your game installed on the system drive or on a different drive? I know this has been an issue for some.

I have an i7-6700k, Z170-A mobo, 16 Gb of RAM, a GTX 970 and I'm using Windows 10 Professional.

prspilot
01-23-2017, 10:13 PM
This is killing me and I have no idea what to do!

I really want to play through these games again, but the information is too sparse. So many people have issues either with low FPS or even running the game but no fixes, so here I am on Ubi's site asking for help.

I installed this game on Steam and found that I can only get a maximum of 40 frames per second by turning down all settings, but this was only in the menus and it would eventually drop down to the standard 13 FPS. When actually trying to game, I seem to only manage 7 FPS. Because of this, I decided that I've got a Uplay version of the game, so I redeemed and installed that and exactly the same problem. I have absolutely no idea what's going on, but it really is giving me a headache.

Spec:

GTX 770
Intel Core i5-4690k
8GB RAM
Windows 10 Anniversary.

Anyone have any pointers?



I am having the same issue with Unity. I reinstalled it a few days ago. Played the first night with everything turned up at 60fps with v-sync. Now, I get 60fps in the inital load screen with the ubisoft symbol. when it hits the main menu, i drop to 15fps. In game, even if i turn everything down I only get 5-15fps tops. I know my rig can handle this, since i played for hours at 60fps. no idea whats causing it. My drivers are current, and my specs are:

fx-8350 amd
16gb RAM
GTX 770 - 4GB VRAM
Windows 10 Home Edition

Dr.GGerm
01-23-2017, 10:44 PM
Due to a recent update on Windows 10 many users had FPS problems in many games......The update is about the Game DVR functionality included in the Xbox app that allows us to record videos and make screenshots in our games.

Apparently, since the Anniversary Update was released, this app always stays in the background even though we are not using it, capturing clips of our games (or any application that uses the graphics card), in anticipation that we want to save them.

To deactivate this functionality, first you need to:

-Open the Xbox app that you canl find in the start menu and log in with your Microsoft account

-Once the app is open, click on Settings (the gear on the left side), and then enter the Game DVR tab.

-Here you only need to deactivate the option "Record game clips and screenshots with Game DVR".

If for some reason you don't have a microsoft account (and can't access this feature) here is another method:

-Open the registry by opening the start menu and typing "regedit". It is RECOMMENDED that you make a backup of the registry in "File" and "Export" in case something happens (not my case).

-Navigate to "HKEY_CURRENT_USER" -> "System" -> "GameConfigStore" and set the value of "GameDVR_Enabled" to 0.

-Navigate to "HKEY_LOCAL_MACHINE" -> "SOFTWARE" -> "Policies" -> "Microsoft" -> "Windows" and create a new key (right button, "New") named "GameDVR". Within this key creates a new 32-bit DWORD value that will be named "AllowgameDVR" and set it to 0.

Good Luck!

Dr.GGerm

GhostAssassinLT
01-24-2017, 07:08 PM
I don't have a Microsoft account on my computer as I feel that what I do on my computer is my business, not Microsofts and hence I've done my best to block them out.
Perhaps this is the reason I don't have this problem. :cool: