PDA

View Full Version : Assassin's Creed 3 has lag even if my PC good



Rindar6lod
12-16-2016, 05:34 PM
I have an ASUS AMD Radeon R9 270X ,16 gb of ram and an intel core i5 6500. The game lags everywhere. From what i understand, this problem is present only to AMD users because i have a friend that has a GTX 750ti and has no problem. Can someone provide me with a fix that can allow me to play the game with all the setting maxed out?

strigoi1958
12-16-2016, 07:24 PM
There are a few ways to speed games up, even running from an SSD drive will add FPS to some games. But if we want lots of performance AND lots of AMD or Nvidia settings that really really damage performance then we either need very very powerful PC's or we learn to adjust settings. 1 guy on here went from 40 FPS to 100 FPS by changing his AA.

Just setting things to Ultra and expecting our graphics card to make it run at a set FPS will not work for every game. You should lower your anti-aliasing and try different things. You would be surprised by how some settings look exactly the same or even better but they with greatly improve performance. :)

The only thing I can remember is that...
In your folder called MY DOCUMENTS is a folder assassin's creed III and in that is a configuration file called Assassin's creed3.
Make a back up copy of it.
Then open it the file, look for the line that starts MonitorDesc= if it says MonitorDesc\\:\bmfiosdl sosotdGMb Benq xdl,w325w3095fjs.s45 (or just a lot of letters and numbers.... )change it so it now says
MonitorDesc=Generic PnP Monitor

For some reason it will give you a few more fps maybe 5 to 10 but it is far better to adjust settings.

I posted in one thread where 2 titan x in sli only got 84 FPS in batman arkham city because it had MSAA x8 setting it to x4 it jumped to over 150 FPS and the image was just as good. :)

Lignjoslav
12-17-2016, 12:55 AM
The only thing I can think of is checking for Vsync and disabling it if it's on. Other than that, game should run reasonably well. At the time of release, I played it on an all-AMD PC: Phenom II X4 3.2GHz and Radeon 6950 2GB and it ran well at 1080p. It stuttered occasionally, but you can easily find people with i7s (and Nvidia) complaining about Boston harbor area, it's just the way the game is, not really that well optimized.

T00l0nglyf
12-30-2016, 01:47 AM
The only thing I can think of is checking for Vsync and disabling it if it's on. Other than that, game should run reasonably well. At the time of release, I played it on an all-AMD PC: Phenom II X4 3.2GHz and Radeon 6950 2GB and it ran well at 1080p. It stuttered occasionally, but you can easily find people with i7s (and Nvidia) complaining about Boston harbor area, it's just the way the game is, not really that well optimized.

I have a Phenom x3 720 12gb ram with radeon radeon rx 280. I definitely have a good enough PC but I only get 4FPS, no kidding.
I tried playing with compatibility mode, disabling high dpi + set admin.
Also set display to Generic PnP something and even copied all info from assassin3mp.ini to assassin3.ini.
Setting resolution to 800x600. I verified the files in Uplay.
Everything gets me 4FPS and below.

I just don't know what to do anymore.

Lignjoslav
12-30-2016, 12:28 PM
That's not normal at all. Like I mentioned, when the game was released, I played it relatively fine on a Phenom II X4 920 and Radeon 6950 2GB at 1080p. An extra CPU core doesn't make a difference in AC3 and your GPU is more powerful, so you would have to be fine. Do other games run normally?!

Can you check that your CPU is speeding up to its full frequency? If your framerate is the same no matter the graphics settings, it indicates a CPU bottleneck. You could use HWInfo to track your CPU clock speed (it also has the feature to display the info on screen while you are in game).

What OS are you using? If you are on Windows 10, have you disabled background recording in the Xbox app (apparently it's on even if you never used it). I had major problems with the new Deus Ex on my W10 (constant crashes in DX12 and frequent sudden pauses in DX11 mode), whereas in W7 (albeit in DX11), on the same system, the game ran fine. I disabled that feature in the Xbox app and the real time protection from the Windows Defender and there are no more crashes and the pauses are much rarer (sadly, because I did both at the same time, I'm not sure which one actually helped; also, the pauses aren't completely gone, so it still runs better on W7).

T00l0nglyf
12-31-2016, 04:00 AM
Thanks for the tips. I am on Windows 10. I disabled xbox dvr feature, what a weird thing to stay activated by default. Unfortunately it did not make any change. Windows defender was already deactivated. Changing game graphic settings did not change anything at all.
I ran HWInfo and found it even more bizarre. My cpu usage stays between 40 and 50% while my GPU usage is at 0%(with very sparse spikes at 80-90%) and 10% for GPU D3D usage

I clean re-installed my graphics driver and tried different settings without any success.
Playing other games goes very well and gpu usage goes up as we would except normally. A game I tried was Battlefield Hardline at 1080 with normal graphic settings, was getting 30 fps.

Now I'll try to install Win7 on another partition see if that works... Do you have any other ideas ?

Lignjoslav
12-31-2016, 12:51 PM
Hmm, bizarre! There is actually a bunch of results for 0% GPU usage, but nothing that looks like it has potential (some are Nvidia specific, in other cases, GPU usage was simply not being reported correctly, others suggest unlikely things like checking whether the monitor is actually plugged into the graphics card and not the motherboard).

I'd try a different driver version, if you haven't already. Specifically, I'd try these (http://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-Edition-16.11.5-Release-Notes.aspx). They are last month's and the user feedback I've seen is very positive. There are two newer versions that came out this month, but while some say they are fine, others claim that there are issues that may or may not be tied to a specific group of cards or a game or a new feature they just added, so the ones from last month seem like a safer bet.

T00l0nglyf
01-03-2017, 10:31 PM
I tried 16.11.5 without any difference. Since I had enough of this problem and you suggested Win7 might work, well I did and it worked. I installed the latest driver update, used the same installation of the game and it just ran smoothly.
Smooth as 26-27FPS at 1080 and about 18FPS in Boston but I'm fine with that. At least I can play.

I probably have some other strange underlying problem that might get resolved with a reset of win10 but I will probably update my PC in the near future which will force me to do so anyway.

Thanks for all your ideas.

ancalimonungol
03-17-2017, 03:33 AM
You do not have a strange underlying problem with your PC.

The game had been running between 20fps, 60fps on my old PC (it had a very fast 7970 graphics card and i7 3820 4.2ghz). Then I replaced the 7970 with a GTX 1070 but the game played the same and there was any improvement at all apart from being able to enable highest anti aliasing setting. The game ran at exactly the same fps everywhere. Then I got myself a 144hz gsync monitor and later when I tried this game again, some weird bug happened and character was not moving properly and textures were flickering all over the screen but the game was running between 90fps 144fps constantly everywhere. I tried restarting the game twice and on the second restart, the bug was no longer there but the game was still running at 80 90fps minimum at maximum details. The only bug I encountered was that the horse cart disappeared from time to time when moving at certain angles.

Then I built a new PC with my old 1080p hdtv monitor plugged to its intel onboard gpu. Later I plugged the 144hz Asus ROG PG279Q monitor that has gsync. And a problem appeared. on my old PC the monitors available refresh rates were 60hz 100hz 120hz 144hz while on my new PC there were also 24hz and 85hz options. Also the resolution option disappeared from the settings screen although I am still using the same monitor.

The PC has i7 7800k at 4.8ghz and 3200mhz 16gb DDR4 memory. (and gtx1070 from the old PC soon to be replaced with a GTX1080ti

Now the game is running between 25fps and 144fps. When looking at certain directions from certain places it lags like helll.

So it looks like the game has a huge problem. It detects something wrongly which results in this mess. I think it should be possible to run the game at full 60 or even 100hz using a mid range graphics card from back when the game was released. But they never fixed this stupid configuration bug.

It seems like the games "LOW FPS BUG" is related with monitors, how Windows records available refresh rates and how the game mixes refresh rates between monitors. Also it is not possible to edit and copy protect the ini file because then game defaults to minimum configuration.

Like I said I was somehow able improve the games performance from 20fps to 90fps on the same computer with a new monitor.

The game run at 20fps using a Samsung T22C350 HDTV monitor as main monitor and an old Samsung 1050p DVI monitor as secondary.
When I replaced the old DVI monitor with Asus ROG PG279Q, suddenly the game was 80 ~ 90fps minimum.

Here is the first time the bug happened when I first got my 144hz gsync monitor:
https://www.youtube.com/watch?v=35ZTL-IL31w

This happened twice and the third time I started the game, it was running like a dream at 80fps minimum whereas it was running at 30fps at the same place before.

ancalimonungol
03-17-2017, 02:01 PM
I tried 16.11.5 without any difference. Since I had enough of this problem and you suggested Win7 might work, well I did and it worked. I installed the latest driver update, used the same installation of the game and it just ran smoothly.
Smooth as 26-27FPS at 1080 and about 18FPS in Boston but I'm fine with that. At least I can play.

I probably have some other strange underlying problem that might get resolved with a reset of win10 but I will probably update my PC in the near future which will force me to do so anyway.

Thanks for all your ideas.

See my other post for the definitive fix and tell us if it also works for you.

http://forums.ubi.com/showthread.php/738298-Assassin-s-Creed-3-is-unplayable-Very-low-FPS?p=12466277&viewfull=1#post12466277

Stellock
03-24-2017, 05:37 PM
I have an ASUS AMD Radeon R9 270X ,16 gb of ram and an intel core i5 6500. The game lags everywhere. From what i understand, this problem is present only to AMD users because i have a friend that has a GTX 750ti and has no problem. Can someone provide me with a fix that can allow me to play the game with all the setting maxed out?

When i first played Assassin's creed 3 on 750 ti, it ran smoothly(50-60 FPS). But later after 2 years(after several updates of the driver) it was running the game at 10-40 fps.
If u want to play the game, install the standard(old) driver(for now) u got with the graphics card and then u wont have any problem running the game.
It might be the same problem with the other nvidia gpus. So give it a try.
Enjoy!!

Stellock
03-24-2017, 05:39 PM
When i first played Assassin's creed 3 on 750 ti, it ran smoothly(50-60 FPS). But later after 2 years(after several updates of the driver) it was running the game at 10-40 fps.
If u want to play the game, install the standard(old) driver(for now) u got with the graphics card and then u wont have any problem running the game.
It might be the same problem with the other nvidia gpus. So give it a try.
Enjoy!!