PDA

View Full Version : PC Far Cry 3 Blood Dragon - Never Started, not working.



sbaffini
12-05-2016, 06:45 PM
Hi all,

I've never managed to have Far Cry 3 Blood Dragon starting at all. Looking through the forums I read I had to disinstall both the game and Uplay, so I did and reinstalled the lot but that didn't work either.
If I click on the game's icon, it runs Uplay then flashes a DOS window then Uplay starts, a splash screen appears the vanishes and that's it.
Pressing on "PLAY" just doesn't do anything apart from flashing a splash screen and the mentioned DOS window.

Does anybody have any idea on what the problem could be ?

Thank you !

B0rjk4
12-05-2016, 09:25 PM
I have the same problem :nonchalance:

yxusyxus
12-05-2016, 10:48 PM
also, the same problem...:(

UbiVertigo
12-09-2016, 01:07 AM
Hey all, please check the steps listed on this post (http://ubi.li/zutqe). If that doesn't fix the issue for you, let me know.

sundark.ssh
12-09-2016, 11:17 AM
Hey all, please check the steps listed on this post (http://ubi.li/zutqe). If that doesn't fix the issue for you, let me know.

Hello, I've tried the steps mention, but it didn't work :\

sbaffini
12-09-2016, 12:01 PM
Hey all, please check the steps listed on this post (http://ubi.li/zutqe). If that doesn't fix the issue for you, let me know.

Hello.

It's working now. Thanks a lot. Fix definately not easy to find.....

Cheers

UbiVertigo
12-09-2016, 10:52 PM
Hello, I've tried the steps mention, but it didn't work :\

Hey sundark.ssh - are you getting an error message, or is the game immediately shutting down when you try to launch it? I'm trying to make sure you're having the same issue.


Hello.

It's working now. Thanks a lot. Fix definately not easy to find.....

Cheers

Glad it's working! Sorry that the info was hidden.

sundark.ssh
12-12-2016, 07:21 AM
Hey sundark.ssh - are you getting an error message, or is the game immediately shutting down when you try to launch it? I'm trying to make sure you're having the same issue.

What happens now is that the splash screen opens, but the game never starts.

UbiVertigo
12-15-2016, 11:14 PM
What happens now is that the splash screen opens, but the game never starts.

Thanks sundark.ssh – Please contact our support team (http://support.ubi.com) and let them know the issue and the steps you’ve taken. I recommend attaching your MSinfo (https://support.ubi.com/en-gb/faqs/000021216/Sending-a-msinfo-report-to-Support) file to the ticket.