PDA

View Full Version : Frames per second performance is broken and 4k is not optimized/Texture Popping



WhiskeyOmega
12-04-2016, 04:50 PM
Not sure if this is just me however I have found the game unplayable at 4k as it only plays at 30-40fps which isnt great for this type of game. I have found the difference from 1440p to 4k in performance to be massive when it really should not be. I goto to start the game in 1440p and run the benchmark I get a good 82fps avg in that bench. However if I change to 4k I get 30fps in the same bench however If i go back to 1440p and do the same bench again I now get 60fps avg.

Now I would like to run 4k however its 30fps and ive found the textures to be popping in the frame which isnt at all good for a snowboarding game since the trees wouldnt be textured properly until ive flown past them. I this could be down to a VRAM issue but I play alot of games in 4k and never seen this kind of popping and extremely slow performance . Im not sure if the textures are just 1440p or there is a general problem with the graphics in 4k but i find 1440p to look better as well as giving me the 60fps thats needed.

I run a 4930k at 5Ghz
32GB G.Skill 2400mhz ram
2 x GTX 970 G1 Gaming in SLI

SaddleBags69
12-04-2016, 07:19 PM
LOL. Optimized it is absolutely not. You are right. I've posted very similar stuff with awesome hardware and clean software. JUST REJOICE! For your money is gone, and life moves on.

SaddleBags69
12-05-2016, 04:49 AM
I dont think they respond to people who took the time to write out detailed issues. Theyre just cruisin for the easy bruisin. I feel so cold inside.