PDA

View Full Version : Lost Archive problem



Crazybone992
07-08-2016, 02:46 PM
I have a serious problem with The Lost Archive dlc for AC: Revelations. I bought it in 2012 but now I can't play it anymore because I lost all backups of the installation file for reasons that were beyond my control and the download links on my email don't work anymore. I can't get it from Uplay shop either because the dlc has been removed from Uplay shop and it just redirects me to the store front page. I have already contacted Ubi support about it and sent them a screenshot of the receipt to prove I have bought it. I post this in here too just in case. It just sucks I can't play a legitimately purchased dlc anymore. Ubi support has got to do something to help me. Because if they don't, my faith in Ubisoft is gone forever.

Hope it won't take them 5 weeks to answer me this time.

Crazybone992
07-08-2016, 04:55 PM
After installing patch 1.03 for Revelations, the game crashes on launch. This is because of the fact that I still have the save file for The Lost Archive dlc, but I can't install the dlc due to the missing install file. And apparently the game believes I have it installed, causing a conflict in the game files and making it crash. I tried to fix it by deleting the Uplay software and manually reinstalling it. It didn't work and it pisses me off I did it for nothing. But luckily, I found another workaround: I deleted all Revelations save files and disabled cloud sync for saves. Now the game starts again. I now have to play with cloud sync disabled until a solution is found (or alternatively start a new game from scratch.)

Black_Widow9
07-10-2016, 03:14 AM
Please hang on and let Support troubleshoot this with you.

Crazybone992
07-14-2016, 12:26 AM
Please hang on and let Support troubleshoot this with you.

Support is being really slow again. They say I should receive a reply within 48 hours but it's been 4 days now.

SixKeys
07-14-2016, 07:09 AM
After installing patch 1.03 for Revelations, the game crashes on launch. This is because of the fact that I still have the save file for The Lost Archive dlc, but I can't install the dlc due to the missing install file. And apparently the game believes I have it installed, causing a conflict in the game files and making it crash. I tried to fix it by deleting the Uplay software and manually reinstalling it. It didn't work and it pisses me off I did it for nothing. But luckily, I found another workaround: I deleted all Revelations save files and disabled cloud sync for saves. Now the game starts again. I now have to play with cloud sync disabled until a solution is found (or alternatively start a new game from scratch.)

Cloud sync has always been a pain in Uplay, TBH. Some players have reported losing progress due to cloud sync. I recommend playing without it at all times, you don't really need it.

WintWolf
07-19-2016, 11:50 AM
I spent a couple months in dialog with Support about Lost Archive’s installation and their last official answer was: “Sorry but you cant install Lost Archive DLC on current Uplay version this game. You must find main game installer compatible with Lost Archive or play game without this DLC”. This is really shame that Ubisoft not support this DLC anymore and don’t care about users that bought it long time ago.

Crazybone992
07-19-2016, 11:27 PM
I spent a couple months in dialog with Support about Lost Archive’s installation and their last official answer was: “Sorry but you cant install Lost Archive DLC on current Uplay version this game. You must find main game installer compatible with Lost Archive or play game without this DLC”. This is really shame that Ubisoft not support this DLC anymore and don’t care about users that bought it long time ago.

Great. This here is another proof that Ubisoft cares about making money more than helping their customers. I love Ubisoft's games but I don't like Ubisoft as a Company because of **** like this.

ancalimonungol
08-04-2016, 01:29 PM
I can see Lost Archive in the DLC tab in Uplay but it does not say "owned" it says "buy". Is there a way to fix this?

ancalimonungol
08-15-2016, 05:51 PM
I tried activating the cdkey inside UPlay once again and it got activated and installed.