PDA

View Full Version : PC Bug - Echo #2 April Kelleher, does not register.



JeanFeedo
04-02-2016, 01:19 AM
When I try to collect April Kelleher echo #2, it doesnt allow me to do so.

I can launch the echo, but it doesnt offer me to "register" it.
I launched the game several times, doesnt solve it.
I tried to randomly press "F" everywhere inside the echo - doesnt work either.

It's the only echo I miss, so it would be a shame to miss the achievement because of a bug :D

atom0s
04-02-2016, 01:34 AM
You can collect all the intel without problems. Some of the echos do have bugs currently that make them not disappear from your map to collect, but they do count. I have everything collected and have 3 Echos still showing on my map due to the bugs.

JeanFeedo
04-02-2016, 01:56 AM
but that's the problem, it doesnt collect it. I can activate it, and usually I've to press "F" to collect it and validate it.
On this one, the "F" doesnt happen once the echo is live. So I'm still at 62/63 even if the echo is on.

http://puu.sh/o2KSR/ffdf2a9c4d.jpg

JeanFeedo
04-02-2016, 01:57 AM
http://puu.sh/o2L6X/6283d4350b.jpg

JeanFeedo
04-02-2016, 12:58 PM
I tried on a friend's map, still not working.

My friend got it registered instantly, so you dont need to press "F" on this one.

Meaning it's bugged with my character.... I need a fix :(

JeanFeedo
04-05-2016, 04:40 PM
Help :( so frustrating !

atom0s
04-09-2016, 06:31 AM
The game counts it regardless of not showing it collected at the time. You can check in the evidence menu that it is collected. It is one of a few bugged ECHOs that are all broken in the same manner. You can still collect the full 293? pieces of evidence without issue.