PDA

View Full Version : PC Uplay is unable to start your download



slasso93
03-08-2016, 06:19 AM
I preloaded the divison a few days ago through the uplay client. It said 'preloaded' until the servers went live. Now it says 'download' and if I click download it says "Uplay is unable to start your download. Check that you have an active internet connection and sufficient space on your hard drive then try again." It's under my installed games already. Why is it telling me to download it and why won't the download it wants me to do work?

Darkmanno
03-08-2016, 07:17 AM
Same here

slasso93
03-08-2016, 07:25 AM
I have tried disabling firewall, allowing inbound connections through rules, allowing apps windows settings, etc. It just doesn't work.

avL.Mau
03-08-2016, 07:46 AM
Im having the same issue

Yakkoni
03-08-2016, 07:49 AM
yeah same here.. wtf is going on !

silencer124
03-08-2016, 08:01 AM
their are other people downloading the game as you are...thus uplay is being flooded.

Halororor
03-08-2016, 08:38 AM
When I hit Download it simply launches the game, doesn't start the update at all. Can't verify game files either because there is no properties tab available.

This really sucks.

JoeSchlock
03-08-2016, 09:19 AM
Same here. I uninstalled and re-installed the game (thank god for fast internet connections ;)) and now it works.

Quinnsten
03-08-2016, 09:33 AM
Same here :(