PDA

View Full Version : PC "Far Cry 3 Has Stopped working"



DarkdevilZz13
03-06-2016, 02:22 PM
When I launch Far Cry 3 from Steam it always gets me back to my desktop telling me "far Cry 3 has stopped working",at my far cry properties at steam it always tells me that im missing one file!Please help me! I really love this game and I cant play it ! I dont know if I've done something wrong,but if I've done im sorry and I promise not to do it again!...Just.......Please......Help me :'(

Agent_G4MR
03-08-2016, 10:43 AM
Hey there,

i had the same issue and tried to find what could cause that problem. In my case the bad and evil error was the tablet service. You might try to stop that and start the game.

Open the task manager, go to the tab services, find tabletinputservice... and stop this service. Try to start FC3 again and lets hope for the best. In my case it worked.

Best regards. :)

TheMouseIsDown
03-10-2016, 10:22 PM
My computer is a desktop and I do not have a touch screen monitor, so the tabletinputservice in Windows 10 was already off/disabled by default and not running.

The fix I found on the forums that worked was to set the file FC3updaterSteam.exe that is located in the Far Cry 3\bin folder to use Windows 7 compatibility. Game launched like a charm for me after that.

sidneydcurry
05-22-2016, 05:33 PM
My computer is a desktop and I do not have a touch screen monitor, so the tabletinputservice in Windows 10 was already off/disabled by default and not running.

The fix I found on the forums that worked was to set the file FC3updaterSteam.exe that is located in the Far Cry 3\bin folder to use Windows 7 compatibility. Game launched like a charm for me after that.

I tried to change the FC3updater file to compatibillty mode but when I pull up the property menu it doesn't show the tap any ideas as to why