View Full Version : Farcry Primal won't run after splash

03-05-2016, 05:24 AM
I recently purchased this game yesterday with high hopes to dive into the world of Far Cry like I had many time before with previous games in the series, however, to my dismay I was unable to load the game past the splash window and it's frustrated me to no end. I've tried every single fix I can think of other than reinstalling the game but everywhere I've seen has said that doesn't work and I'm not willing to waste my time on the off chance that it won't. I am livid to say the least. I essentially spent sixty dollars for the splash screen and nothing else. This isn't okay. Everywhere I looked has claimed that this ONLY happens with Ubisoft games. I've been a long time supporter of Ubisoft and everything they've done but if my first experience on PC with their games is this bad I don't plan on continuing to buy their games.

(things I've done)
Ran as administrator
Switched compatibility mode
Updated my NVIDIA drivers
Tried running with uplay on offline mode
(No I don't have dual monitors so that fix method is irrelevant.)

03-05-2016, 06:54 PM
So am I just not going to get any assistance or?

03-05-2016, 08:03 PM
have you tried to uninstall Uplay

then download Uplay from the Uplay website and reinstall it ?

also what Hardware are you trying to run the game on .. if you have an Nvidia GPU have you tried to open Nvidia geforce experience and disable Shadow play ?
there was a bug with the recent drivers that affected some users and cause FarCry 3, FarCry blood dragon as well as FarCry 4 to just crash on launch if shadow play was enabled . this driver problem mainly affected users with Windows 10 i think ..and began with Driver version 361.75 ..the most recent driver 362.00 even says there are no Fixed issue's in the driver , so it may still be a bug with shadow play for some users ..make sure shadow play = disabled in geforce experience

if your running windows 7 are you sure Service Pak 1 is installed ... this game will probably need it since SP1 is kinda old .. it came out over 5 years ago
and added alot to wiin 7 as far as the .net stuff

have you tried to re run the Microsoft software that the game needs to launch

if you look in your Primal game folder you will find a sub folder called support \ software

try reinstalling the needed Microsoft run-times from there for
Direct X
and Visual C++

a guy on the steam forums said he fixed his too by booting into safe mode with network connection
tried to connect by launching Uplay ..then rebooted into normal windows mode and it worked (and downloaded an update ..??)
(i dunno if he meant a game update or a uplay launcher one .....he never specified )

also what type of CPU do you have ?

is it a dual core or a quad core ?

FarCry 4 i know would not launch at all on a dual core CPU .. .you had to have a CPU with at least 4 cores or threads
the minimum ones in the Primal system requirements do all have at least 4 cores or threads

so it may be a problem again for people with straight up dual core CPU's like the haswell G series Pentiums ?

03-05-2016, 08:19 PM
also see this post and make sure none of the services mentioned are being blocked by your antivirus or firewall


and disable any and all backround applications

FarCry 4 used the same engine as this game and it had problems launching with the following applications running for some users...
you may need to disable them or reconfigure them



C. Riva Tuner Statistics Server

D. DXtory

E. Motionin Joy

F. Anti Virus or Firewall software (AVG , Comodo, Bullguard etc.. <-- check settings)

G. MSI true Color

H. Evolve gameing client

I. AMD Raptr \ AMD Gaming Evolved

J. TeamViewer

K. Overwolf

03-06-2016, 07:37 AM
As of currently I just tried the following:

Uninstalling Uplay and reinstalling
Checked to see if Shadowplay was enabled (it wasn't)
Checked compatibility pack to see if it was pak 1 (it wasn't, still didn't work once switched.)
Turned off my firewall temporarily to see if it was possible that someone was being blocked, still no change.

In the support folder within primal's folder I see the following programs:
Game Launcher
Microsoft.NET Framework 4

As far as my CPU goes, I have a intel i5 quad core.

03-06-2016, 09:29 AM
dunno why everyone is having problems with it .....wish ya luck solving it

i bought the Uplay only version from Green man gaming the day it shipped for only $39.99

i already had a Uplay account and an up to date version of Uplay installed (since i play FarCry 3 & 4 alot \ have all the FarCry games on Steam )

i put in the cd key .. activated the game .. down loaded it ......and it started right up

never had to touch any of my files or anything

running Win 10 Pro 64 bit (clean install after upgrade )

i shut off all the silly metro apps in win 10 back when i installed it in August 2015 on my SSD drive + shut off the Xbox app and disabled tablet and input service (since that messed with FarCry 3 )

then installed classic shell so my menu's look like Windows 7 again

Windows firewall says its running i never made any change to it
using Avast Antivirus + malware bytes (free version )

i already set Steam as well as Uplay to launch as run as administrator for FarCry 3 & 4

and my system is older then dirt
Asus P5 B mother board
Intel Core 2 quad Q6600 overclocked to 3Ghz
8 gig of ram
2 PNY SSD drives
Asus Strix GTX 960 (still running Nvidia driver version 359.06 from December (since it was the last driver asus posted for my card )
OLD Creative Labs SB LIVE 24 bit Sound card
23.6 inch Acer monitor + 40 Inch HD TV

when i installed my Nvidia drivers i used DDU to clear out my old drivers , and then did a custom install of my video drivers without geforce experience or the 3d vison stuff like i normally do , only installed
1.the video driver with the control panel
2.HDMI audio

then checked the box that said perform a clean install

i never install or use Geforce experience since it set my games up wrong in the past
and the 3d vision portion of the Nvidia drivers i never install as you need a 3d monitor as well as the Nvidia 3d vision Glasses and kit to use it

sorry my suggestions didn't help ya out man

dunno what the problem could be unless its blocked some how from activating in your router or modem DNS or windows hosts or maybe an ISP problem ?? .. i do think i enabled port forwarding for all the FarCry 4 and Uplay ports in my cable modem (its an internet gateway \ wireless router + cable modem ) last year when i played co op with my nephew ..but i never made any other changes for Primal

wish ya luck in getting it to work .. its a pretty decent game

06-27-2016, 08:44 AM
hi guys just try this simple fix worked for me 100%

06-27-2016, 03:47 PM
Hey Friends,
I have found the solution of Far Cry Primal Not Starting. This solution is 100% working. :cool::cool::o
Visit This link for more information www.ramdomgames.com/far-cry-primal-not-starting-pc/

07-04-2016, 07:18 AM
I've had that problem... It seems I don't have it when I start Steam in offline mode, then connect to the internet so I don't have any problems with Uplay.

Other background programs don't seem to make any difference as far as I can tell.