View Full Version : Main Menu accepts no mouse or keyboard input

03-01-2016, 11:12 AM
I am posting to report a game-breaking bug, and to seek a solution to the problem that myself, and several others are having. There are at least 5 people reporting this issue over on the Steam forums, and I am quite sure many more will come forward.

The issue, as is briefly mentioned in the Subject header above, is that the game seemingly accepts zero input attempts. I say "seemingly", because certain keyboard functions still operate, such as Alt-Tab, and Alt-F4. No other keybvoard or Mouse input is represented in the game. Upon launch, the splash screen displays, and the main game loads fine. It passes through each of the intro animations and lands on the main menu. From this point, the game is essentially a brick. It sits with all animations running, including "news" items on the right...but nothing can be selected via keyboard or mouse.

I have tried the following procedures to attempt a workaround for the issue...none have proven successful.

-Disable my Firewall/AV software
-Disable Steam Overlay UI
-Disable UPlay Overlay UI
-Changing to all resolutions from native 1440, down to 1080
-Updating my video drivers

I have also sought an editable config file for the game to see if I could change some video modes that might operate in some type of Borderless Windowed mode that pulls me out of Fullscreen. I was unsuccessful in locating one, and am fairly confident that one doesn't exist.

Any help on this would be appreciated.

03-01-2016, 11:17 AM
Hi there, epicdesign,

Welcome to the forum!

Do you have any other peripherals plugged in other than your keyboard and mouse such as a joystick or a driving wheel?

If so can you remove them to see if this is what is causing the conflict?


03-01-2016, 11:25 AM
Hi there, epicdesign,

Welcome to the forum!

Do you have any other peripherals plugged in other than your keyboard and mouse such as a joystick or a driving wheel?

If so can you remove them to see if this is what is causing the conflict?


You are exactly on track. I will repost a reply received on the other thread from the Steam forums via user Honk Dog:

"I was having the same issue just now, but removing my PS4 controller from my paired Bluetooth devices seems to have fixed it. So give that a try if you haven't. If you don't have a wireless PS4 controller paired through Bluetooth then I don't know, sorry.

Super... super dumb issue, Ubisoft."

I also had a PS4 controller paired over Bluetooth, but it was not powered on during all of my failed attempts to get past this issue. Once I unpaired the controller, I relaunched the game and everything seems to operate in the menu as expected. Mouse and Keyboard controls are responding. However, I cannot yet confirm whether full bindings are operational, as I've also noted other users reporting an odd issue with mis-binded keys and controls...like a Mouse button inadvertently controlling walking or strafing. I can report back about that after I've tested the game itself.

For now, the unbinding procedure seems to be working. I hope I won't have an issue later trying to re-pair my controller to the computer. I remember it took many failed attempts to finally complete the pairing process.

03-01-2016, 11:28 AM
Thanks for the information!

If the issue returns please let me know. I'm forwarding this information on to the team.

Your cooperation is very much appreciated!

03-01-2016, 11:30 AM
My pleasure. I know it can be tough for devs and support teams to troubleshoot zero-day bugs and just wanted to provide as much detail as I could.

03-01-2016, 11:32 AM
One more note, a kind thank you for your quick response. I did get a little chuckle when I noticed most of the....loud....threads being ignored, however I received a nice timely response here...lol. Thanks for that. ;)

03-01-2016, 11:55 AM
Further testing, and some details you may wish to pass on to your team.

I re-paired the PS4 controller with the computer to see if I could still replicate the problem. As expected, the Keyboard and Mouse controls were unresponsive. This time however, I entered the game with my PS4 controller on and connected. While I had no KB or Mouse control, the PS4 controller DID work. Even more interestingly, once I entered the Options menu to seek a configuration for a "Default Controlling Device", I went to the Keyboard & Mouse sub-menu and attempted to use the Mouse. Strangely enough, they worked! So apparently if a tertiary game control device is attached, the game ignores the KB&M until the tertiary device has been used.

From here, it was down to testing the Bluetooth itself, so I closed the game, and instead of Unpairing the PS4 controller, I chose to simply disable the Bluetooth adapter temporarily. As far as the Windows sub-system was concerned, no controller was listed or available. Upon relaunching the game, full control was obtained via the KB & M.

I think from all of this, it appears that the game is failing to accept input from any device that is not a game controller if one is connected, until said control device is actually used, and then it will allow input from the standard devices.

I hope this all helps!

03-01-2016, 11:57 AM
Hi again,

Thanks for this! This should help us with the investigation of the issue on our end!

03-02-2016, 01:04 AM

I have exactly the same issues then Epicdesign.
No mouse cursor is visible on the screen menu and I can not scroll down through the different options with the keyboard.
Lone thing I can do in the main menu is Alt-Tab

ONLY my keyboard and my mouse are usb plugged.

I've tried the same procedures he mentioned but without success.

Any advices? Thanks in advance

03-02-2016, 09:59 PM
Upped as I still have this "no cursor" on main menu issue

03-02-2016, 11:22 PM
I have solved the issue by myself and I now have the damn cursor.

It worked on Windows 10:
Go to Settings -> Peripherics (bluetooth, printers and mouse menu) -> Connected devices -> I've removed "generic usb joystick"

Hope it will work for you...until the next bug

06-27-2016, 02:35 AM
I'm seeing the same issue i.e. Keyboard and Mouse not responsive with Far Cry Primal on Windows 10 with a Dualshock 4 controller connection over bluetooth.

This is rather shocking as Far Cry 4 worked perfectly with the same controller + keyboard and mouse!

Please fix this devs! First AAA game that gets broken with a controller connected!

10-16-2016, 04:16 PM
Tengo el mismo problema..

11-10-2016, 05:30 PM
I am reporting the same issue, i have plugged in my mouse+keyboard and my g27 wheel, and the game won't recognize the mouse and keyboard. I have tried unplugging the wheel, but the problem remains the same.

11-30-2016, 01:06 AM
Also having the same issue. DualShock 4 controller connected, no input registering. Wow, 9 months and apparently no fix, so I doubt one will come now.