View Full Version : Subtitles failed to show after the first two lines or so of dialogues with NPCs

03-01-2016, 11:11 AM
Subtitles are vital for me, for immersion, following whats going on when talking with NPCs as I m Deaf.

I understand that theres a proto gibberish language used by NPCs/tribes, however as I had played on my son Xbox One version of Far Cry Primal, so I knows there English subtitles all the way through.

Upon playing the first hour or so of PC version, the only problem I encountered was the missing subtitles, after seeing it at the start. I tried toggling the subtitles in options but still doesn't do anything. Whenever I get into cutscenes with NPCs, subtitles just don't show at all.

I hope this will be fixed, as I have no intension to continue without having access to dialogues.

03-01-2016, 11:15 AM
Hi there, DEAF6E0RDIE,

Welcome to the forum!

Can you try verifying the game files in the Uplay Client?

Did you restart the game at any point during the hour you played to see if the issue persisted when reloading your save?

03-01-2016, 11:51 AM
Thanks for the quick reply

I did restart the whole game couple of times to see if it would help. its doesn't.

Also restarting the game by writing over the save with new game, I would like to correct myself. Subtitles actually only shows up during the cave painting narrating sequences, but after that, Mammoth hunting onwards zero presence of subtitles.

I bought the game via Steam, keycodes validated via UPlay. Just finished verifying the cache there with Steam client, 100% verified all files validated. Restarted the game but reset everything to default including the graphic settings. Which was previously on ultra with custom shadows set to very high instead of ultra to maintain frame rates.

Then opted for new game for the third time today, same issue. The game shows subtitles at start at cave paintings then once in game for mammoth hunting with Dalso and onwards to getting green herbs for Sayla. No subtitles.

I encountered no other bugs. I m not keen to keep trying as want to keep option for Steam refund as now showing 96 minutes played.

Any other suggestion?

03-01-2016, 12:03 PM
Sorry to hear the issue persists.

Can you try changing the game's language to see if subtitles come up in any other language?

If they do can you then switch the game back to English to see if this prompts them to reappear?

I'll have this information forwarded on to the team.

03-01-2016, 12:24 PM
Did as suggested above.

Changed the language to Spanish, the subtitles shows up only during cave painting narrating then nothing during game, mammoth hunt, Dalso dying words, nothing.

I installed latest driver, Geforce 970 and my i7 PC doesn't struggle to run the game at all, frame rates 60 per sec, ultra setting its averaged 50 fps.

I even switched off Steam overlay in case the client was conflicting with UPlay.

Still nothing. I m aware the dialogues with NPCs only represented a small part of the game but its make me feel part of it, otherwise its would feel just a random generating procedural quests without clear purposes other than knowing its a quest for defend, kill, hunt and so on. No story or characters.

Will hold off on the refund for the game until notified of a possible solution.

03-01-2016, 03:20 PM

Successfully got refund from Steam, as I m not prepared to wait god know how long for subtitles issue to be resolved and also where my chance for refund is cutting it close with over 100 minutes spent trying to get subtitles to work after initial few minutes of play.

I may reconsider getting the game at a later date, its apparent that the bugs squashing will take up a lot of time and accessibility may not take immediate response.

Disappointed as the impression was very good with lush visuals.