PDA

View Full Version : Sudden FPS drop since today??



siralex1986
12-02-2015, 02:20 PM
I was playing just fine until today, I even played a bit this morning without noticing any issue but when I tried to run the game during lunch time it was running at about 10fps, it was unplayable.

The recent patch was already downloaded, there were no other updates going on, I was running the game only on the PC and restarting it didn't work.

Before that I was playing with everything maxed, SweetFX and even a few Nvidia Control Center settings boosted at 50/55FPS so I really don't understand what's going on.

Performances just dropped down suddenly and unexpectedly, with no apparent reasons as I played just fine with the exact same PC, the exact same settings, the exact game version and the exact CPU usage(meaning I was not running anything else on the PC) only a few hours ago, with the PC being switched off meanwhile.

Anyone else experiencing the same issue?? What can I do????

EDIT: I know it's not related to my specs since I played fine for about 30 hours, but still:

8GB GDDR5; NVIDIA GTX 980M (N16E-GX)
2.60 GHz (up to 3.5) Intel Mobile Core i7-6700HQ (Skylake)
Ram 16gb

YazX_
12-02-2015, 02:37 PM
do you happen to have MSI Afterburner or any other OC softwares ?!

if yes, you need to reapply the profile you have since sometimes the GPU works at 30% of its power, so enable RTSS and monitor GPU usage and see if its the case, this happens when installing a new driver while you have one of these applications opened, i always reapply the OC profile after installing new drivers.

siralex1986
12-02-2015, 02:49 PM
do you happen to have MSI Afterburner or any other OC softwares ?!

if yes, you need to reapply the profile you have since sometimes the GPU works at 30% of its power, so enable RTSS and monitor GPU usage and see if its the case, this happens when installing a new driver while you have one of these applications opened, i always reapply the OC profile after installing new drivers.

Hey there, sorry for the double thread!

I have no softwares like those installed, the only program related to games, preformances and such is Nvidia Control Center; the laptop is brand new, like a week old, so I just installed a few games and nothing else!

The laptop is a Eurocom so there shouldn't be anything like the MSI stuff..

YazX_
12-02-2015, 03:10 PM
Hey there, sorry for the double thread!

I have no softwares like those installed, the only program related to games, preformances and such is Nvidia Control Center; the laptop is brand new, like a week old, so I just installed a few games and nothing else!

The laptop is a Eurocom so there shouldn't be anything like the MSI stuff..

ok then please install MSI AfterBurner or RTSS and monitor GPU usage and report back so we can see if the problem is from GPU not working 100%.

siralex1986
12-02-2015, 03:21 PM
ok then please install MSI AfterBurner or RTSS and monitor GPU usage and report back so we can see if the problem is from GPU not working 100%.

Alright, I can install some MSI software even on a non-MSI machine, right? It's independent from the PC brand?

I'll test it later!

symbiontreza69
12-02-2015, 05:09 PM
This is my system specs:
i5 4590 3.3 ghz
Ati R9 270 2gig
8 gig of ram
I also have the latest graphic update installed on my system
When i start syndicate it was really smooth...but now in London i have lag and fps drop regularly during the game...it's really suffering.
Even in low setting i have this **** problem
Anyone can help?

siralex1986
12-02-2015, 06:04 PM
Same situation, since today.

http://forums.ubi.com/showthread.php/1343088-Sudden-FPS-drop-since-today

YazX_
12-02-2015, 06:11 PM
Alright, I can install some MSI software even on a non-MSI machine, right? It's independent from the PC brand?

I'll test it later!

Yes you can, it works with all video cards, another thing to try is to open Nvidia Control Panel and check Power Management property and set it to "Prefer Maximum Performance" if its not set, also check power plans in windows and change it to high performance.


Same situation, since today.

http://forums.ubi.com/showthread.php/1343088-Sudden-FPS-drop-since-today

I merged both threads as no need to create multiple threads for the same issue by other members :)

siralex1986
12-02-2015, 06:14 PM
Alright, I checked and the CPU usage flows from 20% to 70%, RAM at 5750.

YazX_
12-02-2015, 09:17 PM
Alright, I checked and the CPU usage flows from 20% to 70%, RAM at 5750.

i meant GPU (Video Card Processor) not CPU and what about GPU frequency??

did you try to create a profile in MSI AfterBurner and apply it?

did you change the power plan in windows and Nvidia Control Panel?

siralex1986
12-03-2015, 12:13 PM
i meant GPU (Video Card Processor) not CPU and what about GPU frequency??

did you try to create a profile in MSI AfterBurner and apply it?

did you change the power plan in windows and Nvidia Control Panel?

Oh, I actually had that info too but I forgot to report here, will check again later.

Nope, didn't create any MSI profile or changed power plans...

Odd enough, game runs just fine on my home PC, which has a Radeon R290 Sapphire though...

blackroseMD1
12-03-2015, 09:24 PM
I've been experiencing pretty frequent FPS drops (sometimes as low as 25 FPS) since the new patch as well, both on the Nvidia ACS Game Ready 359.00 drivers and the new 359.06 drivers. Before the patch the game was running between 45 and 60 FPS at all times, aside from a single FPS drop to 39 frames in the initial loading screen. I'm running SLI Gigabyte G1 970s. Looking at GPU usage, it looks like each GPU is being used at about 70%.

I've got Windows power plan set on high performance and Nvidia control panel set to "Prefer Maximum Performance".

Like I said, I wasn't seeing these kind of drops before the patch, so I'm definitely leaning towards it being an issue that the patch introduced.

Specs:
FX-8350 4.0 Ghz
16 GB DDR3 1333
Gigabyte GTX 970 G1 Gaming x2 in SLI
1920x1080 Resolution

YazX_
12-03-2015, 09:26 PM
I've been experiencing pretty frequent FPS drops (sometimes as low as 25 FPS) since the new patch as well, both on the Nvidia ACS Game Ready 359.00 drivers and the new 359.06 drivers. Before the patch the game was running between 45 and 60 FPS at all times, aside from a single FPS drop to 39 frames in the initial loading screen. I'm running SLI Gigabyte G1 970s. Looking at GPU usage, it looks like each GPU is being used at about 70%.

I've got Windows power plan set on high performance and Nvidia control panel set to "Prefer Maximum Performance".

Like I said, I wasn't seeing these kind of drops before the patch, so I'm definitely leaning towards it being an issue that the patch introduced.

Specs:
FX-8350 4.0 Ghz
16 GB DDR3 1333
Gigabyte GTX 970 G1 Gaming x2 in SLI
1920x1080 Resolution

disable SLI since the SLI profile provided by Nvidia is not optimized and is not scaling well on both cards, there is a specific thread for this issue on AC Technical Support board.

blackroseMD1
12-03-2015, 09:46 PM
disable SLI since the SLI profile provided by Nvidia is not optimized and is not scaling well on both cards, there is a specific thread for this issue on AC Technical Support board.

Thanks. I'll check it out.

Gox420
01-02-2017, 10:18 PM
I am having the same issue since the patch .

I have nvidia gtx980 x2 and asus power supply it shouldnt be this kind of drops..