PDA

View Full Version : Assassin's Creed IV doesnt' launch.



pitx_89
11-28-2015, 11:40 PM
I bought the game in Steam. When I launch the game in Steam, it opens Uplay and Uplay opens the game, but it is in background and I can't play.

This bug is really anoying. I cached the game files in Steam, I unistalled Uplay and reinstall, reboot the PC and the game doesn't launch. It always is in backgroud.

Ubisoft fix this ****ing bug please or I will ask for a refund.

I expect a solution.

UbiSmarmy
11-29-2015, 12:01 AM
Welcome to the forums pitx_89, sorry that you're having this issue.

My first suggestion would be to disable in-game overlay for supported games. You can do this through the Uplay Game Launcher, just go to the menu button (the three little horizontal lines in the upper left hand corner of the Launcher) and then choose the "General" tab. From here just make sure that there isn't a check mark next to "Enable in-game overlay for supported games" and that should resolve the issue.
http://i.imgur.com/AK4xdhK.png
An example of what you should look for.

If that doesn't work try verifying the game files in Steam. You can do this by right-clicking the game title in your Game Library and then go to Properties. This will search the game's files to find any corrupt ones and replace them with not corrupt ones.

And if that doesn't work then please contact Ubisoft Support (https://support.ubi.com/en-US/index) for more in-depth support.

pitx_89
11-29-2015, 03:19 PM
Welcome to the forums pitx_89, sorry that you're having this issue.

My first suggestion would be to disable in-game overlay for supported games. You can do this through the Uplay Game Launcher, just go to the menu button (the three little horizontal lines in the upper left hand corner of the Launcher) and then choose the "General" tab. From here just make sure that there isn't a check mark next to "Enable in-game overlay for supported games" and that should resolve the issue.
http://i.imgur.com/AK4xdhK.png
An example of what you should look for.

If that doesn't work try verifying the game files in Steam. You can do this by right-clicking the game title in your Game Library and then go to Properties. This will search the game's files to find any corrupt ones and replace them with not corrupt ones.

And if that doesn't work then please contact Ubisoft Support (https://support.ubi.com/en-US/index) for more in-depth support.

It doesn't work. :(

Waiting for another solutions.

YazX_
11-29-2015, 04:53 PM
1. Delete this folder:

Documents\Assassin's Creed IV Black Flag

2. Launch game, if its still in background, then close game and go to the folder above again and open file Assassin4.ini

find WindowMode=X (where X is the value)

and change it to WindowMode=1

Also check these values are correct( where X is the value):

DisplayWidth=X
DisplayHeight=X
DisplayableRefreshRate=X

if still it doesnt get in foreground, then there is some program stealing focus from the game, disable all OSD, recording, OC,... softwares and try again.

pitx_89
11-29-2015, 09:47 PM
1. Delete this folder:

Documents\Assassin's Creed IV Black Flag

2. Launch game, if its still in background, then close game and go to the folder above again and open file Assassin4.ini

find WindowMode=X (where X is the value)

and change it to WindowMode=1

Also check these values are correct( where X is the value):

DisplayWidth=X
DisplayHeight=X
DisplayableRefreshRate=X

if still it doesnt get in foreground, then there is some program stealing focus from the game, disable all OSD, recording, OC,... softwares and try again.

I have got a gaming laptop. I installed the game on it, and It works, but in the desktop computer, it doesn't works. Now I can't try to run the game on my PC. I will try your solution several weeks later. Sorry.

My Desktop Computer:

CPU: i5 750 2.67 GHz
GPU: GTX 480
RAM: 8 gigas

pitx_89
12-18-2015, 11:50 PM
1. Delete this folder:

Documents\Assassin's Creed IV Black Flag

2. Launch game, if its still in background, then close game and go to the folder above again and open file Assassin4.ini

find WindowMode=X (where X is the value)

and change it to WindowMode=1

Also check these values are correct( where X is the value):

DisplayWidth=X
DisplayHeight=X
DisplayableRefreshRate=X

if still it doesnt get in foreground, then there is some program stealing focus from the game, disable all OSD, recording, OC,... softwares and try again.

Sorry for delay in my answer. I try your solution, but It doesn't work. Game stay in background. I find the file Assassin's Creed IV Black Flag.ini, but it didn't contain the variable WindowMode=1. I write this variable and try it again, but the game is still in backgroud.

I stopped Evga Precision, but the game is always in backgroud. I haven't got more external programs, it is a new operating system clean install.

I hope a solution. :(

YazX_
12-18-2015, 11:53 PM
Sorry for delay in my answer. I try your solution, but It doesn't work. Game stay in background. I find the file Assassin's Creed IV Black Flag.ini, but it didn't contain the variable WindowMode=1. I write this variable and try it again, but the game is still in backgroud.

I hope a solution. :(

The file name is Assassin4.ini and its located here:

C:\Users\[YOUR_USER_NAME]\Documents\Assassin's Creed IV Black Flag


Close UPlay from tray then run it as admin.

pitx_89
12-19-2015, 03:38 PM
The file name is Assassin4.ini and its located here:

C:\Users\[YOUR_USER_NAME]\Documents\Assassin's Creed IV Black Flag


Close UPlay from tray then run it as admin.

Yes, I edit the correct file, and I run as admin, and It doesn't work.


Welcome to the forums pitx_89, sorry that you're having this issue.

My first suggestion would be to disable in-game overlay for supported games. You can do this through the Uplay Game Launcher, just go to the menu button (the three little horizontal lines in the upper left hand corner of the Launcher) and then choose the "General" tab. From here just make sure that there isn't a check mark next to "Enable in-game overlay for supported games" and that should resolve the issue.
http://i.imgur.com/AK4xdhK.png
An example of what you should look for.

If that doesn't work try verifying the game files in Steam. You can do this by right-clicking the game title in your Game Library and then go to Properties. This will search the game's files to find any corrupt ones and replace them with not corrupt ones.

And if that doesn't work then please contact Ubisoft Support (https://support.ubi.com/en-US/index) for more in-depth support.

It doesn't work, I wait a solution. :(

UbiSmarmy
12-19-2015, 11:34 PM
Sorry to hear that you're still encountering this issue. Since you've tried those steps please try contacting Ubisoft Support (https://support.ubi.com/en-US/index) for more in-depth help to resolve the problem.