PDA

View Full Version : Multiplayer bugs



Sebbern_
09-30-2015, 05:37 PM
1: While playing multiplayer, if a player(player 1) enters combat while another player(player 2) is currently choosing between quick combat or manual combat. Player 2 will instead be stuck in an "opponent currently in battle" screen while the progress bar is stuck on 0%, even when player 1's battle has finished.

Player 2 will also hear sounds from his own battle, and not anything from player 1's battle. Something that tells me that the battles either started at the same time, or player 1's battle ended, and player 2 simply never got out of the indefinite battle screen and into his own battle.

Player 1 and player 2 are written to recognize which player I am talking about.

2: In a multiplayer game, if another player is currently in battle and you try to change your settings. The options menu will continuously close itself, and remain on your screen until the battle is over.

Sebbern_
09-30-2015, 07:31 PM
3: HUGE BUG: If I host a map that has the letter "Ø" (probably any special letters) in its file name, the online game browser will stop working for other players. I tried creating a randomly generated snow map with 7 players and an underground that had the filename "Snømap01.umap" And whenever I host the map in an online multiplayer match, others' lobby browser will stop working, as in no lobbies show up.

Sebbern_
10-03-2015, 10:27 PM
4: In a battle, if a creature is the last creature to do an action on a turn and it moves to another hex, if the creature then is the first creature to do an action on the next turn, the hex grid will not be corresponding with the location of the unit. So the hex grid will be showing the creatures available movement from the previous turn, when it was on a previous hex.

The only ways to fix this in-game currently is to use your hero's attack, or a spell. One can also use the wait function to delay the creatures turn.