PDA

View Full Version : Noble Tempest Airstrike Broken - Can't Play Campaign



Sophex93
09-24-2015, 06:00 AM
I'll cut right to the chase. The Noble Tempest mission is broken in the fact that once I get to the VIP in the shipping container, go through the three shooting gallery set pieces and get to the point where I am supposed to call in an airstrike, I can't do anything at all. The game prompts you to hold down whatever key you have assigned to your airstrike before the timer runs out, for me it was on 4 originally, but when I hold it down nothing happens and the timer just reaches zero and I die and have to restart from the checkpoint. I have searched for hours online trying to find a solution to this and have come up with nothing.
I have rebound the action countless times to a number of different keys and nothing works. I've tried using a different mouse, pressed and held down every single key on my keyboard one at a time regardless of whether it was assigned to the airstrike or not. Nothing. As it stands I cannot move through the rest of the campaign at all, which is completely unacceptable for a game I paid for. If anyone knows about this issue and can provide a fix, please for the love of my sanity, help me out. I was enjoying this game quite a lot until I ran into this issue, and now I'm just ready to throw my computer at the wall.

Tengg-Eri
09-24-2015, 08:00 PM
get a friend... play this mission in coop
try to be a host, if not
let the friend be a host