PDA

View Full Version : AC Unity Crashing Issue



WelshyUK82
09-20-2015, 11:54 AM
So I finally got around to finishing Black Flag a couple of days ago.
I ran all the settings on the highest and it looked and ran great!

Now with AC Unity... Every time I try and play it, the game just closes after about 10 minutes of gameplay.

I've tried:
* Reinstalling (3 times)
* "Delete the .exe and get Uplay to verify the files" (which just made Uplay crash and I had to wipe and install that again)
* Lots of graphics settings and found a list of additional settings to add to the ACU.ini
* Playing in "Offline" mode

My Specs:
Intel i5 3470
16GB Ram
Nvidia GTX 970


Is there anything else I can try before I just give up, delete Uplay and forget about it?
After the hair pulling over the past few days. I'm fine with just writing off the games I've got on Uplay.

Thanks

Ozgoroth.
09-20-2015, 12:27 PM
Have yout tried turning uplay in game overlay off? Also if u are using Precision X or any similar monitoring program with overlay try to turn it off.

strigoi1958
09-20-2015, 12:56 PM
I tend to leave ini files alone... as Ozgoroth has pointed out 3rd party software can conflict with Uplay... your system is great I had a 970 and Unity looked amazing even though I prefer setting below max... FXAA and SSAO.

I'm assuming you've run a good antivirus and malwarebytes anti malware.
I had a few driver problems in the past (I still use Nvidia) one caused artifacts on the screen and discolouration the other affected the card temperature and it ran hot... which made it shut down...
I would try a different driver and use Wagnards DDU (display driver uninstaller) Nvidia leaves data and overwrites data even on clean installs and it is known to cause problems Wagnards DDU (google it) removes everything... (make sure you download the other driver first before running it :D.

Hope this works.

WelshyUK82
09-20-2015, 06:39 PM
Thanks for the quick replies guys!

I've tried all the suggestions and it's still crashing.

The game uses almost all of my CPU (80% when just standing still) and crashes when it can't use anymore.


There's no faults with my hardware as it all works great on other games I play. It's just an issue with playing Unity :(

Thanks again for your help

Ozgoroth.
09-20-2015, 06:48 PM
Does the game utilize all your CPU cores equally? If not try changing affinity in task manager --> details --> acu.exe --> affinity and disabling and renabling CPU 0 (disable CPU 0 , press ok , go to affinity again and enable CPU 0) .

WelshyUK82
09-20-2015, 07:26 PM
Does the game utilize all your CPU cores equally? If not try changing affinity in task manager --> details --> acu.exe --> affinity and disabling and renabling CPU 0 (disable CPU 0 , press ok , go to affinity again and enable CPU 0) .

No change after doing that unfortunately.

Thanks

WelshyUK82
09-21-2015, 08:49 PM
So I had a reply off Ubi$oft


As you have mentioned that you are trying to run the game on Windows 10 which I am sorry to say is not supported for Assassin's Creed: Unity.

So all previous (and much older) Assassin's Creed games run great on Windows 10 but newer Unity doesn't and their "get out" is to blame it on the OS.

Great customer support Ubi!

strigoi1958
09-21-2015, 11:28 PM
I am playing Unity right now on win 10... It isn't officially supported.. I didn't know that.

Win 10 has given me quite a few headaches... it sets itself up as the primary administrator and randomly blocks things I try to do even though I set myself as an administrator as well... I had problems with port forwarding on 1 game, it blocked my connection :(

It blocked my downloads and said I do not have permission and it shut down a few times and refused to boot up my system on several occasions ... I've been to the microsoft community and at first they blamed the z170 chipset but that changed to probably Asus boards (do you have an Asus mobo?) ....

I like win 10 and it offers us dx12 so I'm prepared to stay with it through these problems 1 thing is important though....

You must go to System, advance system settings, Hardware, device installation settings and select "never install driver software from windows updates" it will save you a lot of game related problems...

WelshyUK82
09-21-2015, 11:48 PM
I like Windows 10. It's a hell of a lot better than 7 or 8.1 (in my opinion anyway)
I turned off lots of "features" when I installed in (including the auto driver install)

This is the first game in years that I've had an issue playing. I'd recently finished playing Black Flag which ran great on my machine.
I can play most games on their highest settings with pretty good FPS and low CPU usage.

I had wanted to buy Rouge and Syndicate but I don't think I'll risk it now :(

strigoi1958
09-21-2015, 11:58 PM
I would imagine black flag did run great on your system... it's a bit of a beast pc :D..

If it runs on mine and starts on yours then it should run... there's something that either conflicts or closes it down... do you have any software that monitors temperatures ? As I mentined before 1 driver let my gpu run hot and I guess the system would shut down any demanding software to protect the gpu from burning out...

jonathan7882
09-22-2015, 01:37 AM
So I had a reply off Ubi$oft



So all previous (and much older) Assassin's Creed games run great on Windows 10 but newer Unity doesn't and their "get out" is to blame it on the OS.

Great customer support Ubi! Curious here states different. https://www.microsoft.com/en-us/windows/compatibility/CompatCenter/ProductDetailsViewer?Name=Assassin%27s%20Creed%20U nity&vendor=Ubisoft&Locale=1033%2C2057%2C3081%2C4105%2C16393&BreadCrumbPath=Assassin%27s%20creed&LastSearchTerm=Assassin%2527s%2Bcreed&Type=Software&tempOsid=Windows%2010 I would say most older titles aren't officially compatible. However Unity seems to work fine on my Win 10 I haven't done more than test yet but I'll let you know once I officially start.
Hey guys found this! Hope it helps.
http://steamcommunity.com/app/289650/discussions/0/541907675762107709/

strigoi1958
09-22-2015, 01:59 AM
ah yes audio driver... my realtek drivers crash farcry 4 after a few minutes... I disabled the realtek device and use my turtle beach headset and farcry 4 work perfect

ste7en26
09-22-2015, 02:35 PM
I have exactly the same problems: Win 10, GTX980Ti, 16GB RAM, Core i7.

After a few minutes AC:U just crashes back to desktop. All other games work perfectly and without crashes.

I've tried a million things and all workarounds I could find, but sadly without luck. The xaudio thing isn't working for me either.

When will Ubisoft release a patch for this annoying situation?? How can they still sell this game in it's current buggy form?? :mad:

strigoi1958
09-22-2015, 03:37 PM
I have exactly the same problems: Win 10, GTX980Ti, 16GB RAM, Core i7.

After a few minutes AC:U just crashes back to desktop. All other games work perfectly and without crashes.

I've tried a million things and all workarounds I could find, but sadly without luck. The xaudio thing isn't working for me either.

When will Ubisoft release a patch for this annoying situation?? How can they still sell this game in it's current buggy form?? :mad:

I have a skylake i7 6700k system also with gtx 980 ti and I'm on sequence 10 at the moment so Unity obviously plays and runs as I started this replay from the start on this PC. I also played hundreds of hours using it on win 7, Unity is brilliant.

There is something on your PC that is conflicting with Unity.

It may be a driver, but it is 99% certain it isn't Unity. Unfortunately win 10 is new and in a buggy state and judging by the Microsoft community even MS are confused by some event errors and are unsure how to fix them and have taken a "wait and see" approach to see if users find solutions.

As I already said, Realtek drivers crashed Farcry 4 for me... I found that solution on google. It may take some trial and error by disabling things but when it stops the conflict and it runs then your card will show Unity how it is supposed to be seen.

ste7en26
09-23-2015, 09:53 AM
Hmmm.. I also use Realtek audio (+ 5.1 HDMI audio to my A/V receiver). But this is one thing I haven't tried so far. Maybe I should disable the onboard (Realtek) audio completely in the BIOS and then try again..

Thanks for the tip.. I report back if it helps..

strigoi1958
09-24-2015, 03:20 AM
Strangely today... Unity and Farcry 4 plus another steam game crashed after a few minutes. I know some games do not like Nvidia shadowplay so I went to geforce experience to make sure it was off... while there I noticed a new driver was available. Knowing win 10 is very temperamental about drivers.... anyway I updated my driver and just to be certain, I did a clean install and didn't install the 3d items.... then I uninstalled geforce experience and all games work again.


(I used driverpack solutions online to update my drivers before and that fixed many win 10 problems... if you use it, untick the 4 programs it tries to install)

Jessigirl2013
09-25-2015, 07:09 PM
Same here.
I played ACBF on high, But Unity is a unplayable mess.

It just does show that Unity is a big step up...

... Well that.. or its a badly programmed mess.;)

ste7en26
09-29-2015, 09:34 AM
YESSS!

Disabling the Realtek onboard sound (ALC892) in Windows device manager fixed the crashing of ACU so far (3 days and counting)!!! I'm using HDMI audio to an A/V receiver anyway..

I've wasted many many hours to find this out, thanks Ubisoft for this special gift:mad:. It would be interesting to know if all affected users have Realtek audio and if Creative audiocards/drivers are also affected.

OK, Ubisoft... now that you know what the cause of the crashing is, you can make a patch for ACU!

Win10 Pro, Intel Core i7-4790, 16 GB RAM, Asus Z87-C mainboard, NVidia GTX980Ti

strigoi1958
09-29-2015, 12:09 PM
It is a win 10 problem not a Ubi problem... win 10 also has a problem with our Asus motherboards and I don't expect Asus (or Ubi) to fix win 10's problems with the event errors that it has with Asus products. I understand you are angry but you're angry at the wrong people.

Jessigirl2013
09-29-2015, 06:14 PM
It is a win 10 problem not a Ubi problem... win 10 also has a problem with our Asus motherboards and I don't expect Asus (or Ubi) to fix win 10's problems with the event errors that it has with Asus products. I understand you are angry but you're angry at the wrong people.

Yikes my new system has a Asus MB....

Should I be worried. :confused:

I agree it is a OS issue and you should contact Microsoft not UBI :rolleyes:

legendvinu
09-30-2015, 07:49 AM
So I finally got around to finishing Black Flag a couple of days ago.
I ran all the settings on the highest and it looked and ran great!

Now with AC Unity... Every time I try and play it, the game just closes after about 10 minutes of gameplay.

I've tried:
* Reinstalling (3 times)
* "Delete the .exe and get Uplay to verify the files" (which just made Uplay crash and I had to wipe and install that again)
* Lots of graphics settings and found a list of additional settings to add to the ACU.ini
* Playing in "Offline" mode

My Specs:
Intel i5 3470
16GB Ram
Nvidia GTX 970


Is there anything else I can try before I just give up, delete Uplay and forget about it?
After the hair pulling over the past few days. I'm fine with just writing off the games I've got on Uplay.

Thanks

I had the same problem just run in high settings it will be running don't change any other setting only change the main setting to high others will automatically change then see the miracle it runs well and i am playing it 10th time:rolleyes:

Sneakablez
10-03-2015, 09:52 PM
YESSS!

Disabling the Realtek onboard sound (ALC892) in Windows device manager fixed the crashing of ACU so far (3 days and counting)!!! I'm using HDMI audio to an A/V receiver anyway..

I've wasted many many hours to find this out, thanks Ubisoft for this special gift:mad:. It would be interesting to know if all affected users have Realtek audio and if Creative audiocards/drivers are also affected.

OK, Ubisoft... now that you know what the cause of the crashing is, you can make a patch for ACU!

Win10 Pro, Intel Core i7-4790, 16 GB RAM, Asus Z87-C mainboard, NVidia GTX980Ti

So freaking right!

I was playing unity and it wont last 30mins and it crashes. I keep re-trying desperately for 5x despite the annoying struggle and the 5th crashed I said okay will read some forum complaints. And I read yours, disabling Realtek onboard sound (ALC892) does indeed work. 6th time I tried again and I played like near 2 hours without crashing until I just noticed the time getting late 3AM so I just quit the game myself and not crash quit!

PS: Thank you for the tip. I'm using official audio driver. Will try finding other sound driver or update that might work.

----------------------------------------------------------------------------------------

UPDATE 12 hrs later: Though disabling the audio device makes AC Unity not crash for hours it's not a solution to play without sound. Related solution I found is here http://steamcommunity.com/app/289650/discussions/0/528398719801921667/ which is related to xaudio2_7.dll though I didn't try this myself.

My log error below but it seems not about xaudio2_7.dll issue.

10/3/2015 9:52 PM Application Error
Faulting application name: ACU.exe, version: 0.0.0.0, time stamp: 0x54db5826

Faulting module name: ACU.exe, version: 0.0.0.0, time stamp: 0x54db5826
Exception code: 0xc0000005

Fault offset: 0x00000000025d41cd
Faulting process id: 0x1548

Faulting application start time: 0x01d0fe2518c8993b

Faulting application path: E:\_Games\_SteamLibrary\steamapps\common\Assassin' s Creed Unity\ACU.exe

Faulting module path: E:\_Games\_SteamLibrary\steamapps\common\Assassin' s Creed Unity\ACU.exe
Report Id: 038a726a-6a19-11e5-83bf-80fa5b0fd550

Faulting package full name:
Faulting package-relative application ID:

SOLUTION: I tried first re-installing the DirectX. And oddly it did work! It does not crash anymore every few minutes. Now, I can play for hours without crashing again and again. Just sharing. If this does not work for you then next could be try the xaudio2_7.dll solution.

strigoi1958
10-03-2015, 10:07 PM
Yikes my new system has a Asus MB....

Should I be worried. :confused:

I agree it is a OS issue and you should contact Microsoft not UBI :rolleyes:

For some reason asus mobo's cause 2 specific event errors with win 10 and searching MS community showed that a lot (if not all) asus mb owners have been getting these.. they don't seem to be doing anything bad... although random boots fail to find specific devices like my keyboard or mouse or any audio devices... but win 10 is new and constantly updating so I think it is a good OS and will sort itself out soon.

ASUS are a top make :D

at sneakablez21 if you had read my post below st7en26 you would see it is not a Ubi problem.

Sneakablez
10-03-2015, 10:15 PM
@strigoi1958
Definitely not a Win 10 Problem! ;)
Because I'm using Windows 8.1 and on Clevo Notebook. But disabling the realtek audio on the device manager indeed do the trick. But it's just odd playing without sound :/

To be honest, I never thought your idea will work. My audio driver works perfectly fine on other games without issue. I didn't realized it's what causing unity to always on crashing. I just tried your idea if it's true but it is true indeed...

jonathan7882
10-04-2015, 12:27 AM
It is a win 10 problem not a Ubi problem... win 10 also has a problem with our Asus motherboards and I don't expect Asus (or Ubi) to fix win 10's problems with the event errors that it has with Asus products. I understand you are angry but you're angry at the wrong people.

Really what problems? I have w Asus Maximus VII Hero MOBO and haven't had any win 10 issues(that I know of.)

strigoi1958
10-04-2015, 04:01 AM
there's a problem with win 8 and 10 that affects fast start up... which is why my bios came set with 2 delays... and there are 2 event errors that show up but I don't know if they cause any problems...

ste7en26
10-04-2015, 08:46 AM
So freaking right!

I was playing unity and it wont last 30mins and it crashes. I keep re-trying desperately for 5x despite the annoying struggle and the 5th crashed I said okay will read some forum complaints. And I read yours, disabling Realtek onboard sound (ALC892) does indeed work. 6th time I tried again and I played like near 2 hours without crashing until I just noticed the time getting late 3AM so I just quit the game myself and not crash quit!

The only problem is I don't have sound! As much as it works without sound, it's just really too boring. So this is game or sound choice? GOD PLEASE UBISOFT FIX IT. STOP MAKING MORE AC!


PS: Thank you for the tip. I'm using official audio driver. Will try finding other sound driver or update that might work.

Just use HDMI out on your graphics card and plug it into an TV or an A/V receiver (or an sound-capable monitor). You will get perfect 5.1/7.1 sound that way. You don't need a soundcard at all. NVidia audio has to be installed though (comes with GeForce drivers).

It's unbelievable that we had to come up with that solution (disabling Realtek audio) and not Ubisoft! Shame on you guys!

Cheers, S.

Sneakablez
10-04-2015, 10:33 AM
Well after 12hrs. Though disabling the audio device makes AC Unity not crash for hours it's not a solution I want to play without sound at all. Related solution I found is here http://steamcommunity.com/app/289650...8719801921667/ which is related to xaudio2_7.dll though I didn't try this myself.

SOLUTION: I tried first re-installing the DirectX. And oddly it did work! It does not crash anymore every few minutes. Now, I can play for hours without crashing again and again. Just sharing. If this does not work for you then next could be try the xaudio2_7.dll solution. Now still playing for 3hrs now.... well if it crashes again then will go try removing the xaudio2_7.dll solution.

jonathan7882
10-04-2015, 07:31 PM
there's a problem with win 8 and 10 that affects fast start up... which is why my bios came set with 2 delays... and there are 2 event errors that show up but I don't know if they cause any problems...

Really? My win 10 starts up in around 30 seconds.

strigoi1958
10-04-2015, 08:33 PM
yes mine takes around 20 seconds now but sometimes it is quicker and causes a small problem which requires a restart ... an M2 drive (like mine) can boot in 10 seconds or less but will almost certainly cause problems more regularly...

C08R4.sk
11-25-2015, 05:23 PM
My last experience, this problem (Far cry 3, Far cry 4, Assassins Creed crashed after 10-15min playing. Error module: xaudio2_7.dll) causing service: TabletInputService (Touch Keyboard and Handwriting Panel Service) in Windows 10 x64. Many players have this problem, maybe there is interference between Realtek HD audio and Touch Keyboard. This may help you. Disabling the service solves the problem finaly. Obviously it's a Microsoft problem, i wrote them and pls Ubisoft look at it because many players have same problems with this.

CaramellMeow
12-23-2016, 06:08 AM
YESSS!

Disabling the Realtek onboard sound (ALC892) in Windows device manager fixed the crashing of ACU so far (3 days and counting)!!! I'm using HDMI audio to an A/V receiver anyway..

I've wasted many many hours to find this out, thanks Ubisoft for this special gift:mad:. It would be interesting to know if all affected users have Realtek audio and if Creative audiocards/drivers are also affected.

OK, Ubisoft... now that you know what the cause of the crashing is, you can make a patch for ACU!

Win10 Pro, Intel Core i7-4790, 16 GB RAM, Asus Z87-C mainboard, NVidia GTX980Ti

how do u disable realtek onboard sound ?

strigoi1958
12-23-2016, 02:24 PM
it is in your device manager you go to audio or sound and you should see it just right click and select disable. It can be disabled permanently through the bios but it is not recommended as some other games or devices may use it.

naumaan
12-24-2016, 08:58 PM
I ve stopped playing unity and deleted it for a while from the system ... no need to waste time when i cant play it right

Echelon51
05-22-2017, 11:54 PM
Hey guys! Just wanna ask you one BIG question. Does ANYONE here knows how the hell to fix this annoying crashing...? I've tried everything listed here and nothing helps, game just crashes after a few minutes and that's it. It's not xaudio2_7 problem, neither disabling Realtek onboard sound, not any of the drivers, changing compability modes doesn't help, disabling TabletInputService doesn't work, changing any of the graphic settings is a waste of time...So i ask you, what is there to be done? Is it even possible this game could run normally?

strigoi1958
05-23-2017, 01:27 AM
Hi Echelon it would help if you posted your system specs please... because there are different fixes for different things.. there's no point us talking about nvidia or windows 7 if you are running wing 10 and an AMD system also do you have it on steam or just via uplay.... all information will help

Echelon51
05-23-2017, 09:31 AM
Sure, no problem.

MSI Z87-G43 GAMING
Intel Core i5 4670K
16GB Dual-Channel DDR3
4096MB ATI AMD Radeon R9 380
Realtek High Definition Audio
232GB Samsung SSD 850 EVO 250GB
931GB Western Digital WDC
1863GB Western Digital WDC
Windows10 64bit Pro Creators

The game was bought direct via Uplay, it runs smoothly at about 40-60 fps on very high, but the crashing is the problem i can't get rid off. Please help me if you can.

strigoi1958
05-23-2017, 01:39 PM
Well you have a very nice pc system :)

There are a few random possible solutions that I'm not sure if you may have tried or not...

I do not know too much about AMD cards (I think Lignjoslav is the person to give the best advice on this forum) but I had a friend with an R9 380 and he had crashing in just 2 games. when he went to the AMD form there were a lot of R9 380 users there with crashing problems. and 1 suggested running "clockblocker" I don't know what it does or how he used it but it stopped his crashes Also I believe that the Crimson 15..11.1 beta , was the most stable driver for the R9 380.

I assume you have disabled the game dvr in win 10 xbox app?
And you have set uplay and ACUexe to run as administrator

Echelon51
05-23-2017, 11:33 PM
Thanks, it's not that bad PC :) Perfect for running Unity, well, it should at least...
Alright, I've tried running Uplay and ACU as the administrator and it crashed after 5 minutes. I also turned off game dvr or gamemode and no luck.
So you think the problem could be in AMD Radeon cards? Come to think of it, I remember that Just Cause 2 was also crashing on my PC...But all other games worked and are working perfectly.

I've just tried this clockblocker. It maxes out all the clocks in the GPU, fixes them stable. At first, I could finally complete a mission that I couldn't do it before and I was starting to think that we've finally figured it out...but sadly it crashed after few minutes at the next viewpoint...
Any new ideas...?

strigoi1958
05-24-2017, 02:30 AM
did you install the crimson 1511.1 beta driver? it is supposed to be the driver that fixes most of the R9 380 crashes

Echelon51
05-24-2017, 11:15 AM
I've installed crimson drivers 15.11.1 beta and guess what...I just now synced all the viewpoints in the game and without a single crash! I've definetly couldn't done that before...so I think we just solved our problem, my problem and of many others :) But still I have to do more testing, longer gameplay to totaly confirm it's ok. For now, It's seems alright.
strigoi1958, I'd buy you a beer right now if I could ;) But a big THANK YOU will have to do ;)
And just because of AMD, I was frustrated for two weeks believing the game and my comp were broken and I've tried almost everything there is to do to fix this.

So, for all you guys who are having problems with crashing in this game, just install these drivers:
http://support.amd.com/en-us/kb-articles/Pages/November-30-hotfix.aspx

Hope it fixes for you ;)

strigoi1958
05-24-2017, 04:31 PM
You're welcome. Every time another AC fan plays an AC game it makes me happy to be part of the brotherhood :)

Echelon51
05-24-2017, 11:11 PM
Same here man :) I only hope it's gonna get easier with Rogue and Syndicate ;)