PDA

View Full Version : cant submit TECHNICAL TEST NON-DISCLOSURE AGREEMENT after i click the im older then17



smoker2012
09-19-2015, 07:08 AM
cant submit TECHNICAL TEST NON-DISCLOSURE AGREEMENT after i click the im older then 17 box its greyed out

Crono454
09-19-2015, 08:17 AM
Makes sure you scroll through the entire agreement, then submit lights up yellow

smoker2012
09-19-2015, 09:22 AM
Makes sure you scroll through the entire agreement, then submit lights up yellow

i did im a long time blizzard player always have to do that doesnt light up tho

Cortexian
09-19-2015, 09:52 AM
Make sure your browser isn't blocking anything like javascript or whatnot on that page. Try to force a cache refresh of the page by using Ctrl+F5 to refresh the page. Try clearing your browser cache and cookies then accessing the page again.

smoker2012
09-19-2015, 09:17 PM
Make sure your browser isn't blocking anything like javascript or whatnot on that page. Try to force a cache refresh of the page by using Ctrl+F5 to refresh the page. Try clearing your browser cache and cookies then accessing the page again.

its was chrome. had to use a diff web browser worked fine thx for your help tho

GIjut
09-20-2015, 04:38 PM
i was trying all morning!! I used chrome and then IE.. Had to use my cell phone to make it work!!

Black_Widow9
09-20-2015, 10:59 PM
If anyone is still having this issue-

Please follow the yellow “Register Now” button which will take you to another page showing the NDA (non-disclosure agreement). You will need to make sure you’ve done the following in order to be able to register.

You must read the NDA in its entirety prior to submitting the form.
The “Submit” button will not be enabled until you have scrolled through the full NDA text field.

At this point after you have completed the registration process, you should receive another email with information on how to access this test. Console players should receive a key to activate on their respective online store (Xbox Live Marketplace or PSN Store). For PC players, the test build should be automatically activated on their account.

If you're still having issues afterwards, please make sure to contact Ubisoft Support (https://support.ubi.com/) so they can troubleshoot it with you.

Rincewind40
09-21-2015, 06:10 PM
I had the same problem with Chrome but Microsoft Edge oddly worked fine