PDA

View Full Version : Essential with your servers: "go offline" button on login screen (it's gone)



RdJ1
09-18-2015, 10:53 PM
So your server weren't working a little earlier (happens way too often).

However, with the new client there is no easy way to go offline when login fails.

Let's compare how it used to work (good) and how it works now (bad) when the servers fail:

Old/good:
- Splash screen appears
- Within a second connection/login fails
- You get 3 buttons for: try again, go offline and I think the last one was for proxy settings
- You press go offline (client starts in offline mode)
- Play game
- When you think the servers work again you can press the go online button in the client

New/bad:
- Splash screen appears
- Takes multiple seconds to fail
- You get a login screen where your credentials are gone
- You have to press a little link to go to the settings
- Turn the "always start in offline mode" option on
- Go back to login screen
- Fill in your credentials (don't know what happens if you don't or fill them in wrongly, it can't check the server)
- Hit enter or the login button (client starts in offline mode)
- Play game
- When you think the servers work again you can press the go online button in the client menu
- However, you still have the "always start in offline mode" option on, so when you launch Uplay again, it will launch in offline mode, which you don't want. You have to go to menu -> settings and turn it off.

That's 11 steps were it was only 6. And permanently changing a setting to always start in offline mode just to go offline once is pure nonsense.

I think this is a rather critical mistake in the new client, since your servers tend to be offline quite a lot. Ideally, you finally fix your servers. They are way too unstable.

Otherwise, you should restore the old behavior ASAP (because the next server failure won't be far away). I think a lot of people don't actually know how to get into offline mode anymore with this ridiculous behavior and they won't be able to play games when the servers are out...