PDA

View Full Version : AC Initiates Not Registering AC:IV Multiplayer (Wii U)



phantomhero999
05-23-2015, 04:29 AM
Hey, I have already contacted Ubisoft Support about this and unfortunately, they couldn't help me. I was curious if anyone else was experiencing this issue and if they found a solution.

Basically, I leveled through multiplayer in Assassin's Creed IV: Black Flag up to 55 and then Prestige 1, but never received any progress updates on AC Initiates. I did receive updates for story and synchronization, but not multiplayer. I have this game for Wii U. I also have Asssassin's Creed III for Wii U and it updates multiplayer just fine on Initiates. IT is ONLY multiplayer in Assassin's Creed IV: Black Flag that has failed to update. If anyone else is experiencing this or has a solution, feel free to leave a reply.

Thanks.

phoenix-force411
05-23-2015, 06:05 AM
They hardly cared for the Wii U version. It comes at me at no surprise that your game is not syncing with Initiates.

phantomhero999
05-23-2015, 10:23 PM
It synchronized fine for the STORY and SYNCHRONIZATION parts of the game, but not the MUULTIPLAYER. And it's there I am confused.

X_xWolverinEx_X
05-24-2015, 05:51 AM
youre like the only guy in the world to buy it for the wii u mate dont bother trying to play multiplayer

phantomhero999
05-24-2015, 05:04 PM
Actually, the multiplayer servers for that game are still alive for both AC 3 and 4. I started the AC series on Wii U and hope that at some point Ubisoft will get this fixed for the whole Initiates thing going on in recent and future AC games.