PDA

View Full Version : Assassin's Creed: Rogue is destroying my pc. Thanks Ubi



Crazybone992
03-13-2015, 06:52 PM
My system specs:

GTX 660 1.5 gb vram
i7-3770 3,4 GHz
8 gb RAM

The game runs beautifully at maxed out settings between 50-60 fps. But when I pause the game and leave it untouched for 5 minutes, the game begins to lag so hard it eventually drops to 30 fps. And it spreads the lag to my entire computer. After playing Rogue some programs begin to crash when I open them and all my games lag like they're having a seizure. The only fix is to reboot the computer. AND THIS **** happens to me always when I leave Rogue paused for 5 minutes. WTF Ubisoft?!

Alphacos007
03-13-2015, 06:54 PM
Sorry but you're the only one who ever reported this glitch, so it's 99% chance that it's something wrong with your PC, not with the game itself.

Alias1001
03-13-2015, 07:33 PM
Sorry but you're the only one who ever reported this glitch, so it's 99% chance that it's something wrong with your PC, not with the game itself.

Actually me too. If I just go to the options menu / upgrades.. And go outside have a smoke and come back. It will stutter like mad if I use eagle vision or top speed in the Morrigan

A simple alt tab seems to fix the problem for me see if that helps you too.

AMD 8350 4.00ghz
EVGA GTX 970 FTW
16 gb ram

ryan8374
03-13-2015, 08:01 PM
Sorry but you're the only one who ever reported this glitch, so it's 99% chance that it's something wrong with your PC, not with the game itself.

...and who are you? Do you work for Ubisoft support? How would you know what anyone has reported? Not everyone comes to the forums to complain.

In fact, I myself am having some major problems with Rogue. I can't get into a sea battle without major stuttering and the framerate dropping to <1fps with a system that has no trouble running Unity in the highest settings.

Asus Maximus VII Hero
Core i7 4790K
32GB DDR3 RAM
Zotac GTX970

Crazybone992
03-13-2015, 09:31 PM
Seems to be an overheating issue of some sort. I noticed that a computer restart is not necessary. I just had to wait for some time on the windows desktop and everything started to work again. I resolved this by lowering my graphics settings. It stopped lagging but I still get very loud fan sounds when walking around the abstergo office. Strange, I don't get loud fan sounds when playing as Shay. As soon as I go to Abstergo, the fans start to spin at their maximum speed.

Lignjoslav
03-14-2015, 12:54 AM
+1 that it's overheating, Crazybone. If you can, try capping the game at 60fps. It's a known issue that has historically affected multiple games. What happens is that you go to the menu, it's undemanding so the framerate goes through the roof and the ROPs (render output unit) overheats.

Crazybone992
03-14-2015, 01:28 PM
+1 that it's overheating, Crazybone. If you can, try capping the game at 60fps. It's a known issue that has historically affected multiple games. What happens is that you go to the menu, it's undemanding so the framerate goes through the roof and the ROPs (render output unit) overheats.

Actually the frame rate never goes above 60. When the lag starts to happen, it begins to drop until it goes to 30 fps. If I wait in the pause menu for a longer time, it goes to low 20's. But it's definitely an overheating issue since lowering the graphics settings seems to help. And the fans don't spin loudly in the pause menu. They begin to make noise only when I walk around in The Abstergo building.