PDA

View Full Version : Assassin's Creed Rogue crashing on loadscreen.



Kanariekoe
03-12-2015, 05:04 PM
Hello Ubisoft.

First of all, great gameplay:) I love it!
But.. my game crashes at loadscreens. First it crashed on startup. Then I re-installed Rogue (and Uplay) multiple times, and that seemed to work.
After that the game crashes on a loadscreen after the Prologue. Again, multiple re-installs helped.
Now I'm at 6% progress and yes, the game crashes every single time I try to load. I can get to the mainscreen, but then when I load my savegame it crashes on loadscreen.
I dont want to re-install the game 3-5 times after every sequence or whatever. Also, now it installs the "additional components" (DirectX) everytime I launch the game, but I'm 100% sure my DirectX is up to date since microsoft tells me so.
Also I've updated every single driver on my system, and the recommended system requirements aren't the problem.
Tried every possible sollution I could find on the internet.
I never ever complain on forums, but I felt this needed a thread.
Please help me out.

jeffies04
03-12-2015, 05:40 PM
I had a problem very similar to this. It would get to the disclaimer and freeze.

It turned out to be a corrupt save file. I use Yaz's backup tool (search forums for it) that backs up my uPlay games every so many minutes while I play, so I just restored an earlier backup. Everything was fixed and it fine now. I think there's a little piece of code or something around 6-9% or at a location in the world that's causing it. Deleting that save file worked.

Hope that helps.

PS - I had also reinstalled like 4 times. Only thing that worked was rolling back/deleting my save file.

Kanariekoe
03-12-2015, 05:51 PM
Thanks for the reply:)

Yeah I found that savegames we're corrupt here and there on the forums.
But I had these crashes before the 6%, on 0% and let's say 2%, and re-installing ( while keeping savegames intact ) helped me out there.
So something tells me it's not the savegame that's corrupt.
Also, when I verify Rogue files it tells me that it found corrupt files and when I press "repair" it doesn't seem to do anything, it takes me to the download page, but it doesn't seem to download anything. No matter how many times i use this verifying, it keeps saying that it has found some corrupt files, and it doesn't say what files or how many.

Kanariekoe
03-12-2015, 08:11 PM
Well I guess I'll have to keep re-installing the game on every point it crashes.. seems to be the only thing that helps atm.
But on the bright side of it, the savefiles are all on the cloud :D so progress isn't lost.
haha

jeffies04
03-13-2015, 03:10 AM
I ran into that verify files thing too. I just stopped trying and once I restored my saves, everything was fine again.

I think the verify files is broken on Rogue.